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Preliminaries

Logging into the network

At Dover-Sherborn, you do not have Excel on your own computer. It is a shared
application on a network server computer. To work with programs during adult education
classes, you must begin each session by enterifig a user name and password.

Logging into the networ

The example screen appears when starting a computer. It will have the name of the last
user. You will probably need to change the User Name and then enter the adult ed
Password.

Students, who log in by name during the day, get a different, smaller, set of programs and
options. Please keep this page from being seen by students of the day school. All evening
class adults have the same password, but each User Name must be different.

o Find the User Name taped to the top of the computer monitor where you are and use
it.

o Use the mouse to point and click, placing the I-beam cursor into the appropriate
blank. You will need to put the cursor into the User Name blank. Delete the name that

is there. Type in the User Name found on the top of the computer monitor where you
are sitting.

o Do NOT change the word “gamma” in the Domain blank.

o Finish by clicking the OK button.
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Starting the Excel program

Start Excel from the icon on the Windows desktop screen (if the shortcut is present)...

or by using the Start Menu button...

to access the Programs group...

and finally click on the Microsoft Excel choice from the expanded programs menu list.

If it is installed on your computer (it isn’t on mine), you can start Excel from the
Microsoft Office Shortcut bar that I cannot illustrate here because, as I mentioned, I don’t
have it installed.
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Using Microsoft Excel

Entering Data

Numbers. That’s the reason for Microsoft Excel. Calculations, from simple to complex
are the center of the story, but Excel is more than a substitute for a hand-held calculator
or even an accountant’s adding machine with a tape.

Excel is the most popular of several programs collectively called spreadsheets. The term
originates in accounting where a large sheet of paper divided into rows and columns was
a convenient workspace for keeping the financial books of a company.

All computerized spreadsheets use the same screen format of columns and rows.

oft bxeied - Remidd BREEER

...............

cel Spreadsheet

The columns are labeled with letters left to right and there are many more columns than
show on a computer monitor screen at one time.

The rows are labeled with numbers top to bottom. Again, there are many more rows than
will show on a screen.

Each little rectangle of the grid, where a column and row intersect, is called a cell. The
cells are identified using the column and row labels. The top left cell, at the intersection
of column A and row 1 is, therefore, cell A1. The cell selection is identified by the
highlight around the active cell. The current cell selection is also listed in a space at the
left end of tke formula bar just above the column headings.
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Active cell highlight

Also notice the bold and embossed headings of the column and row, another subtle clue
to the location of the selected cell.

Entering data into a cell is simply a matter of selecting the location where you want the
information to go and then typing it. As you type, the vertical flashing cursor will
advance in the cell. The data isn’t “official” until you enter it, commonly by tapping the
Enter key on the keyboard.

éntering dafa inacell

The standard action of tapping the Enter key is to advance the cell selection highlight to
the next cell down the current column.

Since you may want to enter your next data in the cell to the right of the first instead, you
may opt to “enter” your data by using the Tab key on the keyboard.

Tab ::advances the cell selecto;' right

The four arrow keys on the keyboard can also be used to enter data and move to a new
cell in the worksheet.

Of course, you may be a mouse-oriented computer user. You can also use the mouse to
point and click at the next cell where the data will go. Clicking any other cell also
“enters” the data.
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In Excel, while moving around the grid, the mouse pointer is a large plus symbol...

Mouse pointeI: in spread§heet grid area
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One more way you can move around the grid of cells is to use the Go To... option of the
Edit menu. (Note that the Go To option in the illustration below is actually much further
down a long menu which I’ve really shortened to save space.)

GoTo... option in Edit menu

Enter the cell reference (like G5) into the Reference blank at the bottom of the dialog
box which opens as you choose the Go To... option. Then click the OK button and you’ll
jump to that cell on the grid.

Go To... dialog box

Menu items with three dots after the option like the Go To... option lead you to a dialog
box and further options. Expect to have to enter more information or make more choices
when you use such a menu option. In this dialog box, the scrollable list space is for
named cells (which we’ll cover later). T : '

This is as good a place as any to mention the whole concept of menu options and
keyboard shortcuts. You can pull down a menu with the mouse as most people do, but
you can also pull down a menu with a keyboard combination.

For example, to pull down the Edit menu and select the Go To... option, you should tap
the Alt key; then tap the letter E; and finally tap the letter G. This is sometimes
abbreviated in manuals (like this one) Alt-E-G.

You may also notice that some options in a menu have another even easier shortcut
which shows at the right in the pulled-down menu. You can, for example, go directly to
the Go To... option’s dialog box by holding down the Control key while you tap the
letter G. This combination of keys is abbreviated in manuals as Ctrl-G or <Ctrl-G> to
show that this combination is done together the way the shift key is used with a letter key
to make a capital letter.
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Editing Cell Contents

Data in a cell is intended to be easy to change. One of the main purposes of spreadsheets
is to allow for quick updates when a cell value needs to be changed.

With either the mouse to point and click or the keyboard arrows, move the cell selector
back to cell Al and simply type a new number-followed by the Enter key. Before you tap
the enter key, you’ll be able to see the vertical cursor in the cell. The cursor is always
there when you are typing data. It will disappear after you enter the data. A visible cursor
indicates that you have not finished entering the data.

acell

Editing data right i
When you edit data directly in a cell, whatever was there is replaced by the new data.

You can also edit cell data in the space above the column headings called the Formula
Bar.

Editing in the formula bar

This labe feeds editing

In the case of labels or complex formula constructions, editing in the cell itself is much
more work than you want to do because you would need to completely retype the full cell
contents. By editing in the formula bar instead, you can position the cursor with the
mouse pointer so that it is in a good spot, and just make the necessary change. You can
use the keyboard arrow keys to adjust the cursor’s position if you don’t place it precisely
with the mouse point-and-click.

This label needs editing

2) Editingin the Fomulé Bar (EnteI: key not tabped yet)
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Data Types

There are four basic data types that can go into each cell of a worksheet.

Values (numbers)

Labels (words or special text) (Also sometimes called Text Values)
Formulas (calculations like addition, multiplication, etc. entered by the user)
Functions (complex calculations at least partially entered by Excel)

Values (first data type) are relatively obvious. A cell can contain a number like 55. It
can also contain a number like 3.2 or any other number.

Exercise 1a
Entering number values

Position the cell selection in cell Bl
Type the number 10

Move to cell B2

Type the number 8

Move to cell B3

Type the number 5

Move to cell B4

Type the number 3

Move to cell B5

Type the number 2

Data shown after exercise 1a

Notice that the numbers automatically move to the right edge of the cell. This is normal
for numbers so that the decimal points will line up (even though they are invisible in
whole numbers like these).

Column A is intentionally left blank to leave room for labels. See exercise 1b next.

l We will come back to examine large numbers and other fancy numeric formats Iater.
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Labels (second data type) are one of the great things that a normal calculator cannot
give you. The labels identify the numbers in nearby cells and also provide clarity to a
chart of numbers.

Exercise 1b
Entering Labels

Go to cell Al

Type the word Oranges

Go to cell A2

Type the word Grapefruit

Go to cell A3

Type the word Lemons

Go to cell A4

Type the word Limes

Go to cell AS

Type the word Tangerines

(If you notice the final S is partly hidden, you have good eyesight. You will learn how
to adjust the column widih later.)
Go to cell A6

Type Total Citrus

When entering wide labels into a cell, the label will often extend wider than the column’s
normal space. That’s okay.

If the next cell is empty, the label will simply extend to the right covering the empty
cell(s). The label is “in” only the cell where you started typing, but it “runs over” adjacent
cells. When you try to edit a long label, you must select the cell where the label began.
Although the adjacent cells seem to have part of the label in them, they are really empty.

If the adjacent cell already has data, a new label that is too-wide (like Tangerines, in cell
A5 here) will be partially hidden by the data in the next column. You’ll see how to deal
with that later. ‘ ;

If it seems like many things have been put off until “later,” it is so that initially I can
present a concept in a simple way, without too many options. I hope to show a basic idea
about labels, for example, as T just did. Boxed text like this, adds explanations that are a
hitde beyond the basic idea. More complex examples and explanations should come later
so the initial ideas have time to sink in.
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Formulas (third data type) are descriptions of calculations to be done on numbers
entered into the spreadsheet cells. Always begin typing a formula with the equal sign (=).
Starting a formula with an equal sign is very important. If you forget the equal sign,
Excel may interpret your typing as a text label.

Formulas are designed for general-purpose use. While you could create a formula that
said, “Add 3 plus 4,” spreadsheet formulas attempt to be more general by saying, “Add
the contents of cell Al to the contents of cell B1.” That way, you can later enter different
numbers into the cells and reuse the same formula to calculate the answer.

Brief Excel math lesson

1. All Excel formulas begin with the equal sign.
2. A formula can be built from fixed values. .

=5+4 The answer is 5.
3. A formula can be built from variable values that refer 1o cells.

=Al+Bl1 The answer depends on the numbers in cell Al and B1.
4. Most formulas in Excel will use variable (celi reference) values.

5. The four basic operations use the following operator symbols.
Operation Symbol  Symbol name ~ Example
Addition + Plus symbol =5+3
Subtraction - ‘Minus (hyphen) =6-3
Multiplication =~ * Asterisk =5*5
Division / Right slash =12/3

Exercise 1¢
Entering a formula

e GotocellB6

o Type the formula =B1+B2+B3+B4+B5

(Be sure to begin the formula with the equal sign (=) and do not put spaces between any
parts of the formula and complete the formula by tapping the enter key.)

Exercise 1d
Changing values used by a formula

e Go to cells Bl through B5 and enter different numbers. Each time you do so, notice
that as soon as you complete the entry with the Enter key or by using the mouse to
select the next cell, the answer expressed in cell B6 changes to show the new total of
the column of numbers.
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Functions (fourth data type) are intended to help develop complex calculations that
could be difficult to do in a2 manually entered formula.

Exercise le

o Go to cell A7 and type Sum of Citrus

e Go to cell B7 and carefully type =SUM(B1:B5)

(Don’t forget to tap the Enter key or select another cell with the mouse, Tab or arrow
key.)

That’s a colon between B1 and BS5. It stands for the word “through”. You would read the
function as “Calculate the sum of the range of numbers found in cells Bl through BS.” A
function is excellent for creating the calculation of a long column of numbers that would

be a pain in the neck to enter as a formula. Imagine if your column were 50 numbers long
instead of only five.

Functions refer to a range of numbers. A range can be a group of cells from a column, a
row, or a rectangular area of cells, (and actually even more complex cell selections).

Exercise 1f (another function)
The Average( ) function

Go to cell A8

Type the label Average Citrus

Go to cell B8

Type the function =Average(B1:B5)

Creating a formula to calculate the average could be more complicated than the function.
I figured out three different ways to make an equivalent formula instead of the built-in
average function. There might be more than these three, of course. Nobody’s perfect!

o =(B1+B2+B3+B4+B5)/5

o =(B1+B2+B3+B4+B5)/Count(B1 :BS)

o =Sum(B1:B5)/Count(B1:B5)

The first of these formulas is the most manual.
The second combines a formula and a function.
The third combines two functions

Nonetheless, using the built-in averaging function is the “easiest.” method.

Of course you do need to know about the available functions to make use of them. Excel
has many different functions. We'll come back to examine functions again later.
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If you are practicing at home or in the office, take time now to save this little worksheet.

Pull down the File menu and choose Save. (First Save is always a Save As... for name.)
You will be given a dialog box in which you will choose the new name and the location
to which you want to save the worksheet.

Typically, save the worksheet in a folder in “My dociiménté."-’
I put mine in a folder called Excel class. - i

With good eyesight, you can see, I've called the file Citrus inventoryl.

Formatting

There are many ways to improve the appearance of Excel worksheets. There are many
different kinds of formatting available.

Column and Row Formatting

Remember I promised earlier that you would be able to clean up the column widths
“later”? This is “later.”

Exercise 2a
o Position your mouse pointer in the column headings, the row of letters at the top of

the columns. Get it right at the line between column A and column B. The pointer
should change to a double-headed arrow.

I imnn a
Adjusting column width with two-headed arrow
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e Hold down the left mouse button and drag (move) the mouse to the right until the
words all show.
o Try making column B narrower, too so the numbers just fit.

If you are shaky with your mouse skills, there’s almost always the “other” way to do
every job in a modern computer program.

'

Select the entire A column by clicking the column heading on the top of the column
where the A is.

Pull down the Format menu, select Column and then select AutoFit Selection.

Adjusting columns with AutoFit

You can also make columns a precise size.

Pull down the Format menu, select Column and then select Width...
The dialog box will show you the normal (default) width of 8.43 (measured in digits that
will fit).

Changing column widths precisely

Simply type a new value into the dialog box and tap the Enter key to make the change. Of
course, you have to have some idea of what size you want.

Exercise 2b
Practice changing column widths.

To change more than one column width at once, select more than one. Use the mouse and
click on the heading of the first column you want to change and while holding down the
left mouse button drag across the screen to highlight several columns.
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Click here e===f Drag to here
;

IRRCRRFRVPEPYRIRRROAT TN

Tl s label need

Selecting several columns
Now, if you drag the right heading margin of the last column chosen, all chosen columns
will adjust to the same new width. Put the mouse pointer at the right edge of column C.

When you get there, the pointer should look like a two-headed arrow. Hold down the
mouse button when the mouse pointer looks like this to adjust column widths.

This label needs editing

EEa=r :
Adjusting several columns at once

Rows work in essentially the same way except that you are changing the thickness or
height of the row(s).

Exercise 2¢
Experiment with changing row heights.

If you completely slaughter the practice spreadsheet, close it without saving it and open
the version you saved earlier.

Adding a row

The current Citrus Inventory worksheet should look something like the following
illustration now.

Oranges 10
Grapefruit ' 8
5
3
2
Total Citrus 28
Sum of Citrus 28
Average Citrus 56
.

Citrus Inventory Worksheet

As part of making this spreadsheet better looking, it should have a title of some kind. Of
course, in a perfect world, we would plan ahead and we would have put the title into the

’
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first row before beginning the rest of the data. That’s okay. So the world isn’t perfect.
Excel will “forgive” us. We can add the row we need.

Exercise 3a

e Select row number one by using the mouse to click the row heading. The result
should look like the following illustration.

angerines
otal Citrus 28:

Average Citrus 5.6
) Selectingarow

Pull down the Insert menu and choose the Rows option .
Now select cell Al and type in the text label “Algot’s Kitchen — Citrus Inventory.”
Do it again; add another row, but this time select row 2 so the new row goes between
“Algot’s Kitchen” and “Oranges.”

e Enter labels for the columns “Fruit”, “Count”, “Cost”, and “Sell Price”

Your work should match the following illustrati

‘number icost
' 10
3
5
3

2. .
Total Citrus ~ ; 28!
Sum of Citrus : 28.
Average Citrus: 56:

Added rows
Challenge exercise 3b: Try to figure out how to add two or more rows at once, not one
and then another.

iSales price

AT. Rupeman Using Excel January 1999



Microsoft Excel

Exercise 3¢

Page 17

o Enter prices for the cost of each kind of fruit in the inventory into column C. For now,
enter them just as numbers. Don’t enter a dollar sign as you type each number, just
appropriate decimal points. (0.5 for oranges is 50 cents and that will the number
entered even if you enter 0.50) Copy the values in the illustration below.

Algot's Kitchen - Citrus Inventory

Fruit number cost :Sales price:
Oranges 10 0.5
Grapefruit 8 0.45
Lemons i 5 03
Limes 3 0.4
Tangerines 2 03%k: i
Total Citrus 28 :
Sum of Citrus 28
Average Citrus 56

Prices before formatting

e Leave the Sales price column blank for now, we'll fill it later when you practice a

more advanced skill.

Exercise 3d (No the illustrations won’t pop out of the screen at you!)

o Save your work again using Save As... from the File menu this time so you can
change the name to Citrus inventory2. If you choose the regular Save option, you
will overwrite the earlier version of the worksheet (Citrus inventoryl). We need that
simpler worksheet for a later exercise.

Use Save As... (for changing a file name)

AT. Runeman
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Formatting data in cells
Manual data formatting

I want you to learn to format worksheets in two different ways, first manually and then
automatically. You need both skills.

Exercise 4a
Making text Bold

The title would look much better if it stood out a little from the other words.

o Select cell Al
o Find the large letter B on the Formatting toolbar and click it with the mouse.

Formatting toolbar
The title label should turn Bold.

Exercise 4b
Centering text

o Start in cell A2 and drag to select A2 through D2.
e Find and click the Centering Icon on the Formatting toolbar (below)

The text labels should be centered in each column instead of being left aligned. Left
aligned is the standard alignment for text in a spreadsheet cell.
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Exercise 4¢
Number formats

Select cells C3 through C10 (even though the last three are currently empty.)
Pull down the Format menu and select the Cells option

Click on the Numbers “Page Tab.”

Click on the Currency option.

Accounting
Date
Time
Percentage

Cell format dialog box from the Format menu

The prices will automatically change to look like the illustration below.

Prices after “Currency” formatting

To be fair, I should admit that the “intelligence” of Excel is good enough to recognize
that If I use a dollar sign ($) when I enter the data, I intend that the cell be formatted as
currency. Therefore, if I typed each of the numbers, starting with the dollar sign, like
(80.5), Excel would automatically enter ($0.50) in the cell. There always seems to be
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more than one way to accomplish the same thing in a Windows-style program. It means
that each user can use the procedural style that suits the individual.

There are many different data formats, of course. I casually had you skip over the
General and Number formats for Exercise 4c. Some of you noticed my carefree attitude,
didn’t you? o e S

v L

The General format is the standard for data entry. With the General format, Excel
will use “intelligence” to recognize the kind of data that you are entering. If you begin
typing with a letter, Excel will automatically assign Text formatting to the cell. If you
type in only digits, Excel will use Number formatting. 1f you start with the dollar sign,

Excelpicks Currency. =~ = = 0 g e xS

= Now, let’s look at the special case of zip codes. A basic zip code is composed of
only five digits, so Excel will interpret it as needing the number format. That’s okay as
long as you don’t live in New England. : .

Exercise 4x : Pl _
o Enter Natick’s zip code 01760 into a cell.

The automatic use of Number formatting by Excel causes the first digit, a zero, to
disappear. For a number format, that is the right thing to do. Leading zeros are not
appropriate in number formatting except when the zero comes immediately before a
decimal point. Entering 0.5 would, therefore, keep the leading zero.

The zip code needs the leading zero. The way to keep it is to force Excel to see
the five digits of Natick’s zip code all as “text.”

Exercise 4xx Cyisdii g ~

o Type the zip code again, but this time, start with the quote key {(single
quote/apostrophe). -

o Type: ‘01760

‘When you tap the Enter key, the quotation mark will NOT show in the cell (although if
you examine the formula bar editing space, you will see the quotation mark there).
Starting the zip-code with a quotation mark informs Excel that the rest of what you type
into this cell should be considered text no matter what keys get tapped. Notice, too, that
the zip code is aligned to the left edge of the cell when it is forced as text. Like any
normal text of words, the zip code digits are aligned left in their cells.

If you know ahead of time that 2 column of ce]]s will be zip codes, you can apply text
formatting to a group of cells and then just type the zip codes without needing the
quotation mark. .

Actually, this new version of Excel has a few pecial cell formats. You can preset a
group of cells to be zip, zip+4, phone number and social security number. When you use
the phone number format, for example, you don’t need to type the punctuation. Excel will
keep track of where the parentheses and dash go. (Experiment—go ahead; try it.)
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Exercise 4d
Highlighting Cells for emphasis

o Select cells Al through D2
(Start at cell Al and click/hold the left mouse button. Drag the mouse to cell D2 and
release).

o Select the cell filler button on the formatting toolbar.
(It’s supposed to look like a paint bucket pouring out color.)

o Be careful to click on the little triangle arrow tip to the right of the bucket the first
tune.

As a standard, the cell fill color is listed as (Automatic) which means *“No Fill” as shown
in the color chart that opens when you click the little triangle point. Clicking on the
bucket when “No Fill” is the color option will give you a clear cell, just what you started
with. Phooey! That’s no fun.

You must select a color to fill the selected cells. I chose light yellow, the third from the
left in the bottom row of color patches. Fortunately for the colorblind like me, each color
is given a label if you hover the mouse pointer on the color patch.

If you really want to experiment with different color effects, Excel lets you pull the color
chart out to “float” over the spreadsheet. To pull the chart away, click and drag on the
narrow stripe at the very top of the color fill chart. - :

Select cells A3 through A10 and apply Turquoise color to them.

The result might look something like the next illustration which is going to show both
colors as shades of gray on the printed copy.

What?

Do you think that I could afford a fancy color laser printer?
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Algot’s Kitchen - s inventory
Fruit number cost - Sales price
10 $0.50 -
8 $0.45
5 $0.30
3 $0.40
20
28
28
56

“Highlighted labels enhance appearance

If you are printing your worksheets with a monochrome ink jet or laser printer, as I am,
be sure to test colors for their impact on the printout. Very dark colors may not give

enough contrast for the black text. (Even if you have a nice color ink jet printer, copies
will probably be done on a Xerox machine — unless you have another brand of copier.)

For high contrast, you can use a black fill and then change the text color to white. The
text color tool is just to the right of the background fill bucket. While in the middle of
these two steps, of course, you will not be able to see the black text against the black cell

background.

Algot's Kitchen - Citrus Inventory
Fruit riarnber Coeat

High contrast white text color with black cell fill

Please experiment with different color combinations to see what combinations you like.
Whenever you can, repeat an exercise with different options. The more you repeat the
pattern of steps for an exercise, the more comfortable you will feel with the steps and the
whole concept of the exercise. You will come to realize that you cannot break the
computer by trying simple steps. The repetitive exploration is important, especially if you
can do it under low pressure, non-threatening conditions.
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Exercise 5a

Adding cell borders

o Select Cells A2 through D2

o Select the Border control tool from the Format Bar.

e Remember to use the triangle arrow point to get the border options.

e Use the second one in on the second row to get a nice thick border below the labels.

Border control tool (not the one near El Paso, TX)

Algot's Kitchen - Cittus Inventory
~ Fruit number _ cost Salesprice
10 $0.50 : :
8 '§0.45
5 $0.30:
3 $0.40
2 $0.35!
28
28
56 o

o Save your work again using Save As... from the File menu so you can change the
name to Citrus inventory3. Remember, if you choose the regular Save option, you
will overwrite the earlier version, and we need that for the next exercise.
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Exercise 5b
Automatic formats

e Pull down the File menu and choose the Open option. You will get the standard
Open file dialog box. Explore to locate the “Citrus inventory2” file. If you are
continuing a work session, the file will be one of the ones listed in the current Look

in location.

If you are coming back to this work after many days or after just starting Excel, you may
need to navigate to the proper folder. This booklet doesn’t intend to cover much in the
way of basic Windows navxgauon skills. An Excel class probably should not be your first
exposure to usmg a Wmdows—based computer (Wmdows 95]98)

AYou may be abie 10. savc a stcp here,:f you are. contmumg w1th exercise 5a soon after
finishing the earlier exercises. Excel maintains a list of recent documents at the bottom of
the File menu. Look to see if “Citrus inventory2” is there. If it is, you can just click on the
name there at the bottom of the File menu.

e menu showing recent file (Shortened)

Excel 97 has a group of standard formats to provide the kinds of beautification we have
been trying (desperately?) to accomplish by hand. Sometimes manual methods will turn
out better, but for simple data layouts, you probably will like the AutoFormat options.

o Select the range of cells from Al through D10.
o Pull down the Format menu and choose the AutoFormat option.
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AutoFormat option

o From the list of preset choices in the dialog box, try at least a few. For this context, I
like the Classic 3 choice.

o Don’t just try the Classic 3, though. Try several. Learn by experimentation. It’s very
helpful even though it takes time.

Applying AutoFormat with an
Alternative technique:

Some people describe Excel 97 as “intelligent.” Find out what that means.

o With the mouse, click any cell in the rectangle of data in the Citrus Inventory
worksheet.

Excel’s AutoFormat wizard determines the limit of data by checking for a row or column
of empty cells. If you try to begin at an empty cell, Excel can’t work outwards to reach
any “edge” of data. Excel isn’t really intelligent. It has a limited set of rules to follow.
Excel cannot look to the left and up on the worksheet to see that we’ve chosen a cell just
outside the data range. Nonetheless, being able to let Excel find the margins of a data
block is pretty impressive.

o Try starting AutoFormat with cell F11 selected.

I know that I just told you it wouldn’t work. So what. Find out what happens when you
do the wrong thing. See if the result of your action tells you something useful.

o Save this formatted version as Citrus inventory4 if you wish, just to see what you did.

Actually, it is more important to just be sure you don’t save the formatted version back in
place of the unformatted version called Citrus inventory2. You should keep practice files
in their original format so you can go back to repeat the exercises that depend on them.

If you decide not to save the AutoFormatted version, just close it without saving.
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Playful Exploration

Making a “mistake” is sometimes a very important learning experience. To be truly
literate with computers, you must develop a sense of childlike playful exploration.
Children, especially young ones, do not expect to immediately understand their
surroundings. They explore without much self-judgement. Any result is instructive, even
a result which does not apparently lead in the “right” direction. Young children are
natural learners. Everything is a puzzle to be solved, even tasks adults totally take for
granted. That’s the problem with adult education. Adults may be uncomfortable making
mistakes. There is a feeling that “I should be able to do this. I am an adult.” The sad
corollary is the adult’s conclusion that “I must be really dumb because I don’t get this.”
Adults see the mistake and condemn themselves. Children see the mistake as a natural
step in the learning process. It is only the worst parts of the institutionalized education
process which rob us of accepting the natural mistakes that happen while we are learning.
It is the sad nature of adulthood that we are always in a hurry to be productive. Learning
(during the process anyway) is counter-productive. “I don’t have time for this!” That’s a
common, frustrated reaction to a job full of change and challenge. Learning Excel or any
other computer skill is certainly a challenge. Children expect the challenge. Adults rebel
against it.

Become childlike when you sit down to learn something new. Shed your adult *habits”
and see the exercise before you as a child does. Look at each option again and again with
small variations, not too many at once. Too many changes all at once will get you
frustrated because you don’t absorb the impact of each variation. Return to an exercise
more than once. Don’t assume that your adult brain is good enough to “get it” the first
time you try something. Each time you repeat an exercise, the result becomes more
consistent with other things you already know. Try a new variation. Let the new variation
connect with the knowledge and skills you have absorbed earlier through repetition.

I often tell people that I do not feel like a computer expert. The amount of information to
know about computers is too much for me to memorize. So I don’t memorize. Instead, I
repeat a procedure until it makes sense to me, varying options until I feel comfortable that
I understand what I’ve done. Then I put the skill aside, so to speak. I store it as a piece of
connected knowledge, not as an isolated fact that I have memorized. I don’t think my
learning style is unique. It is the context-based style that children use. If something isn’t
part of their daily routine, it isn’t a habit. If they do repeat something often enough, it
becomes a habit. (We hope most habits are good for us, unlike the smoking habit which

we are counseled to avoid.)

I try to put a new skill in context with the older ones that I've internalized by repeated
use. Then when I need the new skill again, maybe I remember I've done it before and 1
think about what steps probably will get the job done. If I am wrong, I try a variation of
the steps until I find the solution.

Good knowledge is, mostly, knowing how to find an answer, not just memorizing the
answer itself.

rd
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Copying, Pasting and Filling

Exercise 6a
Copying formulas and formats is a time saver

o If necessary, open the unformatted practice file called Citrus inventory2.
Select cell D3 and type the formula =C3*0.5+C3

o Remember to enter the value. (To keep the cell selection from moving, hold
down the control key while you tap the enter key <Ctrl-Enter>). If you just tap
the Enter key the cell selector will jump down to cell D4.

“Wait a minute, you didn’t telt us about this way to enter data before,” says the tall guy at
the back. True, but remember, 1did tell you there is usually more than one way to do
things. This seemed like a good time to introduce you {0 entering data and keeping the
selector in the same cell since you are going to want to copy the cell formula in a minute.

o Read that as: “Multiply the cost times 50% and then add that to the cost.”
o Or read it as “Mark up the cost by 50% to get the sales price.”

This is your reference formula. You are about to copy it to the rest of the cells in column
D where it is appropriate. There are two ways to do it (Copy/Paste) and (Fill).

Method 1a
Copy and Paste (with Menu)

o Select cell D3 again if your selector has moved.
o Pull down the Edit menu and choose the Copy option.

The cell highlight will become a moving marquee-style box.

:Sales price

"""" so.50f  $0.75%
§0.45° o
$0.30.
$0.40:

en ac! :
Marquee style selector (why isn't this paper copy moving?)

(This exercise continues on the next page.)
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Select cell D4.
Pull down the Edit menu again and choose the Paste option.

=C4"0.5+C4

Algot's Kitchen - Citrus Inventory

Frut  number | cost :Sales price
Oranges P 10:  $0.50, $0.75
Grapefruit | 8 so45f " soe8l
Lemons 5 §0.30: B

iman Q: Th AN:
Updated formula pasted in cell D4

Notice that the formula that was pasted into cell D4 isn’t exactly the same as the one
in cell D3. It is almost the same, but it has been updated relative to its current
position.

The formula in cell D3 was =C3*0.5+C3 (referring to number and cost of oranges).
The formula in cell D4 is =C4*0.5+C4 (referring to number and cost of grapefruit).

The reason for the reference change is important. The cell references in Excel are
considered to be relative not absolute references during copy and paste operations.

Paste again into cell D5 and see the new version of the formula in the Formula Bar.
=C5%.05+C3 (referring to the number and cost of lemons).

Paste again into cell D6 and check the updated formula.
Paste again into cell D7 and check the updated formula.

Close the file without saving the changes. (Pull down the File menu and choose the
Close option.)
Repeat exercise 5a exactly as before then go on to Method 1b.

Method 1b
Copy and Paste (Using Keyboard shortcuts)

Start with a fresh copy of the Citrus inventory? file.

Select cell D3 and enter the formula =C3*0.5+C3.

That much is the same.

Hold down the Control key and tap the letter C <Ctrl-C> (meaning copy).
Tap the down pointing arrow key to move the selection.

Hold down the Control key and tap the letter V <Ctrl-V> (meaning paste).
Continue pasting in cells D6 and D7.

So Copy/Paste is faster, if you can remember the shortcut keys.
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Method 1c
Fill Down

o Start with a fresh copy of the Citrus inventory? file.

o Select cell D3 and enter the formula =C3*0.5+C3.
That much is the same again.

e Be sure Cell D3 is highlighted.

o Click and drag to select cells D3 through D7

Algot's Kitchen - Citrus Inventory
Fruit number cost :Sales price:
Oranges 10 $0.50 $0.75

Grapefruit B: $0.45
Lemons 5 $0.30

Total Citrus 28
Sum of Citrus 28

Average Citrus: 56

o Pull down the Edit menu and choose the Fill option.
e Choose the Fill Down option on the extended options.
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e While you are looking at the open menu and its many options, look at the shortcut
keys mentioned for Fill down.

e Select cells D4 through D7 and tap the delete key on the keyboard.
(Hey, that’s a new trick isn’t it.)

e Select cells D3 through D7 and use the shortcut keys <Ctrl-D> to fill the adjusted
formulas down the column.
These techniques are getting very quick, aren’t they?

Exercise 6b
New Formula to duplicate.

Put the following formula into cell E3. =C3*B3

Read that as “Multiply the cost of a fruit times the number of that kind of fruit.”

Add the label Replacement Cost in cell E2.

Put the formula into cells E4 through E7 in each of the methods described in exercise
6a.

This is an important part of repetitive and playful exploration.

Exercise 6¢
Another Formula to duplicate.

e Put the formula =(C3*.5+C3)*B3 into cell F3.

e Read that as “Mark up the cost of a fruit by 50 percent and then multiply that by the
number of that fruit.
Add the label Potential gross sales in cell F2
Duplicate the formula into cells F4 through F7 by whatever method you like best.

Exercise 6¢
The last of these formulas to duplicate for now

Put the formula =F3-E3 into cell G3.
Read that as “Subtract the cost of a fruit from the sales price to find the net profit if
all the fruit sell.”

Add the label Potential profit in cell F2
Duplicate the formula into cells F4 through F7 by whatever method you like best.

Backtrack enough pages to help you remember how to format the new number data as
currency.

If everything goes well in these exercises, the final spreadsheet should look like the
illustration at the top of the next page. Check the calculations and see if they match.
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number : Sales price%Cost of inventary :Potential Gross Sales %Potential profit

10 $0.75: $5.00 $7.50 $2.50:

$0.68. $3.60 $5.40. $1.80:

$0.45: $1.50 $2.25° 30.75

$0.60. $1.20 $1.80; $0.60

$053 $0.70 $1.05. $0.35

......................................... 1

Exercise 6d

o Make the whole Worksheet beautiful with highlight formatting.

o When I chose to AutoFormat using Classic 3, I needed to make some columns less
wide so I could be happy with the result shown below.

Algot's Kitchen - Citrus Inventory
cost Sales price Costof mventory Potential 5ross Sales  Potentiaf profit

S 471 i

I then saved my completed worksheet as Citrus inventoryS.
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Math as applied in Excel worksheets

All through these recent exercises, some underlying discomfort may have been
developing in some of you. MATH was involved, and, while you believed I might know
what I was doing, you still would like to be sure that you could do the proper formulas
yourself.

Let’s review the basics.
The four basic math operations, as done in Excel, are:

Operation Formula Result
Addition =10+5 15
Subtraction =10-5 5
Multiplication =10*5 50
Division =10/5 2

I’'m sure you recognized the plus and minus symbols.

Where did the asterisk (*) come from? Sorry, the letter X cannot be used for
multiplication. Consider multiplying 4 times 2. That would look like =4X2 if X were
used instead of the asterisk (*). Since X2 is a valid cell reference just like A2 or B2,
Excel would be confused. We humans are able to handle ambiguity, but computer
programs are not. To avoid trying to make the letter X have more than one use, computer
programmers long ago decided to substitute the asterisk as the symbol to stand for
multiplication.

“Division has a unique symbol,” argues our tall student from the back row. True, the
accepted symbol is a horizontal line with dots above and below (+) for division, but that
symbol isn’t on any key of a standard keyboard. And besides, algebra students have
routinely accepted that a fraction is another way to show division. The decision stands.
10/5 means *“10 divided by 5.”

The next, and more troubling, issue is precedence. Precedence is the order in which
operations should be done. When doing math with more than one operation, order is very
important. If you do the wrong order, the answer you get will not be correct.

Don’t ask me, I don’t know who decided what order was correct. Since the correct order
has already been decided, though, the rest of us must use the same rules.

Humans frequently think through the rules this way.

1. Generally the calculations go from left to right.

2. Multiplication and division get done first, then addition and subtraction.
Some of us learned rule 2 with the help of the Mnemonic “My Dear Auat Sally.”
My (multiply), Dear (division), Aunt (addition), Sally (subtraction)

3. Use parentheses to group calculations when it is necessary.

4
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To successfully do math in Excel (and elsewhere, t0o), humans need to apply the rules,
but in the correct order.

1. Use parentheses to group calculations when it is necessary for clarity.
2. Multiplication and division get done first, then addition and subtraction.
3. Afier considering precedence, calculations go from left to right.

What does all that mean?” asks the tall man in the corner. “Please explain with some
examples.” (He must be the designated interrogator in the class.)

Exercise 7a
Learning math rules for Excel

Pull down the File menu and start a new worksheet.

In cell Al enter the number 10.

In cell B1 enter the number 6.

In cell C1 enter the formula =A1+B1. (adding 6 and 10)

In cell D1 enter the formula =A1*B1 (multiplying 6 and 10)

These are your reference values. Having them on screen may help with the rest of these
examples.

Now for how the rules apply: Left to right with multiplication first.

o Incell D2, enter the formula =10*6+10.

o Read that as “Add the product of 10 times 6 to the number 10.”
Multiplication happens first, then addition. Humans and computers agree.
The answer should be 70.

o Incell D3 do the formula =B1*A1+B1.

That’s the same as the fixed number calculation just above, but using the cell
references we set up before, to prove that the fixed values (numbers) and the
referenced values (cell references) work the same way.

The formula should still be read the same, and the answer should still be 70.

Now let’s see how human misapplication of math rules can be a problem.
Even when they are wrong, many humans try to apply left to right thinking first,
forgetting that math operation precedence must be considered first.

o In Cell D4 enter the formula =B1+A1*B1
(This is the same calculation as before, just in reverse order)
Careless left to right calculation in a person’s mind would translate to improperly
read this formula as “Add 10+6 and then multiply by 10.”
The expected answer of that careless reading would be 160.
As you can see, looking at the results in cell D4, it says 70. Left to right thinking doe:
not apply first. Multiplication must happen first, before the addition. Precedence!

A.T. Runeman Using Excel January 1999



Microsoft Excel Page 34

The actual order of operations must have the multiplication done first even though it
is not the “first” in a left-to-right reading. We still have to read the formula as
“Multiply 6 times 10 and then add 10.” The answer is still 70.

Now see how using parentheses can tell the computer to understand “human logic” and
work left to right without confusion. Maybe we really do want to add before multiplying.
o In cell D5 enter the formula =(B1+A1)*B1.
In this case, by using parentheses we group the calculations and override the raw
math (and computer) logic.
This time, because the parentheses regroup the calculations, you should read the
formula as “Add 10 plus 6 and then multiply by 10.”
The answer is 160.

16i 60

Formulas i=10%6+10 | 70
=B1*A1+B1 70

................................. =B1 +A1 *81 70 .
=(B1+A1)*B1 160

Math examples:(Formulas added for improved clarity)

Therefore, if you are in any doubt about precedence, use parentheses to force the
calculation to be what you expect. It would be just fine to do parentheses for the
following example that technically doesn’t need them.

=B1*Al+Al
=(B1*Al)+Al

The parentheses do not need to be there. Multiplication would be done before addition
anyway.

They do not get in the way, though. Go ahead and use them. Whenever you have any
doubt about precedence, use parentheses.
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In more complex situations, you may find that you need many sets of parentheses. They
always work in pairs. Generally move from inside out. Watch the bold parts of the
following calculation as we apply the rules.

=(A1*(B1+A1)-B1)/Al First add the inside parentheses
=(A1*(B1+A1)-B1)/Al Next multiply by Al
=(A1*(B1+A1)-B1)/Al ‘Next subtract Bl
=(A1¥(B1+A1)-B1)/A1 ‘Finally divide by Al

To emphasize the pairs of parentheses, visualize the following illustration.

Inner pair

N

=(A1*(B1+A1)}-B1)}A1

-

Outer pair

If you forgot to put in one of the parentheses, Excel would automatically warn you that it
was missing.

Parenthesis missing

l
=(A1*(B1+A1)}-B1/AT

L

Unmatched pair

: Mlcmsofl Excel

Unfortunately, Excel’s advxce isn't always correct. Notice that the final closing
parenthes:s in the dialog box is misplaced compared to my example. You would answer
No in this situation and correct the mistake yourself
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There is actually another level of precedence that comes before multiplication/division.
In cell D6, enter the formula =A14B1 which we read as “Six to the 10" power.”
That’s the same as saying, “Multiply 6 times 6 times 6 times 6 times 6 times 6 times 6

times 6 times 6 times6.”

The expressed number is 60466176..

On paper the formula is sometimes written 6® and most of us cringe at the thought of
doing the multiplication. Scientists encounter this kind of number all the time when they
are counting galaxies, bacteria and grains of sand.

In the situations where you need to do 2 fraéfibnal power, remember to enclose the power

exponent in parentheses.

6™ 5/4)
If you forget to use the parentheses, the formula will raise 6 to the 5™ power before
dividing by 4.
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Exercise 7b
Another Formatting issue
A “bigger” problem

The number 60466176 in cell D6 from the last exercise is a little difficult to read.
American number conventions split long numbers into groups of three digits starting
from the right (at the decimal point) and working left.

60,466,176
“Sixty million, Four hundred sixty-six thousand, one hundred seventy-six”

Select cell D6.
Pull down the Format menu and select the Cell option and then select the Number tab
and the Number Category.
o Click your mouse pointer in the box where it says “Use 1000 Separator (,).”
It is circled in the illustration below.

Fommat Cells

Making long numbers easier to read

The result will theoretically easier to read, but we have another immediate concern.
Long numbers don’t always fit into a cell. When that happens, Excel tells us the number
is too large by showing the number as many number symbols (FHHHEHERRHHAT).

To see a long number like this one, widen the column by dragging the right margin of the
column header.

1 IbUg
B

Long numbers don't aiways fit
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Exercise 7¢
Really Big Numbers

No, you know I don’t mean numbers like 6

There are numbers that are huge (and we dream of equally huge salaries).

e Incell D7, type the number 1000000 (one million) (six zeros)
(Practice getting the commas as in the last exercise if you want.)
(Change the format to “Currency” if you want to think of a nice “seven figure
salary.”)
In cell D8, type the formula =10720 (ten to the 20™ power)
The result is expressed as scientific notation.
1E+20 means “One times ten to the 20" power.” (E means exponent — power of 10)
We could dream (even Bill Gates could dream) of this twenty-one figure salary!

o See if Excel will show cell D8, 10 to the 20" power as currency. (Playful exploration,
indeed!')

o Save this worksheet as Math Rules if you want.
Though it might be more valuable to repeat some or all of exercises 6a through 6c
from scratch with your own variations as part of the playful exploration process.

Now that we’ve all had a good laugh at our own expense... (salary/income — expense, get
it? Sorry! I'll try to avoid such word play in the future.)

Let’s go back to the subject of Copying and Filling, the concept that we were examining
before the extended examination of math rules.

Take a deep breath, shake the tension out of your shoulders and turn to the next exercise.
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Exercise 8a
Filling to create a series

Start a new Excel worksheet file.

Type the number 1 into cell Al (remember to enter the data).

Click on cell Al and hold down the mouse button to highlight (select) cells Al
through A10.

Preparing for a Fill bown

e Pull open the Edit menu and select the Fill option.
o Select the Series option.

Selecting a Series Fill

You will get a new dialog box of options. We'll look at some of them, but remember that
you may want to return later to be childlike, unproductive and an eager learner, as you
explore other options of this dialog box.
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Seiies

Series Fill options

e Notice, when you look at the Series fill options dialog box, that because we have
selected cells Al through A10, Excel has matched our selection of a Series in
Columns.

e Notice, too, that the standard Type of series fill is Linear.

(Linear means “single stepped” in this case

e Notice, finally, that the standard Step value is 1.

When you click the OK button, the selected cells will fill with numbers, counting
from 1 to 10, which is a linear series with a step value of 1.

A Column Linear Series Fill

Exercise 8b
Extending a fill.

e Click on the selection handle (sometimes called the fill handle)...

Selection handle
e And drag the handle down to include cell A20.
The series will be extended, continuing to count from 11 to 20.
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Variations on a Series Fill
Exercise 8c
Stepping by 10

Enter 10 in Cell B1.

Select cells B1 through B10.

Select the Fill/Series from the Edit menu again, but this time change the step value to
10.

Click the OK button and look at the results, a linear series with a step value of 10.
Try some number series variations on your own.

Note that you can do these series in Rows as well as columns. Playfully explore.

Exercise 8d
Alternate method to fill
Drag to fill

Put a starting value in a cell.

Put the next value in an adjacent cell.

Select the two cells (release mouse button after selecting) and then click again to drag
the selection handle to the point where the series should end.

Try putting 5 and 10 in the first two cells of column C.
After selecting the two cells, drag the selection handle down.
You should get a series like 5,10, 15, 20, 25, etc.
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Exercise 8e
Date Series

e Enter the date 1/10/99 in cell C1.

e Select cells C1 through C10.

e Select the Fill/Series from the Edit menu again, but this time note that the Date unit
options are active. They were inactive before.

Series filt - date unit options

Enter the date 1/99 (representing month and year only) in cell D1.

Select Cells C1 through C12 (room for a year of dates counted by month).

Fill the dates by Month (another date unit in the dialog box).

Notice that the date may be expressed as Jan-99 through Dec-99.

Pull open the Format menu (Cells/Number tab) and see that you can also choose other

date formats.

Format Cells

Standard Month-Year format

A lot of information overlaps, doesn’t it? (childlike facination)
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Exercise 8f
Time series

Enter 9:00 AM in cell E1.

Select Cells E1 through E9

Pull down the Edit menu to select Fill/Series.

Enter 1:00 in the Step value blank of the dialog box.

A time series was something I had done using other spreadsheets, but had pot actually
tried in Excel before preparing these class materials. (Remember that nobody knows
everything.) My first playful exploration method was to use a step of 1. It didn’t work.
9:00 copied down into all the selected cells. I next tried a Type of “growth,” but that
didn’t work either. I probably should have looked this up in Excel’s help menu, but I'm
stubborn. I was sure it was possible to create an hour-by-hour series and I intended to
find it by the playful exploration method I’ve recommended so highly. After a few more
failures (harsh word, but not negative when in play mode), I finally tried telling the step
value to be 1:00 {one hour) and had success. I initially thought that Excel’s “intelligence”
would understand that a step of 1 was one hour. It turned out that Excel’s was not really
intelligent, and that I had to be more specific in my description of what I meant by “one.”

1t was even further into my exploration that I found the help menu was not easy to follow
on this one. I got caught in an examination of Date( ), Time( ) and Hour( ) functions
before I went back to the Excel screen and noticed that filling down with an increment
step of 1 actually didn’t produce just 8:00 all the way down. The hour 8:00 did repeat all
the way down, but the date it represented increased by one day. This was one time that
playful exploration got me mired in a swamp of information that a novice Excel user
would have found daunting at best. Remember, I've been playing with spreadsheet
programs since the Apple I+ and the original spreadsheet program called Visicalc. I'm
not a novice. There are plenty of things I do not know about spreadsheets because I just
don’t use all the available features.

‘When playful exploration isn’t enough, and the help menu isn’t a good guide, find a well
written book and check the index there or call a more advanced computer user who can
give you the benefit of experience. i
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A second look at Excel’s built-in Functions

Functions are intended to be replacements for complex formulas you might want to create
manually.

The most commonly used function is the SUM( ) function. For that reason, the toolbar
has a special wizard for helping you build the correct addition.

Exercise 9a
Automatic sums

e Enter the numbers 10, 20, 30, 40, 50 and 60 into column A as shown by the following
illustration.
e Select cell A7 as shown, too.

Prepare for AutoSum

¢ Find the AutoSum function button on the toolbar (circled in the following
illustration).

on the toolbar

Excel’s “intelligence” will figure out that you probably want to create a sum from the set
of cells above. In this case, that Excel decision is good.

o Enter a row of numbers instead of a column, and try the AutoSum button with the
highlight at the end of the row of numbers.

Playful exploration “demands” that you try invoking the AutoSum function wizard with
some other cells selected, not the obvious one at the end of a row or column. Try to figure
out what you get.

o Enter a new practice column of numbers and then highlight the cells you just entered.
e Click the AutoSum button and see how Excel adds a new cell at the bo:tom of your
cells and puts the sum formula there.
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Exercise 9b
Function Wizard (Average)

The less common functions are designed for complex jobs. The function wizard will also
help with these jobs.

Function Wizard button

The function wizard button leads you to a dialog box with many different built-in
functions. We did the Average function manually before. This time, let’s see how to get
the Average by using the function wizard.

o Enter a set of numbers into column C. You may copy the numbers in the following
illustration.

o Select Statistical from the Function category because an average is a statistical
funtion.

e Select AVERAGE from the list of statistical Function Names.
(Be careful not to choose AVERAGEA. That function is not the same.)
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Notice that a description of the function is given near the bottom of the dialog box.

AVERAGE(number1,number2,...)
Returns the average (arithmetic mean) of its arguments, which can be
numbers or names, arrays, or references that contain numbers.

That description may make sense to you. If you are not sure, the Office Assistant can

link you directly to the part of the help file that applies to the Average function if you
click the circle where it says “Yes, please provide me with help.”

The Office Assistant usually takes the form of a paperclip with eyes.

-

—
Office Assistant

Would you like help
with this feature?

& ves, please
provide help

& No, don't

e : provide help

If the Office Assistant doesn’t appear on its own, click the question mark button in the
lower left corner of the function wizard dialog box.

38 o

Calling for the Office Assistant

There is no practical way to select appropriate functions to discuss for this class from the
giant list available in Excel, There are functions for math, finance, logic, text and more.
Ask about specific functions that you want to understand. I'll help you if I can.
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Making Charts

Exercise 9a
Using the Chart Wizard to make a chart

Excel can convert the numbers from a worksheet into a chart or graph that may help you
to visualize the content.

Looking back at the fruit data from an earlier exercise...
e Point to cell A3, click and drag to select cells A3 through B7 that includes the label
and the number of each fruit.

angerines
Tatal Citren

Selecting chart data

o Select the Chart Wizard button from the toolbar.

Chart Wizard Button

When the wizard dialog box opens, you will see a potentially mind-numbing set of
options (and this is just the first of four steps in the wizard process).

E Chart Wizard - Step 1 ot 4 - Chart Type

Chart Wizard (1) — Selecting the chart type
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e Select the type of chart you want to use.
In this case, the purpose of the chart determines the basic type of chart. We want to
compare the numbers of each fruit in the inventory and that is best accomplished with
a column (or bar) chart. If we were illustrating the percentage of the total inventory,
we would want to use a pie chart. If we were showing the change or trend of a single
measurement over time, we would use a line chart.

All the chart versions shown in the Excel Chart Wizard are really just fancy variations
on these three.

Though Excel and other data tools give you the chance to make many different kinds
of chart {graph), fundamentally there are three basic types of graphs:

Type Purpose a8
Bar Compare related items to each other
Circle Show the part each item plays in relation to the whole group

Line Display the changjng pattern of data over time

e Select the sub-type of chart that you want.
Again, recognize the many variations on that basic type.

o

Simple Column chart

e Click the Next button at the bottom of the dialog box so you can go to the second
step.

B haet Wizard - Step 2 of 4 - Chaut

Chart Wizard (2) - Confirming the Data range
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o Confirm the source of the data by clicking the Next button again.
(If you have carefully selected the data in the first stage of this process, the
confirmation can be automatic. Excel “intelligence” determines for you that the data
to be charted is in a column because you have selected a column of numbers and a
column of labels.)
You also see a preview of the chart as it will appear.

-

o Enter a title in the Chart Options step of using the wizard and click the Next button.

Chart Wizard (3) — Options

In this case, the Category (X) Axis (bottom horizontal edge) of the chart is clearly
labeled by the labels we selected from the worksheet. If it were not clear enough (as it is
here), you could create a single axis label to explain the labeling and the data in the
columns. The Value (Y) axis (left vertical edge) is similarly obvious, but if you want,
enter the word “Count” into the Y-Axis blank.

o Select the location to put the chart and click the Finish button.
Usually (the default) location is As object in: the current worksheet. I have chosen
instead, to put the chart into its own worksheet of the Excel workbook.

Chart Wizard - Step 4 of 4 - Chart Location B ER

Chart Wizard (4) - Location
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Exercise 9b
Pie Chart

o Go back through the wizard, but choose to make a simple pie chart of the same data.

Exercise 9¢
Line chart

e On your own, create a new Excel worksheet with data about the heights of your
children from ages 1 to 18. Make up the data if you want. (Make up children, too, if
you want.)

eight chart of Algot's children (imaginary data thi oes have real children)
hild Thor's Janie's
ges Height  :Height Children's height chart
1 30 28
2 33 30
3: 37 33
4 40: 36
5 43; 4
(4 47 43
7 48 46 —e— Thor's Height
-H 50 4 -w-- Janie's Height
9 55 48
10 58 50 ...
1" 60 53
2. 8 57:
13 86 58 -
14 70 60 1 35 7 9 11131517
15 71 66 Age
16 73] 88!
17 74 68:
18 76 69:

If your data worksheet looks like mine, select only B3 through C22 when selecting data
for the chart. (In this example, I made the location of the chart as an object on the current
worksheet.
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Although there are many good data management programs, including Microsoft Access,
the data management program included in the professional version of Microsoft Office,

many people do data manipulation with Excel. Excel lacks many important capabilities,
but it can easily be used to good work with lists.

Exercise 10a
Using Excel to sort lists

The data in an Excel worksheet has an initial order or arrangement based on the way it
was typed into the cells of the spreadsheet. The initial arrangement of the data is not the
only order it can have. The data can be reorganized to have the rows of data treated as if

they were records of a database.

o Open State Population Stats worksheet file (in Dover-Sherborn’s adult class it will
be from the Commedx\Runeman\Excel folder)

POPHIS I LOTPOPCURITOTPOPPROTH

Population Stats (top left corner of large worksheet)

4040587} .. 4221932 _ 4455517
Alaska 580043} 610350 679683
Arizona 3665228| . 4000398 4452859
Arkansas 25 2441646 2566937
California 297600221 - 31546602] 33575312
Colorado : 3294394} 3630585 ‘4079905
Connecticut e 328116 v “ 3275198 3264723
Delaware . 566168} = T07864 757702
District Of Columbia |~~~ 606900} = - 571592 530751
Clarida o 4IRATAIRT - ATIRAQTAA 4A02782R

this workbook. E

The data in this worksheet is taken from a larger workbook called Mapstats, which is
automatically installed when you install Excel using the defanit settings. It is intended
for use with the advanced Excel map annotation features, which we will not cover in

Click to select any single cell of the worksheet. Sorting works with Excel

“intelligence” and if you have selected a small group of cells, the sort will apply only
to that small group of cells and can disrupt your data!
Pull down the Tools menu and select the Sort option.
Click the triangle to expand the choices in the Column selector. In this case you do
not want the default GEONAME column which represents the state name.
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Sort dialog box

e Select TOTPOPPRO, a column heading which stands for total population projected
for 1999.

Select Descending order so that the list will arrange from most to least population.

o Accept Excel’s default choice of having a header row. This is very important because
if you don’t mention it, that row will be moved into a new position in the list. You
should want the header row to remain right where it is.

o At this point, leave the other blanks empty.

The list will rearrange itself almost instantly to have the states in order from California to
Wyoming (highest projected 1999 population to lowest).

Exercise 10b
Quicksort with toolbar buttons

Excel also has a toolbar button that lets you sort data. (It’s quicker but has fewer options.)

o Select any cell in the column of state names. It does not need to be the header label,
but that will work just fine.
e Click the A-Z sort button on the Excel toolbar.

Ascending sort button

The data should be arranged by state name again.

e Sort in descending order by clicking the Z-A button.

Descending sort button
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Exercise 10c
Playful Exploration
And comments

Sort the data by several different columns. You can find out what a column heading
means by “hovering” your mouse pointer on the header label of each column. Someone
attached a comment to each heading label cell. A comment can explain anything you
want and has no impact on the contents of the cell during calculations. Comments are
effectively an extra layer of data for each cell.

BTy -
Comment (hover with mouse)

o Select the state name Georgia (in cell B12 when the states are sorted by name).
o Pull down the Insert menu and select the Comment option.

Inserting a comment for (the cell containing the name of) Georgia

o Delete whatever is currently in the comment editing box (current “Author,” a name
usually) and type in the new comment “The Peach State”.

Florida Peach State) 3
Georgia ;

Hawaii e
ldaho
Ilinois

* Editing the cell comment for Georgia
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Click on any other worksheet cell to finish editing the comment.
Hover the mouse pointer over the cell again, and the comment will show.
You can also see that a cell has a comment because it has a small red triangle in the
top-right corner (see the preceding illustration).

o Show all comments at once by pulling down the view menu and selecting the
comments option (Repeat this step to hide the comments. This option is a toggle on
then off option.)

When you show the comments a small dialog box/toolbar opens to allow you to review
and modify the comments.

.39
T AS409RRl
Reviewing and modifying comments

e Delete the comment for Georgia by clicking the Delete Comment button on the
floating Reviewing dialog box.
Remove the Reviewing dialog box from the screen by clicking the X in the corner.

Continue your playful exploration.
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Combining Multiple Worksheets

Exercise 11a
3.D worksheets
Sheet Labels

g
rd

During these exercises, you have certainly noticed that starting a new Excel workbook
usually produces a set of three worksheets (the default number). You can create formulas
and functions in cells of one sheet that refer to cells in another sheet, even refer to several
cells from different sheets in the same formula. Let’s look at a multi-sheet workbook
using a file of textbook purchase budget items for a mythical high school. The Insert
menu lets you add more sheets as needed.

Open the Budget file (found in the Runeman folder in Commedx at Dover-Sherborn)
Change the label of “Sheet 5 to “World Languages” by double clicking the tab of the
sheet near the bottom of the screen. The text will highlight. Just type the new sheet
name to replace what is highlighted.

Exercise 11b
Linking to data in another sheet

Select cell B11 in the Textbook Summary sheet.
Type equal sign using the key near the right end of the top row of keys on the
keyboard.
o Click the sheet tab for the World Languages sheet.
Click the total of the textbook cost for that sheet (cell F20)
Tap the Enter key.

The Textbook Summary worksheet again becomes visible and the updated worksheet
should include the total for World Languages textbooks in the summative total.

If you look in the Formula Bar while ceil B11 of the summary sheet is selected, you
will see the required Excel formula syntax for building your own links between
sheets. It probably isn’t worth the effort 1o do it yourself, but you should know it is
possible. S e e

="World Languages’ {F20

The equal sign should be familiar. = E

The name of the referenced sheet is in single quotes. .

An exclamation point precedes the cell reference to indicate it is on the other sheet
not the current summary sheet. G
The cell reference is a relative reference and if cell F20 were moved on the World
Languages sheet during subsequent editing of the data, the summary sheet would

properly link to the correct cell

A.T. Runeman Using Excel January 1999



Microsoft Excel Page 56

Exercise 11c
Practice

e Incolumn C of the Textbook Summary sheet, essentially repeat exercise 11b, but set
up the links for all the textbook budget totals from all the departmental sheets.

o By whatever method (Copy/Paste or Fill Right or do-it-yourself) create a total for the
items in column C.

Exercise 11d
Challenge: Create your own multi-sheet workbook with a summary sheet.

Exercise 11e
Move the Sheets around

o Notice that the order of the data in the summary sheet is...
English
Math
Science
History/Social Studies
World Languages

But the sheets are currently in a different order.

o While pointing to the tab of the English worksheet, click and hold the left mouse
button.

it to a new order

Selecting shee

e Drag the mouse to the left and when the small triangle points to the spot between the
Math sheet and the Summary sheet, release the mouse button to drop the English
sheet in its new place.

The links do not change in the summary formulas. Each summary formula refers to

the sheet by name.

Marking.the drop point
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If we can get to these topics, I'll produce pages to replace this one which will cover the
following topics. It may well be that the content to this point has been too ambitious fora
three week class.

Protecting Data

Locking sheets and cells
Hiding sheets, columns, rows
Unhiding

Passwords

Publishing

Copying data to Word
Copying Charts to Word
Active data linked to reports - OLE

Closing Remarks

As stated more than once, I do not know everything there is to know about Excel or any
other computer program past or present. The more I use a program, the better I know it
and when I use a program routinely, I develop some skills I can use without needing to
think about the steps involved. There are other tasks and skills I do infrequently and those
I have to review before doing the job. This need for review has a negative impact on my
productivity.

Practice the skills that you expect to need with data you can throw away if it doesn’t
work, and then become proficient through routine use with live data in your job.

Save a backup copy of any file you will change significantly so you can go back to it if
you really mangle the data while adding to it.

Expect to build in a certain amount of on-the-job training for any new task you assign to
an assistant, as you should expect to need similar time for new tasks you set for yourself.

Buy a good manual (or many of them) to use as a reference as you expand your skills.
While it is not the only good one, I recommend Running Microsoft Excel 97 by Mark
Dodge, Chris Kinata and Craig Stinson, published by Microsoft Press. My 1997 edition
has made using Excel less difficult and has helped me immensely during the preparation
of this classroom workbook.

I would also like to thank my daughter, Janie Runeman for being my editor for this
project. She is a graduate of The Gibbs School where she learned her Excel skills.
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Protecting spreadsheet data

There are going to be times that you will want to give a working spreadsheet to another
person who may not be as careful as you “always™ are. You may want that person Lo enter
changes of data into the carefully designed sheet you’ve made, but you don’t want them
to change your carcfully developed formulas or formatting.

Locking data

Lock it all

Pull down the Tools menu and select Protection.

Select Protect Sheet from the three options. The other two protect more. The workbook
option protects all the individual sheets at once. The share... option allows you to enforce

that a link back to your data cannot be broken in the spreadsheet where the link is made.

:[001 Menu

Enter a password if you want, but you’ll need to remember it or the spreadsheet will be
locked for you, too. Without the password, the whole spreadsheet is fixed, allowing no
changes at all.

That’s it. The whole worksheet is locked.
Now you can let somebody else see it. They can’t DO anything with it. Maybe this isn’t
the best way to lock things up.
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Locking everything but the data entry cells

Select a cell or cells.
Pull down the Format menu; select the Cell option; and select the Protection tab.

T et [d Ty
horma tHCel
o peme

P22 TR

Excel assumes that you will want to lock all the cells of a spreadshect. It 1s casier o
sclect cells to unlock than to select celis for locking.

Therefore, when you want to let people change the contents of cells where there is only
simple value to update, select those cells and click the “Locked” option box to remove
the checkmark. Those unlocked cells can be updated. The rest of the spreadsheet cells
will be locked when protection is turned on. If you use a password, only you can make
changes to the locked formats and formulas in the locked cells of the spreadsheet.

When anyone (even you) tries to enter data into a cell that was locked when protection
was turned on, the following dialog box will appear.

“Read-only” status describes that the cell can be copied and pasted elsewhere. but not
changed on the current spreadsheet.
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Hiding data

Sometimes you don’t even want to call attention io the cell contents. For that you need o
hide the data.

Open the file called Protection.xls for the following exercises.
Whole coluinns and/or rows can be hidden.

Sclect column B and C by clicking in the label margin at the top of the columns. The
whole column will highlight.

In this illustration, click and drag where the Plus pointer shows. Drag across to the right
to select both Columns B and C.

In the practice file, the two columns B and C disappear.
(see illustration on the next page)
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Notice that the column labels are not visible in the preceding illustration. The data is still
there. but the columns are invisible.

Unhide

To make the columns visible again, sclect the two columns that are on cither side of the
invisible, hidden columns. Then go back to the Format menu, Column option and choose
Unhide. If there are other hidden columns, they will remain hidden.

What if you hide column A? You can’t actuaily choose columns on both sides of it. but if
you start your pointer in column B and then drag left, a “virtual” column only a couple of
dots wide will select visibly Ieft of the B column. Then you can unhide and column A
will reappear. You could also select all of the spreadsheet (Control-A) and you could then
unhide the first column—or row.

Another kind of hiding is to hide the formulas that underlie the visible. calculated value
in a cell.

Select cells B2 through C7 (They will of course need to be visible to do it) and pull down
the Format menu.

Choose the Cells option and select Protection.

E ||l‘-:'9.?".-"‘ el

Then pull down the Tool menu and select Protection...Protect Sheet.
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The calculations will still show as results, but you won't see the formulas in the edit bar
when you select the cells. You can still enter new data in the cells of the unlocked cost
column, and the price for wholesale and retail will recalculate. You just won’t be able to
see how the value was calculated. (In our case, it might be trivial to figure out by just a
little algebra, but in some fancy spreadsheets, the complex formula might be valuable as
some kind of secret you wouldn’t want a clerk or end user to see.

You can hide a sheet of a multiple sheet workbook.
Look at the sheet tabs at the bottom of the screen in the Protection.xls file. There are

normally three sheets in a new Excel workbook. In this case sheet 2 is “missing” That
could be caused by deleting the sheet, but in this case it is just hidden.

To reveal the sheet, pull down the Format menu and sclect Sheet and Unhide... from the
submenu.

The dialog box below will open and you will have a selection of hidden sheets to unhide.
In this example, there is just one, but there might be several in a more complicated
workbook.
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Publishing Excel Data

Gretting data from Excel into another document is done in two difterent wavs
Copy and Paste is the basic technique.

Select the block of Excel spreadsheet cells that vou want to put into a Word document
Pull down the Edit menu and select the Copy option.

Start Microsoft Word. or click the Word button on the taskbar if vou are already working
with a Word document. { Remember that starting Word if vou have already started Word
actually starts a second version of Word.)

Place the cursor in the location where you want to put the selected cells
Pull down the Edit menu and select the Paste option

Total Citrus 28 $2.00 $3.00 $12.00 $18.00 $6.00
Sum of 28 $2.00 $3.00 $12.00 $18.00 $6.00
Citrus
Average 56 $0.40 $0.60 $2.40 $3.60 $1.20
Citrus

The selection of cells becomes a formatted table in the Word document.

It is editable. You can change the formatting. You can even change the data.

Actually, as originally pasted. the table didn’t fit. 1 needed to change the width of the
columns in Word so that the Potential Profit column didn’t run off the right margin and
get cut off (see next page numbered the same as this one),

Microsoft formally calls the technique embedding the data. part of the OLE (object
linking and Embedding) technology. As far as embedding is concerned. it is apparently
just a tancyv way of saving Copy and Paste.

The data copy in Word is a copy. but is independent of its origin in Excel. It is not a
“little spreadsheet”™ in the Word document. You can change the number of oranges to 5.
but the Total Citrus will not go up to 33 unless vou tvpe the change

The data originated in a live spreadsheet. but once it 1s in Word. the pasted copv is totally
independent of the source spreadsheet. The data mav look the same. but it is isolated. on
its own
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LinKing is the other technique in OLE

With linking. the copy of the data you publish is “live™ in relationship to the Excel
spreadsheet. Changes that are made in the cells of the Excel worksheet will change n the
Word document when vou update the link

I'he obvious benetit of this method is that the Word document is accurate and up to date
without needing to copy and paste and tiddle with the tormat

I'he drawback is that the source Excel worksheet must be accessible from the computer
where the Word document exists. If the link between the two documents is “broken™ then
the update cannot occur

[Total Citrus 28

To place this small two-cell link in the Word document. have both the Word and Excel
documents open.

Switch to the Excel worksheet and select the cells vou want.

Pull down the Edit menu and choose the Copy option.

On the taskbar. switch to the open Word document.

Pull down the Edit menu and select the Paste Special option.

At the lefi-center of the dialog box. click the circle (called a radio button) that sayvs Paste
link. (Note the explanation in the Result frame of the box when vou click the button. )

Word Hyperlink

The pasted data in the Word document is linked back to the Excel document. When you
change the data in Excel and it changes the linked cell(s). then the data in Word will also
change as long as both the source worksheet and the linked Word document are open
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There are two wavs to keep the document current. You can use the default Automatic

update. Automatic update changes the linked data in the open Word document moments
atter vou change it in Excel

It vou don’t have the Word document open when vou make the changes in Excel. the
Word will update when vou open it.

Alternatively. vou can select Manual updating. That leaves your Word document stable
until you decide to update it. If your Word document were linked to an Excel file that
somebody else was responsible for updating and stored on a shared network drive, then
vour Word document would be constantly changing before your eyes while the data was
being manipulated. If vou were preparing to print an interim report just when the data
was changed in the source file. the planned comments about the linked numbers would be
made potentially invalid by the changed linked value.

Automatic updating makes sure that you always have up-to-date information in your
Word document. You cannot forget to update

Even it vou change the Excel file when the Word document isn’t open and then close the
Excel worksheet. the next time you open the Word document. if you have updating set to
automatic, the change will occur in the Word document

Therefore. if vou try to close the Word document. vou will be asked what to do about the
changes “vou™ have made.
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Keeping Financial Records in Excel

There are programs like Quicken and Microsoft Money that are designed to keep
financial records for business and personal use

However. Excel can be used effectively for the same purpose.

Create a new Excel Workbook.
Set up a line or two describing the Account.

Setup the columns appropriate to tracking the basic income and expense information.

I actually added the formatting later.

The Check No. column will include Deposits labeled - DEP
For maintaining good records. 1 added a column called Category that will allow some
fancy additions, keeping track of the total for each category.

Enter some sample data.

10/1/1999 ‘Account Initailized '

10/1/1999 ‘Opening Deposit _ :$1,278.00 -

10111999 567 Shell Oil Co. . 1597
107211993 568 Star Market $17834 © .

10/2/1999 458 Applebees . $76.37 -

10/3/1899 469 Charles Furniture $20000 .
1051999 DEP | Mason Electric ... ..$790.22
10/11/1999 569 ‘Boston Edison - §78.19
10/11/1999 570 Bell Atlantic $37.60 :

1110/11/1998 580 Town of Natick W/S_ -~ §119.13

The first row of data needs to be a line something like row five. We need to start the
account with a pre-deposit balance of zero. Then we can properly set up the calculations
of'a running balance.

In cell F5, enter the zero.

In cell Fo. enter the calculation that will figure out the running balance
=F5+E6-D6
This tormula adds the balance from the preceding "transaction” to the current
deposit (if any) and subtracts the current payment (if any).

Copy the formula down to the cell of the last transaction. The running balance should fill
the cells of column F
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Enter the label "Insert new Row(s) Here" below the last sample transaction.

In the next row (in the example. row 16). create the formulas to show the current total for
Pavments. deposits and current balance. (The current balance formula is a little
redundant. but will help in a minute.)

Cutrent Totals $705 6O - $2,068 22

$136262

Pavment Formula =SUM(D5:D15)
Notice that the last cell in the range includes cell D15 from the row below the last
transaction. That will allow the formula to properly expand the range
automatically as the rows are added for new transactions.

Deposit Formula =SUM(ES:E15)
Balance Formula =SUM(F5:F15)

Untortunately, as you add a row. the running balance formula does not automatically
Jjump into the new cell in column F. Each time you add a row, you will need to copy the
formula in column F into the new cells. The fastest way to do that is to select the cell of
the formula above the new rows and drag the corner block down to fill the new cells.
Until you enter new transactions, the running total will just be a duplicate of the cell you
copied. As soon as you enter the new transaction payment or deposit, the total will update
to include the value entered.

When you reconcile your account at the end of the month, you can also add extra rows
for ATM and other electronic transactions that you didn't enter the as they happened the
way vou did checks and deposits. Just remember to copy formulas into the added cells
where necessary.

That's all you need for a basic finance tracking spreadsheet, but you can add some extras.

In this packet. I'll describe just one.
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Tracking category totals

There are some fancy conditional formulas that you can use to track the totals for each
category. For each category you want to track, create a new column. In the row of the

first transaction enter a formula like this (using utilities as the category example)
IF(H7="["tilities".D7, ")

This formula says " If the value in cell H7 is the word Ultilities, then copy the value from
the payment cell of this row, otherwise just leave the cell blank"

Copying that formula into each cell of the transaction rows, you can then create a formula
that takes the sum of the column.

In my example worksheet, I've put the sum at the top above the column label.

ilities  iIncome
xpenses :Summary |

Auto

‘Groceries

Misc.

‘Household; ; ;
Salary $790.22 ¢
Utilities $78.19 {
‘Utilittes  © $37.60 -

Utilities - $119.13

See if you can also set up the column and formula for the Income Summary on your own.
The formula will be a conditional formula

- __

_——

— —_——
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