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How To Use This Manual

How To Use This Manual

(Crf) - (D)

(Home),
Program Manager

Save

First Qtr.

If x>1 then

If x>1 then

[argument]

®

Step-by-step directions for carrying out a particular command or task.
Use the Procedure for later reference.

Examples of how a procedure works. This is your guide during the
hands-on exercises.

A note indicates optional information and provides a more complete
understanding of a particular procedure, command, or feature.

A shortcut gives you a tip or a hint that you can use to make a command
or procedure more efficient.

A trap warns you about 2 menu choice, command, or keystroke that may
result in an error or unexpected results.

A word inside a box represents a key on the keyboard.

This PC key combination indicates two keys which must be held down
simultaneously. Hold down the first key, tap the second key, and then
release both keys.

This indicates a key sequence. Press the first key, release it, and then
press the second key.

Any text in this typeface indicates the name of a folder, windows group,
or icon.

Any text in this typeface indicates a menu choice.

Any text in this typeface indicates something that you will type as part of
an exercise or part of a procedure.

Any text in this typeface indicates program code that you will need to type
in an exercise.

Any text in this typeface and shading indicates program code which
already exists. Use this as a reference for typing new code in
programming exercises.

A word in square brackets indicates it is optional. This is typically used in
command syntax examples.

This symbol indicates that a command, line, or program code is the
continuation of the previous line.
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Excel 2010 Intermediate

Course Objectives

Objectives

Leam to rename, insert, delete, move, and copy worksheets
Create linked formulas

Understand named ranges and relative names

Work with various function commands

Use conditional formatting and data validation

Understand auditing and error checking tools

Create, modify, and format charts

Understand table features

Create and use styles and templates

Learn to protect and share workbooks and worksheets

© 2011 Online Consultina. Inc.. Ravisad N7/296/11 -
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Excel 2010 Intermediate

Working with Worksheets

Viewing, renaming, and color-coding worksheets
Editing a group

Manipulating worksheets

Creating linked formulas

Using 3-D references

2011 Oindina Cancultina Inc Pavdcad N7MA41
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Viewing, Renaming, and Color-coding Worksheets

Viewing Worksheets

When you need to view a worksheet, you can click the appropriate worksheet tab at
the bottom of the workbook window to make it the active worksheet. The active
worksheet name appears in bold with a white, rather than shaded, background.

If the workbook has numerous worksheets, all of the tabs may not be visible, so
Excel has several methods to select and move between worksheets. One way is to
drag the tab split box to the right to reveal more worksheet tabs. Another way is to
use the tab scrolling buttons in the lower left corner of the workbook window to
scroll the tabs and display different ones. A third method is to right-click any one of
the four tab scrolling buttons to view a menu of all tabs in the workbook.

A workbook with multiple worksheets is illustrated below showing the position of
the tab scrolling buttons, as well as its shortcut menu, and the tab split box in the
workbook window:

&8 consolidation.xisx o 8 R
T A B € D E F =
1 {New York Sales Data T
2
3. Jan Feb Mar  i1st Quarter
4 Fax $1.500 $1,200 $1.500 $4,200
B3 Copier $2,000 .  $4.000;  $2,500!  $8,500
6 | Printer $3,600 $5,000 $4.500 $13,100
7 Modem $260 $300 $330 $860
s boons 8 Battimore QL §7.350 | §10500: 98,830 $26,680 il
a ing butions g |
shortcut menu s New York QL
11 Philadelphia QL
12 [ qQtrl
::i Baltimore Q2 ‘
15 New York Q2 ,
16! | PhiladelphiaQ2 |
:g Qtr2
v
M b . w York Q1 ./ Phiadelphia djq [n) b [l
Tab scrolling buttons Active worksheet Tab split box
The illustration below details how the tab scrolling buttons work to scroll through
worksheet tabs when not all of the tabs are visible:
First worksheet “ ﬂ-ﬂ -ﬂ b- @-n —h- Last worksheet
_ﬁ_ [ i
Previous worksheet - L Next worksheet

AN Nalina Cancnltinn Ins Rovicard N719RM1
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Viewing, Renaming, and Color-coding Worksheets, continued:

Renaming Worksheets

In a new workbook, Excel assigns the default name “Sheet” with a sequential
number, such as Sheet] or Sheet2, to each worksheet. You can rename the
worksheets to organize the workbook. Worksheet names can be up to 31 characters
long and can include spaces.

If you assign a distinguishing name to each sheet, you will be able to identify the
contents without having to display the worksheet. This is especially useful when you
have numerous worksheets in a workbook.

When you rename a worksheet, its tab is highlighted with a black background as
shown below, and you type the new name directly on the tab to replace the old name:

New York 1 .~

Named worksheet tab Worksheet tab ready to be renamed

Color-coding Worksheets

Besides renaming worksheets, you can also organize a workbook by changing the
color of the sheet tabs. Color-coding worksheet tabs is useful when you need to be
able to quickly locate certain information in a workbook. For example, if you want to
easily identify all of the summary worksheets in a workbook, you can assign each of
those sheets the same tab color.

Insert...
@ Delete
Rename
Move or Copy... Theme Colors
& H BEECE
View Code

(&g Protect Sheet..,

5 .
e g ' III
Standard Colors

Hide
Unhide..  'mmEm @ EEm
SelectAll Sheets  |[ ] No Color

¥ More Colors,.,
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Working with Worksheets

Excel 2010 Intermediate

STEPS

Viewing, Renaming, and Color-coding Worksheets

09

To view a different worksheet using the mouse, do one of the following:

o If necessary, use the tab scrolling buttons to display the desired
worksheet tab; click the tab of the desired sheet.

o Right-click a tab scrolling button and select the desired worksheet from
the shortcut menu.

To view a different worksheet using the keyboard, do one of the following:

o Press [Ctrl) — to select the previous sheet.
o  Press (Ctri) — (PageDown) to select the next sheet.

To rename a worksheet:
e Double-click the desired worksheet tab;
o Type the new name and press (Enter<7).

To color-code a worksheet:

e Right-click the desired worksheet tab;

o Point to Tab Color;

e Select the desired color in the Tab Color palette.

@

To display additional worksheet tabs, position the mouse pointer on the tab
split box so that the pointer becomes a +j* and drag the tab split box to the
right; to increase the size of the horizontal scroll bar, drag the tab split box
to the left. Double-click the tab split box to return it to the default position.

When renaming a worksheet tab, you can edit the existing text rather than
typing over it. Use the left («] and right (3] arrow keys and the and
keys to move within the text.

When you initially format the color of a worksheet tab and the worksheet is
still active, the tab displays as white and the color appears only to underline
the worksheet name. Once another sheet becomes the active sheet, the color
displays on the entire worksheet tab.

To remove the color from a worksheet tab, access the Tab Color palette and
choose No Color.

The shortcut menu of the tab scrolling buttons lists worksheets in the order
in which they appear in the workbook.

If you have a workbook with many sheets, you can scroll a few sheets at a
time by pressing while clicking one of the middle tab scrolling
buttons.

14
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Working with Worksheets

Use the Undo feature if you change the color of a worksheet tab and want to

Y
Q quickly reverse the change.

To rename a worksheet, right-click the tab and select Rename. Type a new
name and press {Enter«-).

® Once a worksheet has been renamed, you cannot use Undo to revert to the

previous name. You can, however, rename it again.

10.

11.

12.

Viewing, Renaming, and Color-coding Worksheets
Open the Consolidation workbook.
Click the Qfr 1 worksheet tab to make it the active sheet.
Use M to display the last worksheet tab.
Click the Qfr 2 worksheet tab to view the contents of the sheet.
Right-click any tab scrolling button and select Ot 1 from the shortcut menu.
Click the . tab scrolling button to display the first worksheet tab.
If necessary, drag the Tab Split box to the right to display all worksheet tabs.

To rename the Qfr 1 worksheet:
e Double-click the Qfr 1 worksheet tab;

o Type 1lst Quarter asthe new name;

o  Press [Enter<t].
Rename the Qfr 2 worksheet tabto 2nd Quarter.

To color-code a worksheet:
o Right-click the 1st Quarter worksheet tab and point to Tab Color;

o Click one of the green color boxes that appears under Theme Colors.

Change the color of the 2nd Quarter worksheet tab to the same shade of green as
the 1st Quarter worksheet tab.

Save the workbook.

- nnes o~ e -



Working with Worksheets Excel 2010 Intermediate

Editing a Group

Editing worksheets as a group can save you time with entering, changing, and
formatting worksheet information. Use this feature when you need to create or
modify several similar worksheets.

For instance, if you need to set up several worksheets in the same manner, you can
temporarily group blank worksheets together and create them simultaneously by
entering the labels, numbers, and formulas that you want to appear on all sheets in the
group. You can also alter column widths and row heights, change the appearance of
text, and, in general, format the active worksheet the way you want all of the sheets
to look.

Changes to the active worksheet are repeated in the corresponding cells of other
worksheets in the group. If you want to view or enter changes on another worksheet
in the group, you can click any sheet tab in the group to make it the active worksheet
and the group will stay intact. If all the sheets in a workbook are part of the group,
clicking another sheet tab will exit the group.

Once the worksheets are created, you can disband the group and work on the sheets
individually. At any time, you can regroup the sheets or form another group using
different worksheets whenever you need to add, edit, or format information in
worksheets that look alike.

The illustration below shows a series of adjacent worksheets grouped for editing:

[Group] in the title bar of the workbook indicales
that multiple worksheets are selecled.
[

=

I
@8 consolidationxisx [Group] o B %
A | B __¢C D E °F B~
1 'Baltimore Sales Data -
Jan Feh Mar 1st Quarter
Fax $2,500 $4,500 $3,600 $10,600

Copier $5.000 $7,000 $10,000 $22 000
Printer $1,200 $24,000 $4.,500 $29.700
Modem $350 $600 $425 $1,375
Totals $9.050 $36,100 518525  $63,675

7 .
8!Qla,‘;a,‘l;‘!ﬁlﬁ{:ls‘wlwlﬂjoﬂm!‘hlwrol

b - v_
[ <> u| Baltimore Q1 . New York Q1 . Phiadepha 01 . qj4 [ w_ ] R

— J
Y

Worksheet tabs with a fighter background, even if the tabs
have been color-coded, indicale that the sheets are a group.

1-6
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Editing a Group
[2] (53 )
1. Select the first worksheet to be modified.
2. To group nonadjacent worksheets:
STEPS group nionac)

o Hold down {Ctri};
o Click the other worksheet tabs to be included in the group.

3. To group adjacent worksheets:
o Hold down while clicking the last desired worksheet tab.

4, Make the desired modifications.

5. To exit group editing, use the appropriate method:
o Click a worksheet tab not in the group.
o Ifall worksheets are in the group, click any other worksheet tab.
o Right-click a sheet tab in the group; choose Ungroup Sheets.

6 When several worksheets in a workbook are grouped, click any sheet tab in
the group to make it the active sheet and retain the group.

If you close and save a workbook with multiple worksheets selected, the
worksheets will still be grouped when you reopen the file.

Sheet tabs that are color-coded or appear with the default shading indicate
that those worksheets are not part of a group.

N~.- To group all worksheets in a workbook, right-click the tab of the sheet you

Q want to edit and choose Select All Sheets from the shortcut menu. If you
want to make a different sheet active while maintaining all sheets in the
group, right-click the desired sheet and choose Select All Sheets.

To quickly copy data from one worksheet to corresponding cells of other
worksheets, select the worksheet that contains the data and the sheets to
which you want to copy the data; select the cells containing the data you
wish to copy. On the Home tab locate the Editing group; click Fill, and then
select Across Worksheets. Make the desired selection from the Fill Across
Worksheets dialog box and click OK.

® If you delete cells, rows, or columns in the active worksheet, they will * .
deleted in all of the other worksheets in the group as well.

Essentially, all changes are repeated in all worksheets in a group. Entering
data in cells in the active sheet will overwrite data in the corresponding celis
of grouped worksheets.

When all sheets in a workbook are grouped, clicking any sheet other than
the active sheet will ungroup all of the worksheets.

O ARAA PN T . P o AT mAe s - -
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10.

11.

12

13.

14.

15.

16.

Editing a Group

In the Consolidation workbook, view the Baltimore Q1, New York Q1, and
Philadelphia Q1 worksheets to see that the worksheets have the same type of
information and are similar in structure. Also notice that the width of column B is
slightly narrower on the Baltimore Q1 worksheet.

View the Baltimore Q1 worksheet.

Hold down and click the Philadelphia Q1 worksheet tab. Notice that
[Group] appears in the title bar.

Select the cells A1 through F1; on the Home tab, click |[EH *| Merge and Center in
the Alignment group.

Click the New York Q1 worksheet tab and note the changes on the worksheet.

With merged cell Al still selected, click the down arrow of “E:! Font Color in the
Font group and click one of the blue color boxes under Theme Fonts.

Click the Philadelphia Q1 worksheet tab, note the changes.

View the Baltimore Q1 worksheet. In cell B3, enter Equipment as the column
label.

View all three worksheets in the group and notice that “Equipment” does not fit
in the column.

To adjust column B, double-click the line between columns B and C in the
workbook frame in any one of the selected worksheets.

Exit the group by clicking the 1st Quarter worksheet tab and view the changes in
the three worksheets.

Regroup the same 3 worksheets.

To color-code the tabs of the grouped worksheets:

o Right-click any one of the grouped worksheet tabs, point to Tab Color and
choose a color.

Ungroup the worksheets.
Group and then color-code the Q2 worksheets in a different color.

Ungroup the Q2 worksheets and save the workbook.

1-8
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Manipulating Worksheets

Excel gives you control of inserting, deleting, moving, copying, and hiding
worksheets. By default, when you create a new workbook it contains three
worksheets. If desired, you can delete the extra worksheets so that only one remains
in the workbook. If you need additional worksheets later, you can insert them at any
time. Although new worksheets are inserted before the active worksheet, you can
reposition them as needed in the workbook.

To create a new worksheet that is similar to an existing one, you can duplicate the
worksheet and then make the necessary alterations to the duplicate. Worksheets may
be copied or moved within the same workbook or between open workbook files.

When you right-click a worksheet tab or a group of selected tabs, the shortcut menu
illustrated below displays to help you manipulate worksheets:

&) consolidationxdsx o B &

s AT B T € | b T T °F G H =)

1! Philadelphia Sales Data ]

5

3 Equipment Jan Feb Mar 1st Quarter |

4 . Fax $3,600 $5,500 $4,800 ¥ Insert... ‘__

5 Copier $4800 | §2600| $10.000! 3153 perete 1

6 : Printer $600 $3,000 $1,200 ! =

7 Modem 5200 $600 5260 {4  Bename |

8 Totals $9,200 $11,700 $16,260 $3 Move or Copy... i______

2 , & View Code

:}? @ Protect Sheet... b

. Shortcut menu

12 Tab Color L .
13: " '

145 Hide —

15:’ Unhida,, s

16 Select All Sheets v
M 4 » W] 1stQuarter , Baltimore Q1 . New York Q1 | Phifadelphia trr—r—owomore—gz—pr~i ] » [l.:

Choose the workbook —{-| Consolid.xlsx v|

Check to make acopy —3 [T] Create a copy

The Move or Copy command on the worksheet shortcut menu above opens the dialog
box illustrated below for you to duplicate or relocate worksheets within the same
workbook or to another open workbook:

[Move or. (‘-Z;g py

S

Move selected sheets
To book:

Before sheet:

R c e R A !

New York Q1 -

| Philadelphia Q1 i
15t Quarter z |

Choose the sheet |Baltimore Q2

iNew York Q2 —_

i Philadelphia Q2

i2nd Quarter v
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Manipulating Worksheets, continued:

Using Drag-and-Drop to Move and Copy Worlksheets

To quickly move or copy single or multiple worksheets, you can use the
drag-and-drop methods illustrated below:

The down arrow indicates where the sheet will be
Move positioned when you release the mouse.

To move a single worksheet,
drag it to the desired location.

ZNew Yok 02 . Phiadelpha Q2 | YTD .~

Copy A plus displays in the page icon when you are
copying, rather than moving, worksheets.
To copy a single worksheet,

hold down (Cirl} while you drag l—&
the sheet to the desired location.  “7-ror 02 = Phiadelbhia 02 | YID
. A S

Move or Copy Multiple Sheets

To move or copy muitiple sheets, first select them. When moving the sheets, you can
drag any one of the grouped sheet tabs. When copying the sheets, hold down
while dragging the sheet tab of the active worksheet to the desired location.

The icon changes to show three sheels to indicate that multiple sheets are being
manipulated. While copying multiple sheets, a plus will display in the icon.

3

- Philadelphia Q1 x*-'ist':@mer—' Baltimore Qz: Hew York Q2

Hiding Worksheets

If need be, you can also hide worksheets so that they cannot be readily viewed. If you
have hidden multiple worksheets, they can only be unhidden one at a time.

The dialog box for unhiding worksheets is shown below:

You cannot
select multiple
sheets in the
list of hidden
worksheets.

=) (o]
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Working with Worksheets

Manipulating Worksheets

STEPS

Select the worksheet or worksheets to be manipulated.

To move selected worksheets within a workbook or to another workbook:

Right-click a selected worksheet tab and select Move or Copy;
Select the target workbook from the To book drop-down list;

Optionally, choose the desired worksheet location from the Before sheet
list box; then click OK.

To copy selected worksheets within a workbook or to another workbook:

Right-click a selected worksheet tab and select Move or Copy,
Click in the checkbox next to Create a copy;
Select the target workbook from the To book drop-down list;

Optionally, choose the desired worksheet location from the Before sheet
list box; then click OK.

To delete selected worksheets from a workbook:

Right-click any sheet tab in the group and choose Delete.
If prompted to confirm the deletion, click Delete.

To hide selected worksheets, do one of the following;:

On the Home tab, locate the Cells group and click Format; point to Hide &
Unhide and then select Hide Sheet.

Right-click any sheet tab in the group and choose Hide.

To unhide a worksheet:

o Right-click any visible worksheet tab and choose Unhide;
o In the Unhide box, select the worksheet to unhide;

e Click OK.

To insert worksheets in front of the active sheet:

o Ensure that the number of worksheets selected is the same as the number
of sheets to be inserted and do one of the following:

— On the Home tab, locate the Cells group and click Insert; select Insert
Sheet.

To insert one worksheet after the last sheet:

o View the last worksheet tab and then click the 22 “Insert Worksheet tab.
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Manipulating Worksheets, continued:

In the Move or Copy dialog box, select (new book) from the To book drop-
down list to create a new workbook that contains only the moved or copied
worksheets.

To move or copy a worksheet to another named workbook, the workbook
must be open.

The default number of worksheets in a new workbook is three. To change
that value, click the File tab and click 4 optiens _ Make sure the General
options are displayed and enter the new value in the nclude this many
sheets text box; then click OK. The maximum number of worksheets you
can enter as the new default is 255; however, you can insert as many
additional worksheets as desired, limited only by your computer’s available
memory.

Using the shortcut menu to insert a sheet gives you a choice as to the type of
sheet to be inserted. To insert an additional worksheet, right-click the tab of
the worksheet to follow the new sheet and select Insert. On the General tab
of the Insert dialog box, Worksheet should already be selected for you; click
OK to accept the choice.

Y~y- Ifaworksheet contains data when you attempt to delete it, Excel displays
Q the warning “Data may exist in the sheet(s) selected for deletion. To
permanently delete the data, press Delete.” Y ou will receive the same
warning for worksheets that you have used, even if you have deleted the
data and they are blank when you attempt to delete them.

To use the drag-and-drop method to copy or move worksheets between
open workbooks, arrange or tile the windows of the workbooks so you can
see both worksheet areas simultaneously. To tile the open workbooks, click
the View tab and locate the Window group, click Arrange All; choose Tiled.
Horizontal, or Vertical.

Press —(F11]) to quickly insert a worksheet in front of the active
sheet.
® No two worksheets in a workbook can have the same name.

You cannot use the Undo command to reverse the action of moving,
copying, or deleting worksheets.

You cannot simultaneously insert noncontiguous worksheets.

Excel does not display a warning when you delete worksheets that have
never been used.
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9.

Manipulating Worksheets

. Inthe Consolidation workbook, right-click any worksheet tab and choose Select

All Sheets from the shortcut menu.

To copy all of the sheets to a new workbook:
o Right-click any worksheet tab and select Move or Copy,

e Select the Create a copy check box (so you don’t mistakenly move the
sheets, instead of copying them);

o Open the To book drop-down list and select (new book);

e Click OK; note by the name in the title bar that you are viewing a new
workbook.

To use drag-and-drop to copy several worksheets in the new workbook:

o Ifnecessary, click {¥]to display the last worksheet tab;

o Select the three Q2 worksheets, Baltimore Q2 through Philadelphia Q2;

o Position the mouse pointer over the active sheet of the three selected sheets;

o Hold down (Cir) and drag the duplicates after the YTD sheet;

o Release the mouse before releasing [Cirl). Note that each copied worksheet has
a (2) after its name to distinguish it from the original sheet.

Edit the worksheet names to: Baltimore Q3, New York Q3, and Philadelphia Q3.

Group the three Q3 worksheets and do the following:
o Change the color of the tabs;

o Select the range C4:E7 and press to remove the values from the
worksheets, while retaining the formulas.

To insert a new worksheet in front of the YTD sheet:
o Click the YTD worksheet tab;

o Display the Home tab and locate the Cells group; click the down arrow next
to Insert and select Insert Sheet.

Name the new sheet Mid-YTD and move the YTD sheet to the end of the tabs.

To hide the quarterly worksheets:
o Select the 1st Quarter and 2nd Quarter worksheets;

o Inthe Cells group, click Format and point to Hide & Unhide; select Hide
Sheet.

Unhide the 1st Quarter worksheet and delete the Mid-YTD worksheet.

10. Save the workbook in the student data folder as Third Quarter.

11. Close all open files.
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Creating Linked Formulas

You can create formulas that refer to cells in other worksheets or workbooks. This
process is called “linking” because it allows automatic updating of data in the target
or linked worksheet whenever data is changed in the source worksheet. Linking can
be accomplished by creating simple formulas or by using the Paste Link option of the
Paste Special command.

The illustration below shows a sample of a worksheet link:

wif
.

£ | #New York'B13

BG6
A

B I

c__A

|1
2— - -
3 3
Target formulain 2
cell B6 references o
another worksheet
as the source of

the information.

k2

& INewYork
7 |Riode Janeiro

| 8 Sydney
9

Total

23]

. Expenses

I8l

Yy pure

'aAYLOR FASHIONS

) ?roﬁtSum ary

=

Jan

$345,000

Feb

i < v W[ New York .~ Rio de Jangio _, Sydney | Profitl]« |

Il <

Mar IstQtr
$345,000
0

$0

$0 $345,000

m ] t»l]v

Ready | {5 |

|(EEm 10 O—0—®

When you create a formula linked to another worksheet, the name of the sheet
appears in the formula separated from the cell reference by an exclamation point.
When you create a formula linked to another workbook, the name of the workbook
appears in square brackets. If you create formulas by selecting cells, rather than by
typing, the cell references will be relative when referring to another sheet and
absolute when referring to another workbook.

The table below shows the basic differences in linked formulas:

Linked to:

Resulting Formula:

Another workbook

A worksheet in the same workbook

=Sheet2!B1

=[Book2]Sheet2!$B$1

114
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Creating Linked Formulas, continued:

After you copy a cell or range of cells from a source worksheet, you can establish a
link using the drop-down list of the Paste button:

iw

Paste

hd

AR EE
BHEE

Paste Values

=) )

Other Paste Opfions

BREE

Deandem =

~———— Paste Link (N}

If you paste an item, the Paste Options button automatically appears as below the
cell or range of cells. Click the button to choose an option for the pasted information;
the Paste Link choice lets you link the pasted data to the copied cells.

B6 vi(® ﬁrl ='New York'!B5
j A l B c l D [ E F
1/ TAYLOR FASHIONS INTERNATIONAL
_2_;“ o Profit Summary _ . -
¥
5 Jan Feb Mar 1stQr

New York B 5200000 $225000 g13anoal  $559,000

Rio de Janeiro @m.‘ sa

Sydney

Paste
_‘lQ_Total $200,000 $225,000 $134,000 @ %
4

12 [Expenses Paste Values

13 -

T4 1125 i) i3]

% Other Pasie Options
Eid %l &)




Working with Worksheets

Excel 2010 Intermediate

Creating Linked Formulas

(=}
D0
STEPS

Select the cell or range in the source worksheet that will be the reference.
Click [52] Copy.
Select the desired worksheet in the target workbook.

Select the cell that represents the upper left corner of the Paste range for the
target formula.

On the Home tab, locate the Clipboard group and click the Paste down arrow;
choose Paste Link.

@

Some tools are segmented with the top portion of the tool being a button
that you click and the lower portion of the tool a drop-down arrow that
displays different options of the command. The Paste tool is an example of
this type of tool; click the lower portion of the tool to display the menu
containing the Paste Link option.

If a workbook contains links to another workbook, display the Data tab,
locate the Connections group, and then click B2 Edit Links | to do any of the

following: update links in the workbook, open or change the source
workbook, or break the link.

To display options for updating links upon opening a workbook, display the
Data tab; in the Connections group, click |=2 Edit Links |. Click Startup Prompt
and make a selection.

Depending on your security settings, when you open the target workbook,
the message “dutomatic update of links has been disabled” may appear in
the Info Bar under the Ribbon. If necessary, click Options, choose Enable
this content and then click OK. This will allow Excel to automatically
update the links.

If either the source or target workbook has been moved to another location,
the following prompt will appear when you open the companion workbook:
“This workbook contains one or more links that cannot be updated. To
change the source of links, or attempt to update values again, click Edit
Links. To leave the links as is, click Continue.” To relocate a linked
workbook, click Edit Links; in the Edit Links dialog box, select the link that
contains the linked file name and click Change Source. Navigate to the
location of the moved workbook, select the file, and click OK to update the
linked data; then close the Edit Links dialog box.

The (& Paste Option button is on by default. If it does not appear when you

paste an item into a worksheet, click the File tab and click ) Options

Display the Advanced options and select Show Paste Options buttons when
content is selected from the options under Cut, copy and paste. It should then
display the next time you paste into the worksheet.

1-16
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_—;:) Creating Linked Formulas
1. Open Links and view the New York, Rio de Janeiro, Sydney, and Profits worksheets.

2. To create a formula that links the profit figures on the New York worksheet to the
New York row in the Profit Summary worksheet:

Select the New York worksheet;

In the Profit row, select the range B13:D13;

On the Home tab, locate the Clipboard group and click Eé_l Copy;

Move to the Profits worksheet;

Select cell B6;

To see what happens if you just paste the copied information into the cells,
click Paste in the Clipboard group and view the results;

To correct the results, click the [E&] Paste Options button and choose Paste
Link from the bottom row;

o View each of the three linked formulas in the Formula bar.

3. To create a formula that links the profit figures on the Rio de Janeiro worksheet to
the Rio de Janeiro row on the Profits worksheet:

e On the Rio de Janeiro worksheet, copy the range B13:D13;
e Move to the Profits worksheet and select cell B7;

o In the Clipboard group, click the down arrow on the Paste command and
select Paste Link.

4. Paste link the same range from the profit row of the Sydney worksheet into cell
B8 in the Profits worksheet.

5. Note the value in cell B6 on the Profits worksheet.

6. On the New York worksheet, change the value in cell B5S to 250,000 and note
the change in cell B13 below it.

7. Display the Profits worksheet and note the change in cell B6, the New York profit
for January.

8. Save the workbook.

© 2011 Online Consulting, Inc., Revised 07/26/11 1-17



Working_; with Worksheets Excel 2010 Intermediate

Using 3-D References

You may need to create formulas that use information from several worksheets. If the
data on the worksheets is not arranged similarly, you will need to view each sheet
separately to create its reference for a formula. However, if the worksheets are
arranged in an identical fashion, you can use a three-dimensional reference that spans
multiple adjacent worksheets for certain functions. A 3-D reference refers to the
same cell or range of cells on multiple sheets.

The illustration below shows a 3-D sum function being created on the Profits
worksheet in cell B11 on three contiguous worksheets—New York, Rio de Janeiro,

and Sydney:
IF v " X « S| =sum{'New York'iB11 v
A ] B i c D E F_ 6 =

1 Taylor Fashions International B
2 ~ NewYork (in thousands)

3

| 4 |sales Division Jan Feb Mar 1stQtr

[ 5 | women's $200,000 $225,000 134,000 $559,000

6 | Men's $250,000 $210,000 $245,000 $705,000 =
7 Munior's $75,000 $63,000 $100,000 $238,000

8 { Children's $120,000 $114,000 $87,000 $321,000

9 ‘Yotal $645,000 §612,000 $566,000 $1,823,000

10

11 |Expenses | $2500008  5187,000 $78000  §515,000

12 —
13 |profit (SUMinumbed, fumberd] . ), $488,000 51,308,000

14!

15

e w
H 4 » M| New York /”Rio de Janeiro_ " Sydney " Profts "0 Jj« [ u LY
Point | F | S 2 |BEEm o e 4

Three-dimensional references can make lengthy formulas more readable. For
instance, if you created a simple formula that adds the expenses for the same cell in
the three worksheets above, it would look like this:

='New York''B11+Rio de Janeiro'!B11+Sydney!B11

By comparison, the 3-D formula is simplified and condensed to:

=sum('New York:Sydney'!B11)

1-18 © 2011 Online Consulting, Inc., Revised 07/26/11
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Using 3-D References

Select the cell that will contain a three-dimensional function.

Type = followed by the name of the function and an opening parenthesis;
for example: =sum (

Select the tab of the worksheet that contains the first reference in the
function.

Click the cell that represents the data for the first reference in the function.

If necessary, click a tab scrolling button to display the tab of the last
worksheet to be referenced.

Hold down and click the tab of the worksheet that contains the last
reference in the function.

Press (Enter<-).

i

A number of common functions can be used with three-dimensional
references, including: SUM, AVERAGE, COUNT, MIN, MAX, and
PRODUCT.

For a full list of functions that can use 3-D references, see the Excel Help
topic titled “Refer to the same cell or range on multiple sheets.”

The Auto Fill Options button appears after dragging over a range with the
Auto Fill handle and offers options for filling the range. Click |Z+| Auto Fill
Options to display the list of options. Auto Fill options vary according to the
type of data to be filled. The button will disappear with the next action you
perform.

4 410
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Try It

Using 3-D References

In this exercise, you'll first create a simple formula that sums information on three
worksheets and then create a SUM function using a 3-D reference to accomplish the
same thing. As you create the formulas, note how they are being built in the Formula

bar.

1. In the Links workbook, create a simple linking formula for expenses using the
following information:

On the Profits worksheet, select B12 and type an (=];
Click the New York worksheet tab;

Click B11 in New York and type a (+};

Click B11 in Rio de Janeiro and type a (+);

Click B11 in Sydney and press (Enter<2].

2. As an alternative, create a 3-D linking formula for the expenses using the steps
below:

-}

Select cell B13 on the Profits worksheet;

Type =sum( and click the New York worksheet tab;
Select cell B11;

Hold down and click the Sydney worksheet tab;
Press {Enter<-).

3. Compare the formulas.

4. Select both formulas and use the Auto Fill handle to copy both formulas across
the row to column E.

S. Save and close the workbook.

4.0
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ing with Functions

Using absolute cell references
Creating and using named ranges
Creating a relative named range

Using custom zoom

Using functions

Working with Insert Function
Using financial functions

Using date functions
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Using Absolute Cell References

Typically when a formula is copied, the cell references in the duplicate formula
change to reflect the new location of the formula. This is because, by default, the cell
references in formulas are relafive references. However, sometimes it is necessary to
have a cell reference that remains constant when it is copied so that it always refers to
a specific cell. This requires the use of an absolute cell reference. An absolute cell
reference in a formula will not change when it is copied to another location. The
absolute reference is created by placing a dollar sign to the left of both the column
letter and the row number in the cell reference, for example $B$4.

A common use for an absolute cell reference is to include a variable constant value in
a formula, for example, an interest rate or sales quota.

The illustration below shows a typical use of an absolute cell reference:

B8 v % | =As*sass

: A | B | [ D
_1 BGAFinancial Services, Ltd.

_2 Rates as of 5/13/2011

3 This cell is referenced in the
—_ formulas shown below with
_4 Rate: 4 an absolute cell reference.
5
6 | Principal $ Interest Total
7. $2,500 $163
Il $5,000 ﬂ $325 ! <4— The formula in this cellis:
8 $7500 $488 =AB3B34
10 $10,000 $650
11 $12,500 $813 ¢+—————— The formula in this cell is:
12 $15,000 3975 =A11°$B8%4

13 $17,500 $1,138
14 $20000  $1,300 o
15 $22 500 $1,463 < Izﬁé%nggza in this cell is:
16 $25,000 $1,625
17 $27.500 $1,788
18 $30,000 $1,950

2-2
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Using Absolute Cell References

%
STEPS

Select the cell that will contain the formula.

. Press(=).

. Build the formula as usual.

. To make a cell an absolute reference:

o While building the formula, press when the cell is selected.

. Build the remainder of the formula, as necessary.

. To complete the formula, perform one of the following:

o  Press (Enter<J).
e Click |« |Enter on the Formula Bar.

0 When you press (F4), the cell reference becomes absolute. Optionally, you

can continue to press to make only the row reference absolute or only
the column reference absolute. For example, H$7 is an absolute row
reference while $H7 is an absolute column reference.

Using Absolute Cell References
Open the Function workbook.
On the Absolute worksheet tab, select celi B7.

Create a formula that multiplies the principal in cell A7 by the interest in cell B4.

. Fill the formula down the column and note the error messages.

Select cell B7 and click in the Formula bar after the reference to cell B4.

. Press to make the reference to B4 an absolute reference; the reference should

appear as $B$4. Press (Enter<).

. Copy the formula down the column again.

. Complete the Total column, if desired.

On the Bonus worksheet, create a formula in C7 that will calculate the Principal

. multiplied by the Rate. Make sure the Principal column letter and the Rate row

number are absolute.

10. Copy the formula from C7:F18 then save the workbook.
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Creating and Using Named Ranges

You can attach a name to a cell or group of cells. Once named, the cells can be
referred to by name instead of by cell addresses. Creating defined names for
worksheet areas can simplify using advanced commands and formulas. Range names
can serve as a type of internal documentation that helps you to understand what is
happening in a formula. In addition, if named cells are cut and pasted into another
location, the name follows the data to the new location.

The Name Manager dialog box is illustrated below:

‘Name Manager:
B e e e g X el

Buttons fo create,
edit or delete a
name., T _New...

Displays a list of all J
defined names in

the workbook.
\
. ;efersto: o T T
Displays the ~ r
referenced range. ¥ v _|=Payrolli$§6:40420 R - |
By default, range — —
names use absolute i
cell references.
The Name box, on the left end of Excel’s Formula bar, can also be used to quickly
create an absolute named range. After you create named ranges in a workbook, you
can also use the Name box to move the cell pointer quickly to a named range.
The Name box is illustrated below displaying its list of range names:
H2-¢-BlEA8D -
Namebox —— rm - ., - ¥ | Reardon International Payn
List of range Salary B : c D
names Sumstats | International Payroll
Tota
3]
4
5 |Employee Name Department Hire Date Salary
€ |Robbins Sales 2/3/2001 574,750
7 iShoemaker Admin 371471999 555,600
8 iSmith, 1. Operations 6/6/2004 855,900
9 |Thompson Customer Service 7/16/2008 535,880
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Creating and Using Named Ranges

© 0
0 !
STEPS
2.
3.

To create a named range using the Name Manager dialog box:

Select the cell or cells to be named;

On the Formulas tab, locate the Defined Names group and select Name
Manager;

Select New;
Type the desired name in the Name text box and click OK. Click Close.

To create a named range using the Name box on the Formula bar:

(-]

Select the cell or cells to be named;
Click once in the Name box;

Type the desired name;

Press (Enter<-].

To move to a defined name, use one of the following methods:

Open the Name box drop-down list and select the desired name.

Press (F5), select the desired name from the list in the Go To dialog box,
and click OK.

Defined range names must start with a letter, underscore (), ora
backslash (\) and are not case sensitive. You can use numbers, letters,
periods and underscore characters but no spaces in your range name. Be
careful not to use names that resemble cell references such as BC10 or
QTRI1. Defined range names can be up to 255 characters.

After defining the first named range, if you wish to create other named
ranges, click New to leave the Define Name dialog box open. Type the next
name, and use (%3 Collapse Dialog in the Refers fo text box to select the
appropriate range in the worksheet. When you have finished naming ranges,
click Close.

When a defined range is selected, its name, rather than a cell address,
appears in the Name box on the Formula bar.

Excel’s Name box list is not available while you are editing a cell. To
display a list of defined range names while editing, press (F3). The Paste
Name dialog box will be displayed so that you can select the desired range
name.

You can use defined names in formulas and functions. For example,
=sum (wktotal).

To create names based on existing worksheet labels, select the ranges
including the cells with labels. On the Formulas tab, locate the Defined
Names group and select Create from Selection; indicate where the labels are
situated: Top row, Left column, Bottom row, or Right column; and click OK.
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©

The error value #NAME? will display in any cells containing a formula that
refers to a range name that you have deleted.

Remember to press if you create a range name using the Name box.

Range names use absolute cell references by default.

Try It

Creating and Using Named Ranges

1. On the Payroll worksheet in the Function workbook, select cells D6:D20.

2. On the Formulas tab, locate the Defined Names group and click Name Manager.

3. In the Name Manager box, click New.

4. In the New Name dialog box, note the suggested name Salary and the
information in the Refers to text box and then click OK. Click Close.

5. To use the Salary range name in the statistical formulas:

In G3 type =max (salary) and press (Enter<-);
In G4 type =min( and press(F3);
Select the range name Salary, click OK, and press (Enter<-);

Use the AVERAGE and SUM functions to complete the formulas in G5 and
G6.

6. To name and then move the summary information to the Summary Stats
worksheet:

Select the range F1:G6,

Click once in the Name box;

Type in the name sumstat and press (Enter<2);

On the Home tab, click | d | Cut.

Move to the Summary Stats sheet and click :_3 Paste in cell Al;

Return to the Payroll sheet and use the Name drop-down list to go to the
Sumstat range in its new location.

7. Press and use the Go To dialog box list to go to the Salary range.

8. Save the workbook.

2-6
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Creating a Relative Named Range

By default, when you create a range name the cell references are absolute. If you use
a range name in a formula and you want that named range reference to change when
you copy the formula, the defined name should be relative. When you create a
relative name, the cells that are named are relative to the active cell. Therefore, it is
important that you select the correct cell prior to creating a relative name.

The illustration below shows the New Name dialog box with a relative name:

A I 8 1 c D E | F G
_1 |Warehouse 101-Inventory Status

i : f)l_;May §'18_-May ;lé-May
hMetal Chairs 1750 1695 1650 1525 1050 7895

Wooden Chairs 675 605 550 675 450 2955
Rolling Chairs % 85 80 90 90 435
Metal Dasks ] 200 140 150 200 250 940
Wooden Desks 100 120 90 140 120 570
Computer,Desks) 45 45 50 50 45 235

10 {Chairs Totals
11 |Desks Totals
A2
_13|Warehouse 201 - Inventory Status
"

The cells being ® : oo | Neve tome - Rofars i nx Cell addresses
named display a T\ ooden Cha 00 ‘ - shovyn here are
marquee and are Py e 150 [LIoRcktivo Ronges B1c:818 e relative. Note the
relative to the Y retal 0 200 250 200 140 135 925 absence of the
position of the cell PTY Wooden De 300 100 350 375 150 1625 characters.
pointer. 70 55 80 90 75 370

2 ichaisYotals | |

23 |Desks Totals

Creating a Relative Named Range

Select the cell to which the named cells will be relative.

2. On the Formulas tab, locate the Defined Names group and select Name

STEPS . Mamnager; click New.

3. Type the desired name in the Name text box.

4. Press three times or click &) Collapse Dialog in the Refers to text box.
5. Select the cell or cells to be named in the worksheet.

6. Press three times to make the cell references relative.

7. Expand the dialog box, if necessary.

8. Click OK.
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Creating a Relative Named Range, continued:

@

When you press (F4), the cell reference changes from absolute to a mixed
reference. Continue to press to cycle through all the combinations; for
example, H$7 is an absolute row reference while $H7 is an absolute column
reference.

The Auto Fill Options button appears after dragging a range with the Auto

Fill handle and offers options for filling the range. Click |22 Auto Fill Options
to display the list of options; the options shown will vary according to the
type of data being fill. The Auto Fill Options button disappears with the
next action you perform.

After an item is pasted, the Paste Options button automatically appears
below the cell or range of cells. You can choose the characteristics of the
pasted information after it has been pasted into the selection.

When you type the left parenthesis after the function name, a ToolTip
appears displaying the recommended function arguments. Click the function
name to link to the Help topic for that specific function.

When you enter a range name in a formula, the Range Finder feature places
a colored border around the range used in the calculation.

When creating a relative name, do not select the cells to be named before
opening the New dialog box. If you do, the cells will be relative to the
active cell in the selected range. If you use this defined name in a formula, it
will result in a circular reference.

2-8
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Creating a Relative Named Range

In this exercise, we’ll first use an absolute range name in a formula so you can see
Try it the problem when copying the formula. Then we’ll create a relative range name, use
it in a formula, and copy the formula to see it done correctly.

1.

10.

11.

12.

13.

14.

15.
16.
17.

18.

Click the Relative Ranges worksheet tab in Function, and define the name
Chairs forthe range B4:B6.

Create the formula =sum (Chairs) incell B10.

Use the fill handle to copy the formula, which uses an absolute range name,
across the row and note the erroneous formula results.

To determine that the range “Chairs” is absolute, select cell E10 and use the
Name box to select the range. Note that it refers to B4:B6.

Select cell B22.

On the Formula tab, locate the Defined Names group and select Name Manager.
Select “Chairs” in the Name Manager dialog box and click Edit.

Click (2] Collapse Dialog in the Refers to text box.

Select the range B16:B18.

Press three times to make the cell references relative.

Expand the dialog box, click OK, and then click Close. Notice the totals in row 10
have updated.

Type =sum(chairs) incell B22.
Copy the formula across the row using the fill handle.

Double-click cell D10 and notice the formula is fixed. Press {Esc) to exit the
formula.

Select cell B11 and create a relative named range for Desks using cells B7:B9.
In cell B11 create a formula to total the Desks named range.
Copy the formula from B11 to C11:G11 and B23:G23.

Save the workbook.
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Using Custom Zoom

You can see the defined names associated with ranges of cells on the worksheet when
you reduce the zoom magnification below 40%. This is most useful when working
with fairly large ranges in a worksheet. When custom zoom is activated, you can see
a border around each range and the name superimposed over the cells.

The worksheet in the illustration below is using Custom Zoom to show Defined
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Using Custom Zoom
L 1. To display Custom Zoom:
@ . To display Custom Zoom:
o On the View tab, locate the Zoom group and select Zoom;
STEPS o Type 39 inthe Custom % text box; click OK.
2. To return to Normal Zoom:
e  On the View tab, locate the Zoom group and click 700%;
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0 Any zoom percentage below 40% will display defined range names for
absolute ranges. Relative range names are not displayed.

<. Return to Normal View from a custom view by pressing (Cul) - (z] or
Q clicking | ¥ Undo if changing to the custom view was your last command.

The zoom tools on the status bar can be used to adjust the magnification.

— Using Custom Zoom

1. Display the Payroll worksheet in the Function workbook.
2. On the View tab, in the Zoom group, select Zoom.

3. Enter 39 in the Custom text box.

4. Click OK.

5. Note the label for the range Salary.

6. Return the view magnification to 100%.

© 2011 Online Consultina. Inc.. Revised 07/26/11 2-11
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Using Functions

A function is a predefined formula that performs calculations by inputting specific
values in a particular order. The specific values used in a function are called the
arguments and the order is referred to as the synrax.

A number of functions work as shorthand methods for performing calculations. For
example, the SUM function can be used in place of a lengthy formula adding the
values in a group of cells. In other instances, functions are substitutes for complex
formulas. Knowing the interest rate and the amount you want to borrow, you can
calculate the monthly payment on a loan using the PMT financial function.

While different functions require different input, all functions are comprised of three
components: an equal sign, followed by the name of the function, and the arguments
in parentheses.

The following describes the syntax of a function:

=function name(arguments)

=SUM (C14:C24)

= indicates that a calculation is to be performed.

Function Name is the name of the function.

Arguments are the specific values to be used as input. Arguments are
typically cell addresses or defined range names. They are
listed inside parentheses and are separated by commas. In the
example above, the SUM function has one argument, which is
the range C14:C24.

2-12
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Using Functions, continued:

Excel has numerous functions that are divided into specific categories. The most
commonly-used categories, along with examples and descriptions, are listed below:

: Category

Example

Description

- Math and
Trigonometry

Statistical

Financial

Text

- Logical

- Date and
_ Time

=ROUND(number,number of digits)

=AVERAGE(range)

=PMT(rate,number of periods,
present value future value,type)

=VALUE(text)

=IF(logical_test,truevaiue,
falsevalue)

=MONTH(date)

performs calculations on
numbers. The arguments vary
based on the function.

performs statistical
calculations on a group of
numbers. The arguments are
usually ranges of cell
addresses.

calculates interest rates,
payments, and other financial
outcomes. The arguments are
usually cell addresses.

changes the appearance of
text. The argument is usually a
single cell address.

tests a condition and retums
values based on the resuit. The
arguments vary based on the
function.

manipulates dates entered into
the worksheet. The arguments
vary based on the function.
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Working with Insert Function

The Insert Function dialog box, illustrated below, is used to select a function for a
worksheet calculation; it provides a search feature as well as descriptions and help
information on all of Excel’s functions:

Search for a function:
Locales a function based on a Type a brief description of what you want to do and then dick I Go |
description of what the function — | Go
should accomplish. Or select a category:  Math & Trig i'; <
Select a function: ﬁ:st R y Used »
SUBTOTAL  |Financial [~
Displays available functions in the oA 2
selected category. Select a o ]
function fo display its description
below. ~
v,
Displays the selected function Logical —— =
syntax with a short description of SUMIF(range,critedy formation
Y P Adds the cels i v
the function. ec User Defined
Opens the Microsoft Help window
for the selected function. Help on this function | ok || concet |

Lists all function categories. Select a category
to narrow the list in the Select A Function box.

Once you select the desired function, the Function Arguments dialog box, which is
illustrated below, displays to assist you in assembling the function arguments and
inserting the function into the worksheet:

e T T T o S T e A e P S T e =

Shows required i 1 A e e

X i Range !B8:821 = {Engineering";"Engineering”;"Engine...
arguments in bold; ; — ;
optional arguments Criteria “Finance” = *Fnance”
are not bolded. Sum_range |D8:D21 = {282.1;237.15;145.08;149.42;91.14...

= 21762 ¢
. - Adds the cells specified by a given condition or aiteria.

Displays a description ¢ Y
of the function and the Sum_range are the actual cells to sum. If omitted, the cells in range are used.
active argument.

Formula result = 217.62

Heln on this Function | [ o ][ concel ]
Displays the resuit of the function with Displays the result of the function
formatting as it will appear in the worksheet. based on the current arguments.
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Working with Insert Function, continued:

The Name box on the Formula bar changes to the Functions list whenever you start
with an equal sign (=) in a cell. The most recently used function name appears in the
box; other recently used functions appear in the drop-down list attached to the
Functions list.

The Functions list is illustrated below:

Click the Functions - SUMIF ~ " XV fe|=
list drop-down amrow SUMIF B | ¢ D E
{o display recently SUMIES
used functions.
IF NAL DEFECTS (PER THOUSAND)
AND e T
DSUM
HLOOKUP
ICONCATENATE Jan Feb Mar IstQtr
OR hort:
. ) IAVERAGE Alloy 48 52 51 151
Click More Functions
ROUND Holds 36 38 40 114
{0 access the Insert .
Function dialog box. More Functions... yrities 18 1 17 54
10| Engineering Design 22 21 21 64
1 Electronic/Computer 2 3 2 7
12

| 13 Total Defects E |

14 |Average # Defects
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Working with Insert Function

e e
STEPS

1. Select the cell that will contain the function.

2. Use the desired method to display the Insert Function dialog box:

e Click the Formulas tab and click Insert Function in the Function Library
group.
o Click [%]Insert Function on the Formula bar.

o On the Home tab, click the | ’-'"'| AutoSum drop-down arrow and select
More Functions.

o Type = and click the Functions drop-down arrow on the Formula bar:
select More Functions.

3. Do one of the following:
o  Enter search text in the Search for a function text box and click Go.

o Select the desired Function category.
4. Select the desired Function name from the Select a function list box.
5. Click OK.

6. To enter arguments in the Function Arguments dialog box, use the desired
method:

o  Click in the appropriate text box, if necessary, and type the cell address
or range.

o Click ["] Collapse Dialog in the appropriate text box, select the desired
cells in the worksheet, and press (Enter<2).

Click OK.

N

@ The result of the function will be displayed in the Function Arguments
dialog box. If the value does not look correct, edit the arguments before
clicking OK.

To access a list of all available functions in the Insert Function dialog box,
choose All in the Or select a category drop-down list. Click any function in
the Select a function list box to display a short description of it below the
list.

To display more in-depth information about a specific function, select it in
the Select a function list box, and then click Help on this function at the
bottom of the dialog box.

If you are unsure of a function name, you can search for it in the Insert
Function dialog box. Type a short description of what the function should
do in the Search for a function text box and click Go. In the Select a
Junction list box, select each recommended function and note its description
until you find the correct one.

2-16

© 2011 Online Consutting, Inc., Revised 07/26/11




Excel 2010 Intermediate

Working with Functions

Working with Insert Function, continued:

You do not need to include quotation marks to enter text as an argument in
the Function Arguments dialog box.

Text entered as a function argument is not case sensitive.

When typing a function directly into a cell, the Function AutoComplete
feature displays a scrollable list containing the functions that start with the
leiter or letters that you have typed. A ScreenTip appears with a description
for the function that is selected in the list. You can use the (1] and (4] arrows
to scroll through the list. To select a function, double-click it or press the
key when the desired function is selected.

If a cell has an error in the formula, a green triangle will display in the

upper-left corner and the || Trace Error button will appear when the cell is
selected. Point to the Trace Error button to display a ScreenTip describing
the error or click the button to display a list of commands to help resolve the
error.

Once an error is resolved, the || Trace Eror button and green triangle
disappear from a cell.

As an alternative to using the Collapse Dialog button, select the desired
text box and then select cells directly in the worksheet. If necessary, move
the dialog box so that you can view the desired cells.

Double-click a function in the Select a function list box of the Insert
Function dialog box to quickly display the Function Arguments dialog box.

To edit an existing function using the Function Arguments dialog box,
select the cell in the worksheet that contains the function and click
Insert Function on the Formula bar.

While the Function Arguments dialog box is displayed, you cannot access
range names from the Name box on the Formula bar to use them as
arguments. You can, however, press (F3] to open the Paste Name dialog
box, which contains a list of range names for the current workbook. Select
the desired range name from the list and click OK to paste the name into the
active argument text box.

You do not have to use the Insert Function dialog box or the Function
Arguments dialog box to enter a function into a cell. If you are familiar with
a function’s syntax, you may prefer to type the function directly into a cell.

Select a cell and press —(F3) to access the Insert Function dialog
box. If the selected cell already contains a formula, the Function Arguments
dialog box will be displayed.

To copy a function example to a worksheet for reference, select Help on this
function in the Insert Function dialog box, click How do I copy an example
under Example in the help topic for the function and follow the

instructions.
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Working with Functions Excel 2010 Intermediate

Working with Insert Function

1. In the Function workbook, display the SumIf worksheet.

2. Select cell B26.
3. Click | #|Insert Function on the Formula bar.

4. With the text in the Search for a function text box selected, type count and
click Go.

5. Select a few of the functions that appear in the Select a function list box and note
their descriptions; then select the COUNTIF function in the list.

6. Click Help on this function at the bottom of the Insert Function dialog box.

7. If you are not familiar with this function read the information and note the
examples. Close the Help window when you are finished.

8. Click OK to accept the COUNTIF function.

9. In the Function Arguments dialog box, note the description for the active
argument named Range and then click %) Collapse Dialog in the Range text box.

10. Select the range B8:B21 and press to expand the dialog box.
11. Type Engineering inthe Criteria argument text box.

12. Click in the Range text box and note the answer that appears in the Formula
result area. Click OK.

13. To create a SUMIF function that will add the amounts in column D based on the
department name, do the following:

o Select cell C26 and click | % | Insert Function on the Formula bar;

e In the Insert Function dialog box, select Math & Trig from the Or select a
category drop-down list;

o Inthe Select a function list box, choose SUMIF and click OK;

o In the Function Arguments box, enter the range B8:B21 as the Range
argument;

e Enter Engineering as the Criteria argument;
o Enter the range D8:D21 as the Sum_range argument;
o Check the formula result and then click OK.

14. Save the workbook.
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Try It

Working with the Functions List

In the Sumlf worksheet, type = in cell B27.

2. On the Formula bar, click the Functions list drop-down arrow and select
COUNTIF.

3. Drag the Function Arguments dialog box to the right of the worksheet data, if
necessary.

4. In the Function Arguments box, make sure the cursor is in the Range argument
box.

5. Inthe worksheet, select the range B8:B21.

6. Press to move the cursor to the Criteria argument box and then type
Finance for the Criteria argument.

7. Click OK.

8. Enter a SUMIF function in C27 to sum the mileage amount for the Finance
department. Use the Functions list to display the Function Arguments box for the
function.

9. Iftime allows, create COUNTIF and SUMIF functions for the remaining
departments.

10. Save the workbook.

Working with the Formulas Tab

1. In the Round worksheet, select cell D4.

2. On the Formulas tab, locate the Function Library group and click Math & Trig.

3. Select Round.

4. 1Inthe Number text box, type B4.

5. Inthe Num_digits text box, type CA.

6. Click OK.

7. Use the Auto Fill feature to copy the formula down the column.

8. Save the workbook.
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Using Financial

A financial function is a formula used to make a financial calculation. Most functions

Functions

require arguments to calculate the result. In financial functions, a negative number
represents any payment that is made; whereas amounts received are represented by a
positive number.

The PMT Function

One commonly used financial function is PMT. The PMT function calculates the
payment per period for a loan.

The syntax of the PMT function is as follows:

=PMT(Rate,Nper,Pv,Fv,Type)

=PMT (0.1,48,19000,,1)

Rate

Nper

Type

is the interest rate per period.
is the number of payments for the loan.

is the present value or amount of the loan.

is the cash balance at the end of the loan. This argument is optional

and defaults to 0 if omitted.

indicates when the payments are due. Payments due at the beginning
of the period = 1; payments due at the end of the period = 0. This

argument is optional and defaults to 0 if omitted.

The illustration below shows the Function Arguments dialog box for the PMT

function:

T T T I S

PR 1 - o
RunctionfAreumenis G NNNINSURIR

Rate 67 = 0.07
Nper (B8 ] =
Pv B6 T B = 14000
S - ®E-
Tye _[E -
= -4133,193633

Caladates the payment for a loan based on censtant payments and a constant interest rate.

Fv is the Future valus, or a cash balance you want to attain after the last
payment is made, 0 (2ero) if omitted.

Formula result = -4133,193633
Help on tis Function Lo ) [ camcel ]

2-20
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Using Financial Functions, continued:

The Rate Function

Another common financial function is the RATE function. RATE calculates the
periodic interest rate necessary for the present value to grow to the future value. The
syntax of the RATE function is as follows:

=RATE(Nper,Pmt,Pv,Fv,Type)

=RATE (48,-250,0,19000,1)

Nper is the number of payment periods.

Pmt is the payment per period. This number is traditionally a negative
number and cannot change over life of the investment.

Py is the present value.

Fv is the cash balance you wish to realize at the end of the period, the

future value. This argument is optional and defaults to 0 if omitted.

Type indicates when the payments are due. Payments due at the beginning
of the period = 1; payments due at the end of the period = 0. This
argument is optional and defaults to 0 if omitted.

The illustration below shows the RATE function from the syntax box above as it
would appear in the Function Arguments dialog box:

= TR R R A T T T P T T R T A T

" N
Nper |Bz0 )= 20 -
Pmt [B19 [B] = -1200
Pv|B18 =0
Fy!B17 (%] = 60000 .
Type k| =
= 0,087953515
Returns the interest rate per period of a loan or an investment. For example, use 6%/4 for
quarterly payments at 6% APR.

Fv is the future value, or a cash balance you want to attain after the last
payment is made. If omitted, uses Fv = 0.

Formua result = 0.087953515
Help an this function o )| cancel |
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Using Financial Functions

STEPS

Select the desired cell.
On the Formula tab, locate the Function library group and click Financial.
Select the desired function from the list.

Enter the required arguments.

Click OK.

The rate and number of periods must be consistent units in the PMT
function. For example, if you make annual payments on a five-year loan at
an 8% annual interest rate, you would specify 8% as the rate and 5 as the
nper. If you make monthly payments on the same loan, specify the rate as
8% / 12 and the nper as 5*12.

2-22
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10.

11.

12.

13.

14.

15.

16.

17.

Using Financial Functions

In the Function workbook, click the Financial Fx worksheet tab and select cell
B10.

On the Formula tab, locate the Function library group and click Financial.
Select PMT.

Make sure the cursor is in the Rate text box and then select cell B7 in the
worksheet.

Press to move to the Nper text box.

Set the Nper argument using the Term in BS.

Move to and then set the Pv argument using the Principal in B6.

Click OK.

Using the PMT function again, create a new formula in B11 that calculates the
monthly payment due on the loan. If you need a hint, hover the mouse pointer
over cell B11.

Change the Term to 5 in cell B8 and note the changes in the payments.

Select cell B22 and click [%] Insert Function.

Select the RATE function and click OK.

Enter the appropriate values from the worksheet into the Function Arguments
box.

o Nper—Term

¢ Pmt—-Payment

o Pv—Present Value
e Fv—Future Value

Check the formula result and then click OK.

On the Home tab click \j.ifij Increase Decimal twice to display the result with 2
decimal places.

Change the Future Value to $75, 000 and note the change in the rate.

Save the workbook.
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Dersseard N7RM1 2"23



Working with Functions

Excel 2010 Intermediate

Using Date Functions

Since Excel stores dates and times as serial values, you can perform complex date
and time arithmetic in your worksheets. The number 1 represents the beginning date
of January 1, 1900. Successive dates are numbered in order to represent the number
of days from the base date. For instance, the serial value for January 1, 2011 is
40,544 because it is that many days further on the timeline from the starting date.

Excel’s date functions can help you manipulate dates. For example, you can use a
date function to determine the year, month, or day on which a specific date falls.

Below are examples of several date function options:

=NOW()

=TODAY()

=YEAR(x)
=MONTH(x)
=DAY(x)
=WEEKDAY(x)

=DAYS360(startdate,
enddate)

enters today's date along with the current time into a cell.
You may need to change the format to see the time, which
shows as a decimal place. The NOW function updates each
time you open or recalculate the worksheet.

enters today's date into a cell. The TODAY function
updates each time you open or recalculate.

returns the year of the specified date (e.g., 1999, 2000).
returns the month of the specified date (e.g., 2, 12).
returns the day of the specified date (e.g., 13, 30).

enters the day of the week of the specified date. By default,
Sunday is equal to 1, Saturday is equal to 7.

calculates the numbers of days between two dates based on
a 360 day year.

The illustration below shows a worksheet containing several common date functions:

A Cc D [ E | F G
1
2 =NOW(} 5/13/2011 12:14
3 =TODAY() 511312011
4
5 Last day of the Year 12/3172011
6
7 =YEAR(C3} 2011
8 =MONTH(C3) 5
9 =DAY{C3) 13
10 =WEEKDAY{C3) 6 (1=Sunday. 2=Monday. 3=Tuesday. etc.}
1
12
13 =DAYS360{C3,C5) 228
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1

Using Date Functions

1]

- © e .
: @ 1. Select the desired cell.
- 2. Use the desired method to open the Insert Function dialog box.
STEPS P
- 3. Select Date from the Or select a category drop-down list.
- 4. Select the desired function from the Select a function list box.
5. Enter the required arguments.
- 6. Click OK.
- @ You can type dates directly in cells using either forward slashes or hyphens
- as separators. For instance, to enter December 31, 2011, you can type either
- 12/31/11 or 12-31-11. Excel will automatically format the cell as a date.
— Although you can type a two-digit year for a date, Excel will display the
- year with 4 digits. For instance, if you type 1/1/11, Excel will display
- 1/1/2011.
- December 31, 2029 is the last date for which you can type a two-digit year
K and get the correct year. For example, if you type 1/1/30 into a cell, Excel
. will display 1/1/1930. To avoid confusion, you may want to enter the year
2 with all four digits.

- N~ To display the serial value for the =TODAY{() or =NOW( ) functions or a

: Q date or time that you have entered into a cell, you must change the format of
- the cell. To format the cell, display the Home tab and locate the Number
group. Open the Number Format drop-down list and choose General or
Number.

[

Time values are stored in Excel as decimals after the date value. The

beginning of a day is 12:00 midnight; so, the value 0.5 represents 12:00

! noon. For example, if you enter the =NOW( ) function into a cell on January
1, 2011 at noon and format it to display the serial value, the number will

- show as 40544.5.

b
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Using Date Functions

1. Display the Date Functions worksheet in Function.

2. Type =today() in cell B14 and press [Enter«2).

3. Incell E4 use the DAYS360 function to calculate the approximate number days
since the last order date.

4. Use the Order Date in C4 as the Start_date argument.

5. Use the current date in B14 for the End date argument; make the reference to it
an absolute reference.

6. Copy the function down the column.

7. Save and close the workbook.
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Working with Formatting and Data Validation

I \

g with Formatting

ta Validation

Using conditional formatting
Using data validation
Creating and using custom formats

Working with auditing and error checking tools
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Applying Conditional Formatting

Conditional formatting facilitates data analysis by adding visual indicators to your
data that allow you to spot trends and recognize patterns at a glance. The formatting
applied to a cell is based on the cell’s value as compared to some criteria. Excel
provides several sets of built-in indicators that show values in relation to one another;
alternatively, you can apply formatting based on criteria that you set.

The Conditional Formatting options are found in the Styles group on the Home tab:

Canditional
Formatting v/

% Highlight Cells Rules »
Data Bars add a gradient bar fo a cell.

The length of the bar indicates the relative | ,% Top/Bottom Rules >
value of the cell data compared to other P
cells in the range.

Color Scales add shading to a cell using
a two or three color gradient scale. The
color and shade represent the relative
value in the cell.

| EEEE
icon Sels use special symbols such as / E kcon Sets ' ﬁ E ﬁ E !
arrows and traffic lights to indicale the cell

value. (B NewRule.. ﬁ % % ﬁl

@ Clear Rules »
@ Manage Rules...

v

More Rules... i

In the picture below, the Data Bars formatting appears on a range of cells:

1
Cllﬂ'q ®-is Datafist.xisx - Mirosoft Excel ,u__wg_gl S-S
ot Pagelayout  Fonmias  Oata  Rewew  View  Developer  Aadins Design oo

& TR . e . ﬁ e -vmut- :~
2 a- Anat Nammow 0 - A A wlad ¥ & e a H 3 ? m
i‘med B IO~ T &-,ﬁ,v!EBEEEﬂ&B $-% » 33 w-::m—w;'a - s-.ma:rmua:
Qipboard Font . Aligrment - Humber 5 Ceils Edting
o e %] sum0 { g Cets Rules » =
A __ .. 8B __c ] E | _F 1%1 ,- K [N M
— 'op/Boltom Ruses .
1 South Moon Under, Inc. = ,"‘
Sal n ; i
2 les Repo. E R , | GadiestFin
: S EE
‘ — . v
St54e B i
i | ] Bive bata Bar
- i View s colured Oata batinthe cell. |
R ca West t The length of the data bar i
e — SR Wax sepresents the value m the cell. &
10 YeexCoas Festors Porany oR Wee Mens Sniger £ EC3.Z) HewRule. ;2 longertar represents & hgher
13 -ResCoax Fashong Portand ] West Yomens Brucaber ‘33 Clesr Rutes > |
12 i¥esCons Fasoes San Frarcsto ca Mec Cniteas  Jores B 1 " .
13 Woruas Fastors SenFans  CA Wex Wars Sones “—‘ tanage Butes... I !
4 WesCoas Fasors Sar Fraeoses [¥) Wes #orens  Jores [ s:m i ldoteRules. t
MA Horhaas
3 MA Nerheas
= WA Norteas:
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Applying Conditional Formatting

STEPS

Select the range of data for the conditional formatting.
On the Home tab, locate the Styles group and click Conditional Formatting.

To format cells based on their value using one of the built-in indicators:

o Point to the Data Bars, Color Scales, or Icon Sets and then make a
selection from the submenu.

To format cells containing a certain value based on a rule:

o Point to Highlight Cell Rules and then select the type of rule from the
submenu;

o Define the criteria for the rule in the text box or boxes on the left;

o Select the formatting to apply in the with text box and then click OK.

To format cells with top or bottom ranked values:

e Point to Top/Bottom Rules and then select the type of rule from the
submenu;

o Set the number of items or percent;

e Select the formatting to apply in the with text box and then click OK.

To format cells with above average or below average values:

e Point to Top/Bottom Rules and then select the type of rule from the
submenu;

o Select the formatting to apply in the with text box and then click OK.

To create a rule for formatting cells in the New Formatting Rule dialog box:
o Select New Rule;
e Make a selection in the list under Select a Rule Type;

o Enter the rule criteria and formatting using the options under Edit the
Rule Description;

o Ifnecessary, click to set the formatting for the rule in the
Format Cells dialog box and click OK;

o Click OK in the New Formatting Rule dialog box.

To remove a rule or rules, do one of the following:
o Point to Clear Rules and make a selection.

o Select Manage Rules, select a rule to remove and click ; then
click OK.
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10.

11.

12.

13.

Applying Conditional Formatting
Open the Format workbook.
On the Conditional Format worksheet, note the formula used in column D.

Apply a conditional format to cells in column D that will display red if the value
in the cell is greater than the maximum allowance in cell B3:

o Select cells D7:D30;
o On the Home tab, locate the Styles group and click Conditional Formatting;
o Point to Highlight Cell Rules and choose Greater Than;

o Click in the text box under Format cells that are GREATER THAN and then
select B3 in the worksheet;

e Note that Light Red Fill will Dark Red Text is selected in the with list and
click OK.

Select cells C7:C30.
Click the Home tab, locate the Styles group and click Conditional Formatting.

Point to Data Bars. Point to the selections that appear on the Data Bars submenu
and view the previews in the worksheet.

Preview the Color Scales and Icon Sets formatting choices also.

With the data still selected point to Data Bars; select the first choice Blue Data
Bar. View the formatted data.

Select Conditional Formatting, then Manage Rules. Select Data Bar, click Delete
Rule and then click OK.

To apply a conditional format to the top 10 highest values in column C to display
green:

o Select cells C7:C30;
o  On the Home tab, locate the Styles group and select Conditional Format;
o Select Top/Bottom Rules and choose Top 10 Items;

e Select Green Fill with Dark Green Text from the with drop down and click
OK.

Select the Department names in cells B7 to B30.

Apply conditional formatting for the cells that contain the text Marketing with a
color of your choice to the selection and then view the data.

Save the workbook.

34
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Using Data Validation

Excel’s data validation feature can ensure that new data entered into a worksheet
range meets certain criteria. Data validation is often incorporated into worksheets or
forms, such as an expense report, to help other people enter information correctly.
When you set up data validation, you specify the criteria, and you can also create
on-screen prompts, such as directions and error messages, to assist a user.

Data validation settings do not affect data that is already in a cell. However, if you
change the existing data, the replacement data will be validated as you enter it.

The illustrations below show a worksheet using two areas of data validation:

==~ [5 D]
Client Code and Di Workst
{Company Name Code Contact Discount
5 ‘DMRMBW DESROS Jane Sullvan 6.0%
1l Capitan Hotel CAPTTAN  Roger Smith 10.0% =
7 'Hamiman Aulo Sales HARRI0T  Alice Haniman 5.0%
iKemymore AMC Jesp KERRO?  John Jones 55% @ Enter cient code again - 3 char min to 6 char max.
9 iLa Belle Epoque EPOQUE  Barbar Belford 4.5%
10 ‘Satum of Pinedale ~ SATPIN  ChesterHolloway  6.0% Coey ) (oo J [ w5 ]
11 'Waltham Stores, Inc. WALST1__Sam Billings 8.0%
Wheeler Industies  [wheel01 ]Gloria Cameron 7.0%
Clent Code Entry u.o0%
Enter dient code -3
charaderminto 6
character max
2.
! Conditional Format ll)a!ﬂ\l‘ah‘htbn; Qustom Fomats _'@B4l []
= =
[ I | E F | 6 H 1 J
Client Code and Discount Worksheet
Code Contact Discount R S N TRy
DESROS  .ane Sulfvan 6.0% {DiscountiError] v s ‘;i
CAPITAN  Roger Smith 10.0% w s e =
HARRIOT  Alice Hamiman 5.0%
KERRD1  Jahn Jones 5.56% @ Enter a discount between 5% and 15%.
BPOQUE  Barbar Belford 45%
SATPIN  Chester Holloway 6.0% Ceoy ) (oot } [ 1ep ]
WALST1  Sam Billings 8.0%
WHEE® L
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Using Data Validation, continued:

Specify the Criteria

The illustration below shows the Settings tab of the Data Validation dialog box,
where you specify the criteria for validation:

P -

E
d Ek o - R
it b 4 a2 s e D ey )

| Settings 1| tnput Message { Error Alert
‘ validation criteria

Select an option from the

drop-down list as defined S
inthetable below. =~ ——f—  {Decima! vl [4] tgnore blank

lo.as

! [ Apply these changes to all other cells with the same settings

[ ok ][ concel |

The information box below summarizes the options in the Allow drop-down list:

Whole Number, limits the data entered into cells to be of that exact type.
Decimal, Date, or You can specify a range of valid numbers, dates, or time
Time using the Minimum and Maximum text boxes. Minimum

and Maximum text boxes can contain a cell reference, a
formula, or they can be left blank.

List allows the user to specify a range of cells in the
worksheet that contain the list of all valid entries.

Text Length limits the number of characters that are valid as a cell
entry. This option does not automatically format cells as
text, and it does not limit the data type to text. The
number of characters can also refer to a number of digits.

Custom allows you to specify valid data based on the resuits of
calculations done on multiple cells. Entries in the
Formula text box should start with an equal sign and
must result in a logical value of TRUE or FALSE. An
example is: =A74>SUM(E73:F73)/10 where A74 is the
cell that is being checked for validation.
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Using Data Validation, continued:

Create a User Input Message

Use the Input Message tab of the Data Validation dialog box to create a prompt that
appears on the screen when a user selects a cell in a range set up for data validation.
The message can specify acceptable data types or limits on what can be entered into
the cells.

The illustration below shows a sample of a completed input message:

s T T e

{Data ¥alidation

Clear fo suppress the , Settings | {Inpuk Message | | Eror Alert |
display of an input i
message. [] show input message when cellis selected

When cell is selected, show this input message: :

Tle: i
| |Discount Entry |
Input message: |
{Enter a discount betweeen 5% and 15%. :

|
|

fat

il

Clear Al I o« [ cancel |

[N

Create a User Error Message

Use the Error Alert tab of the Data Validation dialog box to enter an error message
that appears on screen if invalid data is entered. Three different error alert styles are
available; the choices offered for the user to reenter data will vary based on the style
you select.

The illustration below shows a sample of a completed error alert:

;'Qata_ Yalidation

! Settings || Input Mes: Error Mlert }

Clear o suppress the ‘ [[nput Message |[Error er] | x

display of an error [] show eror alert after invaiid data is entered i

alert message, which When user enters invalid data, show this error alert: i

also tums off data !

validation. Styte: | e I

|stop ~|] Error P

Error message: !

@ {Enter a discount between 5% and 15%. | i

: L

| 2

{

f |

Returns every option !
on all three tabs to its

default value. -|_Qear AU f ook [ concel |
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Using Data Validation

STEPS

Select the cell or range of cells for data validation.
On the Data tab locate the Data Tools group and select Data Validation.

To specify data type and acceptable values:
e Click the Seftings tab;
e Open the Allow drop-down list and select the desired option;

e Ifnecessary, open the Data drop-down list, select an operator, and
provide Minimum and/or Maximum limits.

To create an input message:

e Select the Input Message tab;

o Ifdesired, type a title in the Title text box;

o Type the message contents in the Input Message text box.

To create an error prompt:
o Select the Error Alert tab;

o Open the Style drop-down list and select the desired option;
o If desired, type a title in the Title text box;

o Type the message contents in the Error message text box.

Click OK.

To create your own list of acceptable values for input, select the Seftings tab,
open the Allow drop-down list, choose List, and use [%.] Collapse Dialog in
the Source text box to specify a range in the worksheet where you have
entered allowable input. If you want to use a range on another worksheet,
give it a range name to be able to access it. When the user selects a cell in
the data validation range, a drop-down list of the entries becomes available.

If you do not create your own error message in a data validation range,
Excel displays a standard error message whenever a user enters invalid data.
The error message has options to retry input or cancel, which leaves the cell
contents unchanged.

The maximum number of characters for the input message is 255. Error
messages can be 225 characters.

To locate areas of a worksheet where data validation rules exist, on the
Home tab locate the Editing group and choose Find & Select. Choose Go To,
click Special, and choose Data validation. Leave All selected to have Excel
highlight all cells on the worksheet that are formatted with a data validation
rule; select Same to have Excel highlight only those cells that have the same
data validation rule as the currently selected cell.

3-8
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- Q/ Clearing the Show error alert after invalid data is entered check box on the

Error Alert tab will stop the display of an error alert prompt; however, it will
also turn off data validation altogether. Clearing the Show input message
when cell is selected checkbox on the Input Message tab will suppress the
input message when a cell is selected.

To identify cells with invalid data, on the Data tab, locate the Data Tools
group and click the Data Validation down arrow. Select Circle Invalid Data to
place a red circle in cells where the data is not valid; click Clear Validation
Circles to remove the red circles. Entering the correct data will also remove
the circles.

® By selecting different styles on the Error Alert tab, you can allow or limit

invalid data. The Stop style will not allow a user to enter invalid data.
However, the Warning and Information styles provide the user with an
option to enter invalid data.

Using Data Validation

Select the Data Validation worksheet in the Format workbook.

To see if any areas of data validation have already been set up on the worksheet:

o On the Home tab, locate the Editing Group and click Find & Select; select Go
To Special,

o Select Data validation; beneath the choice, leave Al] selected, and click OK.
Select cell B12 and note the data entry prompt.

Type the code WHEELO1 and press [Enter<).

In the error dialog box, click Retry and enter the code correctly as WHEEO1 .

To see how the data validation is set up for this area, click the Data tab, locate the
Data Tools group and select Data Validation. View the information on all three
tabs of the dialog box and click Cancel when finished.

To begin setting up data validation for the Discount area, select the range
D5:D13. On the Data tab, locate the Data Tools group and select Data Validation.

On the Settings tab, restrict the entries in this column as follows:
©  Open the Allow drop-down list and select Decimal;
o Inthe Data drop-down list, between should automatically be selected;

o Enter .05 inthe Minimum text box; and enter .15 in the Maximum text
box.

continued on next page
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10.

11.
12.
13.
14.

15.

16.

17.

18.

19.

20.

Using Data Validation, continued
Click the Input Message tab and do the following:
o Type Discount Entry in the Title text box;

o Type Enter a discount between 5% and 15% inthe Input
message text box;

o Ensure that Show input message when cell is selected is enabled.
Click the Emor Alert tab and create an error message as follows:
o Ensure that Show error alert after invalid data is entered is selected;

o View the choices in the Style drop-down list and select Stop as the error alert
style;

e Type Discount Error as the error message title;

o Type Enter a discount between 5% and 15% as the error
message.

Click OK.
Select cell D12 and enter 7%.
Enter 16% incell D13.
Click Refry in the Discount Error dialog box, and then enter 12%.

To change the error alert style for the discount area, select D5:D13 and do the
following:

e Open the Data Validation dialog box;
e On the Ermor Alert tab, change the Style from Stop to Warning,
o Click OK.

In cell D13, enter 16% and click Yes to continue.

On the Data tab, locate the Data Tools group and click the Data Validation down
arrow; select Circle Invalid Data.

Enter 14% in cell D13 to correct the error and note that the red circle
disappears.

Click the Data Validation down arrow and select Clear Validation Circles.

Save the workbook.

2 4N
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1.

Using Data Validation with a List of Values

In this exercise we will use lists of acceptable values to complete areas of data
validation for the customers and sales reps.

In the Format workbook, select the Custom Formats worksheet. Note the
customer and sales rep information in columns A and B.

Open the Name box drop-down list on the Formula bar and select the range name
Customers. Note that the range is on the Lists worksheet.

Select the SalesReps range name from the Name box. Note that both lists are in
alphabetical order and contain the same information as on the Custom Formats
worksheet.

Return to the Custom Formats worksheet.

To create the validation area for customer names, do the following:

Select the range A4:A25;

On the Data tab, locate the Data Tools group and click Data Validation;
On the Settings tab, do the following:

— Select List from the Allow drop-down list;

— Press to display the Paste Name dialog box with a list of range
names for the current workbook;

—  Select Customers and click OK;

— Press to expand the dialog box.
Click the Input Message tab and do the following:
— Type Customers as the title;

— Type Please choose a customer from the list asthe
message.

On the Error Alert tab, create a Stop style alert with the title and message of
your choice and click OK.

Select cell A13 and test the drop-down list to enter any customer.

If desired, create another area of data validation in cells B4:B25 on the Custom
Formats worksheet using the SalesRep named range.

Hide the Lists sheet and save the workbook.

® 2011 Online Consuitina. Inc.. Revised 07/26/11
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Creating and Using Custom Formats

If none of the available built-in formats meet your needs, you can create your own
format scheme. For example, if you want to add a three-letter prefix to purchase
order numbers or add a state code to form numbers, you can devise a custom format

to accomplish such tasks.

When you create a custom format, it is placed at the bottom of the Type list on the
Number tab of the Format Cells dialog box as below:

g e ey et o

Format Cellss =
e b

ig’Nmnber“; gligwent ~ Font | Border  Pattems  Protection
| Category: Sample )
t TGeneral i 43-3453-A0 _}  Displays asample as
| {Number i you create a format.
{ I Currency ! Type: o
‘ gcai:mtmg | [43-00004A0 - - I(ye?: the new code
‘ { Percentage [T ,#20.0); (4 (#,##0.0);_($ —
%gr?ctigf?c ! xﬁ(g* #0200, _($* (#,##0);_($* " Select a format from
i 1 Scientil . —d A .
ilgg g:;tom fo | {Text L (F R ER0.00; (% (#,#40.0);_(*" the list to modify.
access 1l | |special (e Re0 ) (@ R0y 62—
custom formats. —| el R R T ] '
Removesthe —f= | Delete t - Custom formats appear
selected custom % at the botiom of the fist.
format from the fist. } | Type the number Format code, using one of the existing codes as a starting |
Does not remove | point,
built-in formats.
| i
r OK ] rCancel J
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Creating Custom Formats

Select the desired cell or cells.

9. Use the desired method to display the Format Cells dialog box:

o On the Home tab, locate the Cells group and select Format; select Format
Cells.

o Right-click the selection; select Format Cells.

3. On the Number tab, select Custom from the Category list and do one of the
following:

e To base the new format on an existing format, select the desired format
from the list under the Type text box.

o To start from scratch, select any format that appears in the Type text box
to replace it when you type.

4. Type or modify the custom format code.

5. Click OK.

Use # as a number placeholder for significant digits. Use 0 as a placeholder
for leading or trailing zeroes.

To copy a custom format to another workbook, copy a cell with the desired
format. Open the destination workbook and select the desired cell. Click
the Paste down arrow and select Paste Special and then Formats. Click OK.

For more information on the special characters that can be used in custom
formats look up “number format codes” in Help.

The backslash character ( \ ) appears in custom formats immediately to the
left of any character that appear literally in a format and is inserted
automatically in front of any character that isn't a placeholder character. To
include a placeholder character in a format as a literal character, you must
precede it with the backslash when you enter the format.

® Custom formats are workbook dependent and are, therefore, only available
in the workbook in which they are created. If custom formats are needed in
various workbooks, create and save them as a template file.

If a built-in format is selected in the Type list, the Delete button will be
unavailable because you cannot remove built-in formats. You can only
delete custom formats.
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Using Custom Formats

9
STEPS

Try Bt

Select the desired cells.

Use the desired method to display the Format Cells dialog box:

©  On the Home tab, locate the Cells group and select Format; choose
Format Cells.

o Right-click the selection; select Format Cells.
On the Number tab, select Custom from the Category list.
Select the custom format from the list under Type.

Click OK.

Creating and Using Custom Formats
In the Format workbook on the Custom Formats sheet, select the range C4:C13.
Right-click the selected range and select Format Cells.
On the Number tab, select Custom from the Category list.

Note that the Sample area shows the first number in the list. Double-click the
information in the Type text box.

Type 43-#-A0 as the format, note the information under Sample, and click OK.
Note the change in the order numbers in column C.

In cell C12, enter 9845 as the order number.
In cell C13, enter 0503 as the order number.

To modify the custom format:

o Select the range C4:C13;

e Open the Format Cells dialog box;

o Select the Custom category and scroll to the bottom of the Type list;

e Select your custom format and note that Excel automatically placed a\ in
front of the text portion of the format;

o In the Type text box, change the format to 43-0000-\A0.

Save the workbook.

3-14
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Working with Auditing and Error Checking Tools

Excel has many features to assist you in determining how information in one part of
the worksheet relates to information in another part. Several tools are also available
to find worksheet errors and to analyze formulas.

The Formula Auditing group on the Formulas tab has many useful tools as shown

below:
Shows the cells Shows the formulas
towhicha in each cell instead
formula refers. of the value.
Showswhich | S 1race Precedents Show Formulas “““ Opens the Waich
formulas use the 3 =;, = window to monitor
selecied cell, —=%%Trace Dependents ¥ Error Checki values in ceriain cells.
i Watch
,,-3, RemovejArrows ~ @ Evaluate ormuld\  Window
Formula Auditm
Removes all Opens the Evaluale Checks for
tracer arrows. Formula dialog box. worksheet efrors.

Two important terms are defined below:

Precedents are cells referenced in a formula. For instance, if the formula in
cell C10 is =A10-B10, then A10 and B10 are precedents of cell
C10. Precedent cells can contain either values or formulas and are
indicated by dots in the illustration below.

Dependents  are cells that use the value of the selected cell and, thus, are
dependent upon it. In the example above, C10 is a dependent of
both A10 and B10. Dependent cells always contain a formula and
are indicated by arrows in the illustration below.

The arrows in the illustration below indicate the direction of the data flow.
In the illustration below, the Trace Dependents button was clicked twice to show the
cells where the Product Price is used.
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Working with Auditing and Error Checking Tools, continued:

When you have an error in a worksheet cell you can use the Error Checking dialog
box for assistance as shown below:

gt W
“a

RN S g g A e,

Shows the error Ervorin cB1,C6 £ Fielp on this ]
Help on eror
cell and formula. { =B5*$C418 -
Error in Value [ Show Calculation Steps. .. ]
Explains the A value used in the formula is of the wrong
type of eror. data type. L Ignore Error ]
[‘ ~ Editin Formula Bar + — Lets you correct
the formula.
Options... { Previous | [ mext |
I ]
l |
Opens the Options dialog box where you Moves fo the previous or next error.

can customize the error checking rules.

The rules that Excel uses to check errors can be customized in the Options dialog box
shown below:

L&"ml ] % Change options related to formula calculation, perfarmance, and error handling.
Formutas
Proofing Calcntation oplions
Save Workbook Calculation i Enable jterative calcutation
QO Automatic Tterati
tanguage @ Automatic except for data tables ::-:::: Qnan °:g ‘%—:i—
Advanced O Manual e 2
Pelazuale b 2ok LetCreang
Customize Ribbon
Quitk Access Toolbar ; Waorking with formatas
Adddns 3 mic1 reference styte- -
{¥] Eormuta AutoComptete-+:
Teust Center [ Use table names in formulas
I [¥] Use GetPivotData functions for PivotTable references
! Error Checking .
N Resets erors that were ignored
Erable background errat checking (Fesdiormatrong— 0Uring emor checking.
Indicate grross using this colon
A~ Enor chiecking nutes
[ Cepis containing Tormulas that result in an emor [ Formutas which gmit cells in a region +
Select the m"es ] Inconsistent aiculated cotumn formula in tables + v cells .
that Excel will use (4] Cetis containing yeers represented as 2 digits } 7 Formytas refenring to empty cefis +
to check for errors. [} astedor byanapostrophe::- (7] Data entered m a table is inyatd ¢
\1‘ [4] Formulas inconsistent with other fomulas in the region 1°
i p——
(anar ]|
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Working with Auditing and Error Checking Tools, continued:

Whenever you have an error in a worksheet formula, a green triangle will display in

the upper-left corner of the cell and the |<®| Trace Eror button will appear when the
- cell is selected. Point to the Trace Error button to display a ScreenTip describing the
- error or click the button to display a list of commands.

The Trace Error button, illustrated below, has many of the same choices as the Error

Checking dialog box:
_—:M - BVALUE

Error in Value

Help on this error

Show Galculation Steps...

Ignore Error

- Edit in Formula Bar

Error Checking Options...

- When you select Show Calculation Steps in the menu above, the Evaluate Formula
- dialog box, which is illustrated below, opens:

T ot e e e e e e e~ e i~ e

tvaluate/Formula

; A
e e T S G ey ST, T 7 k]

S Reference: Eyaluation:
= Solvmod!$C$6 = |"Units Sold"*42

) The next evaluation will result in an error.,

Click to see the value of each part of a formula. This
is most helpful with complex nested formulas.

A ANLA Mrbina Panccdiines e Baciend A70a144 247



Working with Formatting and Data Validation Excel 2010 Intermediate

Working with Auditing Tools

©
STEPS

To identify all the cells referenced in a formula (the precedents):
o Select the cell containing the formula;
o On the Formulas tab, locate the Formula Auditing group;

o Click [B=Trace Precedents|.

To display all the formulas that use a specific cell (the dependents):
o Select the cell;
o On the Formulas tab, locate the Formula Auditing group;

o Click [nc-:'*, frace Dependentﬂ_

To remove the tracing arrows:
o On the Formulas tab, locate the Formula Auditing group;
~ Click l.aa Remove Arrows| ~| Remove ATows to remove all arrows.

—  Click the | 4% Remove Amows|~| down arrow and select Remove Precedent
Arrows.

—  Click the |[¢& Remave Arrows|~| down arrow and select Remove
Dependent Arrows.

&

The tracer arrows can be used to navigate through the worksheet. Double-
click a tracer arrow to move the cell pointer to the cell referenced at the end
of the arrow.

Tracing arrows cannot be removed by the Undo command.

P e Amm b Deddead NT7IORMA1
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Working with Error Checking Tools

© o . '
1. To open the Error Checking dialog box:

o Select the cell containing an error;
STEPS

o On the Formulas tab, locate the Formula Auditing group;

o Click [% Error thecing)~|,

2. To trace the flow of data to an error value:
o Select the cell containing an error value;
e  On the Formulas tab, locate the Formula Auditing group;
e Click the |—£:55:d?éd5n§1'l down arrow;

e Select Trace Error.

3. To open the Evaluate Formula dialog box, choose one of the following:

o On the Formulas tab, locate the Formula Auditing group; click
| Bxaiuate Formuia),

o Click Show Calculation Steps in the Error Checking dialog box.

4. To customize the error checking rules, do one of the following:

e Click Options in the Error Checking dialog box.
e  Click the File tab and click| £ Otions | click Formulas.

To add a note to a cell, right-click the cell and select Insert Comment. Type
the desired text and click any cell in the worksheet.

Cells that contain comments appear with a small red triangle in their
upper-right corner.

To view a comment, position the mouse pointer over the cell. In order to see
the comment, the mouse pointer must be shaped asa .

To remove a comment from a cell, right-click the cell and select Delete
Comment.

To change a comment, right-click the cell and select Edit Comment.
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. Q To see worksheet formulas instead of the results, on the Formulas tab, locate

the Formula Auditing group and click Show Formulas. Click Show Formulas
again to return to the results instead of the formulas.

To get to formula auditing mode for an individual formula, double-click the
formula.

When you need to monitor a formula as you make changes to other areas of
your workbook, turn on the Watch Window and add the formula that will be
monitored. To open the Watch Window, display the Formulas tab, locate the

Formula Auditing group and click Watch Window.

10.

1.

Working with Auditing and Error Checking Tools
Move to the Auditing worksheet in Format.
On the Formulas tab locate the Formula Auditing group.

To work with precedents and dependents:

o Select cell G13 and click [P Trace Precedents |

o  Click [£*Trce Precedents| a second time;

o  Click the |2 Remove Amowsi ~ [ down arrow and select Remove Precedent
Arrows; do this again to remove the second set of arrows;

e Select cell C18 and click | Trace Dependents |,

e Click @'ﬁ; Dépe;d;n—“l a second time;
e  Click |4 Remove Arrows|-|.

Change the formula in C6 to =B5*$C$18 to create worksheet errors.

With C6 as the active cell, click the [ Emor thedingi~| down arrow and select
Trace Error.

Click |42 Remove Arrowsi~| on the Ribbon.

Click [ Emor Checing ~|,

Click Next to move to the next error; then click Previous to return to cell C6.

Click Show Calculation Steps to view the Evaluate Formula dialog box and then
click Close.

Click Edit in Formula Bar to correct the formula from B5 back to C5; then click
Resume and click OK.

Save and close the workbook.

3-20
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Excel 2010 Intermediate Working with Formatting and Data Validation

10.

11.

12.

13.

14.

15.

Review - Worksheets, Functions, and Conditional Formatting
Open the Orders workbook.

Move the Annual Summary and Profit and Loss worksheets to the end of the
workbook.

Group the Quarter 1 through Quarter 4 worksheets.

On the Quarter 1 worksheet, select cell B32 and create an AVERAGE function for
the range B7:B30.

Copy the function across the row to column I.
Select the Quarter 2 worksheet tab.

Format the values in rows 7 and 32 as Accounting with 2 decimal places and the
dollar symbol.

Format the remaining rows to align rows 7 and 32, but without a dollar sign.
Ungroup the worksheets.

Select the Profit and Loss worksheet. Apply conditional formatting that will
display negative cell entries in light red fill with dark red text to the range
B7:F14.

Create totals in row 16 of the Profit and Loss worksheet.

In column G use the ROUND function to round the numbers in column F to the
nearest thousand.

On the Annual Summary worksheet, create a 3-D sum in B7 to add the values in
B7 on each of the quarterly worksheets.

Copy the formula in B7 down and across the sheet to create the summary
information for each product and company name.

Save and close the workbook.
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Excel 2010 Intermediate Working with Charts

g with Charts

Creating Charts

Changing the chart location and size
Changing the chart type

s : _ Modifying chart elements
Formatting chart elements

Adding and removing data series
Printing charts

Creating and using a chart template

Creating a Sparkline
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Working with Charts

Excel 2010 Intermediate

Creating Charts

This range is
selected to create
the chart below.

A chart is a visual representation of data from a worksheet that shows comparisons,
trends, or patterns. The enhancements to the charting feature in Excel 2010 help you

create professional—looking charts. Three contextual tabs, Design, Layout, and

Format, expose the galleries, options, and other tools for working with charts. The
Chart Styles gallery provides over forty choices for formatting charts. Additionally, if
you develop a custom design for your charts, you can easily save it as a template so

that it can be used over and over again.

The illustration below shows a worksheet with data selected to create a chart:

il A ] B | [ ] D | E
11 Glad Rags International
2 . Quarterly Report
| 3

-
5_|Region Y1D
6 | Nosth $804,000
7 | South $529,000
8 | East $586,000
9| West $296,000
10 Total Sales $2,214,000
11!
12 |Expenses $223,000 $214,000 $245.000 $682,000
13
[14 Profit $472,000 $549,000 $511,000  $1,532,000

The following illustration shows an Excel column chart and the contextual Chart
Tools that appear in the Ribbon when the chart is active:

- wioe tan Devicod NTIPRIMA
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Creating Charts

(2]
%&)% 1. Select the data for the chart.

2. Click the Insert tab, locate the Charts group and do one of the following:
o Open the gallery for the type of chart to insert and select a chart subtype.

e Click the ['#] dialog launcher to open the Insert Chart dialog box to see
all chart types; select a subtype and click OK.

9 The Excel 2010 charting feature is shared with Word and PowerPoint. If
you create a chart in one of those applications, you will have all of the same
tools and options that are available in Excel.

A Select data and then press (F11] to quickly create a chart with the default
Q settings on a new chart sheet.

To change the default chart type, select a chart type or chart template in the
Insert Chart dialog box and click [ setasbefaitchert |,

® The Live Preview feature does not work with the Chart Styles gallery.

Creating Charts

1. Open the Charts workbook, switch to the Chart Data worksheet, if necessary.
2. Select the range A5 to D9.

3. Click the Insert tab and locate the Charts group.

4. Click Column and view the different column charts. Point to a chart type and note
the description in the ScreenTip.

5. In the choices under 3-D Column, select Stacked Column in 3-D.

6. Save the workbook.

© 2011 Onlina Canaliltinn Inn Revised 07/26/11 4'3
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Excel 2010 Intermediate

Changing the Chart Location and Size

When you create a chart, Excel sizes and places the chart on the worksheet. If you
don’t like the chart’s position, you can move it to a different location on the
worksheet by dragging any portion of the chart outside its plot area. To resize a chart,
you need to select its chart area so that sizing handles appear around the periphery of
the chart; you can drag the handles to resize the chart.

You can also relocate a chart to a separate chart sheet or vice versa. When you switch
a chart’s location in this manner, Excel will automatically resize the chart and its
elements, including text, and you may have to manually adjust areas of the chart to
your liking. Charts on chart sheets are created in a standard size and the chart area
cannot be resized, although you can resize chart objects, such as the plot and text, to
make the chart appear larger or smaller.

When an embedded chart’s Chart Area is selected, sizing handles appear around the
chart as in the illustration below:

—— — — ~

([zg Thasae - buersaoh Fee o=Ex
bﬂ_-t-:_w _Pimen  fomun Do Remes  Viow Dessper § Ocon  tayed ot | c@oan
Zﬂ o e ¥ e —— N
BE DS GE D (k| S, [l e, - 2
Ot Type Tempiale * RowaColoms  Dats - - T Ot
B2 oo -1 guam N\ .
The Name box displays [@2-*-30d 289 < ' Contextual tools for .
the chart name. EE TR 1H 5 o~ working with charts, |~
i Glod Rlags imtarmadensl B
: Quanesly Report
6 Nech 80000 $2576°  S2VEN  SBOALN
7 Sowh SM5008.  SWIEZ0  $1S7.000
0 Esst 3190809 $187,030 208,630 $585,008
S West $80.000 $52,030 St 03 $285830
13 Teolal Seles $635,000 $756.008 52214000
‘};’,aqu- $223£00  S2ME0  SMEE  SBR26X
:‘E— Prolit {72800 549,000 $511028 $1.512008 R
w B . P — S H
An active ‘;ha“ haasc?u A é/] FirstQuarter Sales 4———— Click on the background
sizing han !e ate » _ seme ¢ i of achart to select the
comer and in the z v bt — i chart area and make the
middle of each side. —— 1'-—; i sunse . ' chart active.
% 0 [ ———
b/
= l B
>
32 e e e ——— e — e
k]
O:F"' » . ~ W _ ’




Excel 2010 Intermediate

Working with Charts

Changing the Chart Location and Size, continued:

The Move Chart dialog box that is displayed when you move a chart is illustrated

below:

e

{Move Chart

Choose where you want the chart to be placed:

Bl ©newsheet: iviD
ol |

Lﬁ__‘!_;: O Objectin:  |Chart Data

f7] Chasts.xisx - Microsolt Excel | sheie | B a’
towe  bwt  Powttwns  fomi  Ous  Meww  Vior Do | Dowe | lyow fews B c@c@z,
5] B 5o isE. | : se [aa | %
BN 2N pogdlen- g%"&,]&, 88 |23 .e8 |88 . >
Cranthpe Vemgisle  RowTobsmn Dola  — - ——rr —-ToM.. | ! e
S9C-Fad A |
B T . _ __ _ ] R -1
t
i
ek s
--_,:{; - afek =}
R o
asr Wt i
TV W] Sy G Ptk VIO O, T i Condl e - 95, e = 7
ety | 53§ (oS G [CI]
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Working with Charts Excel 2010 Intermediate

Changing a Chart's Location and Size

(5]
@ 1. To move an embedded chart to a different location on the current worksheet:
e Click in the chart to make it active;
STEPS

o Position the mouse pointer on the chart’s frame but not on the sizing
handles so that the ScreenTip says “Chart Area”;

o Drag the chart to the desired location.

2. To resize an embedded chart;
o Click in the chart to make it active;

o Position the mouse pointer on the chart’s frame in a corner of the chart so
that the ScreenTip says “Chart Area”;

o Click to select the chart;

o Position the mouse pointer over the desired sizing handle so that it
appears as l.e,N o

o Dragaway from the center of the chart to make it larger; drag toward the

center of the chart to make it smaller.
3. To relocate a chart to another sheet:

o Select the chart;

o On the Ribbon select the Design tab of the Chart Tools;

o In the Location group, select Move Chart;

e To move an embedded chart to a chart sheet:
—  Select New sheet and, optionally, type a name for the new sheet.

o To move a chart from its own sheet to embed it on a worksheet:

—  Select Object in and use the drop-down list to select the desired
worksheet.

o Click OK.

By default, charts are created as an embedded object on the source data
worksheet. Once created, they can be moved, resized or placed on a separate
worksheet.

To delete an embedded chart, select the frame and press [Delete).

To delete a chart sheet, right-click the chart sheet tab, choose Delete, and
click Delete.

.+ To maintain an embedded chart’s proportions while resizing it, hold down
Q‘ while dragging a corner handle.

To maintain the location of the center of an embedded chart while resizing
it, hold down while dragging any sizing handle.

A 3111 Onlina Conailting Ine . Revised 07/26/11




Excel 2010 Intermediate Working with Charts

Changing a Chart's Location and Size

1. On the Chart Data worksheet make sure the newly-created chart is selected.

2. To move the new embedded chart to a separate worksheet:
o Click the Design tab of the Chart Tools;
e In the Location group, click Move Chart;
o Select New sheet,
o Type Summary asthe sheet name;

o Click OK.
3. Return to the Chart Data worksheet and select the existing cylinder chart.

4. Resize the chart by dragging the upper right hand corner of the chart frame so it
stretches out to right edge of column F.

5. Reposition the chart so it is centered under the worksheet data with the upper left
corner in A16.

6. Save the workbook.

@& 2N11 Onlina Cananltina Ine Revdcead N712R141 ALY



Working with Charts

Excel 2010 Intermediate

Changing the Chart Type

Once a chart has been created, the chart type may be changed at any time. Some of
the main types of charts available are column, line, pie, bar, area, and scatter. The
other types of charts available are stock, surface, doughnut, bubble and radar. In
addition, 3-D types are available for area, bar, column, line, pie, surface, cylinder,
cone, and pyramid charts. Each of these main chart types has a gallery of several sub-
type choices. Additionally, a number of custom chart types are available.

Below is an illustration of the Change Chart Type dialog box:

T S N T T T T s

Change Chart Typ

& Pie o | ipE K=1 ) N ]
: : T [ = u H ' L{k:ﬂ J" J. A J. I,\ —
ew 0b))e0] BB B Jh 4 Jal J04
Jos mrea p——— — e o —
Lists available s CoA ,& T A
chart types o wveam A ;Jﬁé& JAA] Il
i stock ¢ L = L
‘,A._" Lme
gr— Ll N e B P B = H PR R P
i ?g B’.bble “l‘ l 8 l L
:ﬁ Radar . Pie - - - - —
‘ S et Hersr IR | Rats Rra: v
[ Manage Templates... | | SetasDefault Chart | ook ][ cance )
e e s
Sets the selected chart type as
the default type for new charts.
4-8
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Working with Charts

Changing the Chart Type

©
STEPS

. Make the chart active.

. Display the Design tab of the Chart Tools.

Locate the Type group and click Change Chart Type.
Select the desired chart type and, if necessary, choose a sub-type.

Click OK.

After the chart type is selected, the data can be switched from the row to
column. To make this change, on the Design tab of the Chart Tools, locate
the Data group and click Switch Row/Column. Click it again to switch it back.

Changing the Chart Type
Move to the Format Chart sheet in the Charts workbook and click in the chart.

On the Design tab of the Chart Tools, locate the Type group and click Change
Chart Type.

Choose Bar from the list of chart types.

Explore different chart sub-types.

Select Clustered Bar in 3-D and click OK.

Change the chart type to the Clustered Horizontal Cylinder style.

On the YTD Chart sheet, change the chart to a Pie in 3-D chart.

Save the workbook.

g Amianaa A.Q




Workingﬂith Charts Excel 2010 Intermediate

Modifying Chart Elements

In order to modify a chart, you need to click in it to make it active. Depending upon
where you click, an object within the chart will be selected, thereby activating the
whole chart. As you move the mouse pointer over an active chart, ScreenTips display
the name of the chart element beneath the pointer so you can select the object by
clicking the mouse.

The illustration below identifies typical chart elements:;

First Quarter Sales

<+— Chart Are

Gridlines

sam.o0 $763,000 $756,000

g
g

ssi000 g¢———— Data Labx

BTotal Sales -
AExperses <4 Legend

o Proft

sug: in Dolars
g

Data Marker

Data table P [w ot sae 569,000 755,000 756,000
D Expenses 5223,000 $214,000 5245 000
$472,000 $549,000 $511,000

You can also select chart elements from the Chart Elements drop-down list on the
Layout tab of the Chart Tools as illustrated below:

Chart Atea

Back Wall

| Chart Area !
Chart Title

Data Table

Floor

Horizontal {Category) Axis

tegend

Plot Area

Side Wall

Vertical (Value} Axis

Vertical (Value} Axis Major Gridlines
Vertical (Value} Axis Title

Walls

Series Total Sales”

Series “Total Sales™ Data Labels
Series “Expenses”

Series “Expenses” Data Labels
Series “Profit”

Series “Profit” Data Labels
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Excel 2010 intermediate Working with Charts

Modifying Chart Elements, continued:

The Design tab of the Chart Tools provides options to change the chart type, modify
the data source, change the chart layout, select a chart styles or change the location.
The Design tab is displayed below:

: Design {'

D% 58 EER b [ [ [, - =

ChartType Template Row/Column Data -————' ———
Type Data Chart Layouts

Chart Stylas Loaation

The Layout tab of the Chart Tools provides options to add, remove or customize
chart elements such as the titles, labels and legend shown in the illustration below:

— e —— — ———— ‘ - - . -
i Chart Area - - - - 2 iy g . Chart Wall ~ - tine: Chant Mame:
: ool P 53] ] P2] o8 ] (@) ] @ it -
: 8 Format Selection by ot o o oo | G Al chartFloor-  —'  :JUp DosnBu:  Chat2
' Pidure Shapes Chart s Llegen ta Azes  Gridines  Plot Trendline
: &8 Resetto Match Styte v Box  Tilew THlesr o Laneie Tablew .~ . 22 i) 3-DRotahon _JEmorgar:
Current Seledion . Insert. Labels 1 Axes Badkground Analysis Properties

Modifying Chart Elements

© (53 .. . .
1. Click in the chart to make it active;
(<] 1V

2. To modify a chart using the shortcut menus:
STEPS - . .
e Right-click the object to be modified;

e Select the appropriate choice;

© Make the desired changes in the dialog box;

e Click OK.

3. To modify a chart using the Ribbon:
o If necessary, click the desired area of the chart to select it;
o In the Chart Tools, click the desired button Design or Layout tab.

0 When a chart is active, the Chart Tools contextual tabs are displayed.

On the Layout tab of the Chart Tools, the chart elements list changes to
reflect whatever object is selected in a chart.

~y- Asyoumove the mouse pointer over a chart, ScreenTips appear to help yon
Q identify which chart object will be made active if you click either the left or
right mouse button.

© 2011 Online Consultina. Inc.. Revised 07/26/44 4.41
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Excel 2010 Intermediate

9.

Modifying Chart Elements
On the YTD Chart sheet in Charts, make sure the pie chart is active.

On the Design tab of the Chart Tools, locate the Chart Styles group and click on
one of the visible styles.

In the Chart Styles group, click the drop-down arrow for more options and select
a style of your choice.

On the Design tab of the Chart Tools, locate the Chart Layouts group and click
the first choice (Layout 1). Notice additional elements are added to the pie chart.

Select the Summary sheet; activate the chart, if necessary.

On the Layout tab of the Chart Tools, locate the Labels group. Click Chart Title and
then Above Chart.

With the Chart Title already selected, type First Quarter Sales and
press (Enter+].

On the Layout tab of the Chart Tools, locate the Labels group and click Axis Titles.
Point to Primary Vertical Axis Title and then click Vertical Title.

Type Sales in Dollars and press [Enter<2).

10. Add a horizontal axis title and type Region as the text.

11. Save the workbook.

412
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Formatting Chart Elements

Select a chart
element in the
drop-down list.

Charts are comprised of individual elements that you can modify using the formatting
options that correspond with the element. Formatting chart elements changes or

enhances their appearance.

All of Excel’s chart elements have corresponding Format dialog boxes that contain
options to alter that specific chart element; you can also transform chart elements
using tools on the Format tab of the Chart Tools. For instance, you can format text
elements in a chart by choosing a different style, alignment, orientation, and font size
to improve the readability. Enclosed elements, such as a slice in a pie chart or the
area surrounding a text object, can be filled with different colors or fill effects like
textures and patterns. Additionally, you can alter the borderlines of various elements,
such as the data series, axis, legend, title text, or text boxes.

The Chart Elements drop-down list pictured below shows the Legend as the selected
chart element. Clicking the Format Selection tool with Legend as the selected
element displays the corresponding Format Legend dialog box with the choices for

formatting the legend:

egend [

[ Back Wall
Chart Area
Chart Title
Data Table
Floor
Horizontal {(Categony) Axis
itegend
Plot Area
Side Wallt
< Vertical (Value) Axis
Vertical (Value) Axis Major Gridlines
Vertical (Value} Axis Title
Walls
Series “Total Sales™
Series “Total Sales” Data Labels
Series “Expenses”
Series "Expenses” Data Labels
Series "Profit”
k Series “Profit” Data Labels

[
>~

o

Glow and Soft Edges

Fill

Ot

O soid

@® Gradentfl

O pictisre or texture £l

O rattem ft

O Hutomatic
Preset eolors:
Type:

Direction:
Angle:
Gradient

T
<

stops

@I"__“ 1
Coor pestion: [o% <]
Bhiness:
Tangpareney:

St msTane
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Working with Charts

Excel 2010 Intermediate

Formatting Chart Elements

09
STEPS

Make the chart active.

On the Layout or Format tab of the Chart Tools, locate the Current Selection
group.

Open the Chart Elements list and select the element to format.

Do one of the following:

Click [& Farmat seiedion| in the Current Selection group, make the desired
selections in the Format dialog box and click Close.

Use any applicable tools on the Format tab of the Chart Tools or the Home
tab.

As you move your mouse pointer over a chart, ScreenTips show the name
of the chart elements.

To quickly display the respective format dialog box for a chart element,
right-click the element and choose Format <Object Name>.

When a chart element is selected, its name is displayed in the Chart Elements
drop-down list in the Current Selection group.

To delete a chart element in an active chart, select it and press [Delete).

To select one data label or one entry in a legend, click to first select the
whole legend or all data labels; then click the desired label or entry within
the selected object and format as desired.

To create a gradient, texture, pattern, or picture fill for a selected element,
click Fill in the Format dialog box. Make the desired choices and click
Close.

To select one data marker in a series, click any marker in the series, then
click the desired marker.

To move chart legends, titles, or data labels, click the desired chart object to
select it. With the mouse pointer as a [k , drag the object to the desired
position.

Data labels are used to identify chart data series with values, percents,
labels, or various combinations.

You can format chart text using WordArt Styles. Select the text and display
the Format tab of the Chart Tools; open the WordArt Styles gallery and
make a selection.

The Format tab of the Chart Tools contains the Shape Styles group. Use the
tools in this group to apply formatting to selected chart elements.

® 2011 Online Consulting, Inc., Revised 07/26/11
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Working with Charts

Formatting Chart Elements, continued:

g

If your value-axis units are large numbers, you can change the display using
the Display units drop-down list in the Axis Options category of the Format
Axis dialog box. The choices range from hundreds to trillions. For instance,
$200,000 will display as $200 if you choose Thousands from the Display

Units drop-down list. Excel will add a thousands label above the value-axis.

To explode a pie chart, activate the chart and click the pie to select the
entire chart. Drag any slice away from the center of the pie.

To explode just one piece of an active pie chart, click once on the whole pie,
and then click again on the desired slice. Drag the selected slice away from
the center of the pie.

To rotate the position of slices in a pie chart, select the slice you want to
change. Right-click and select Format Data Point. In the Series Option
category, and enter a value between 0 and 360 degrees in the Angle of First
Slice text box. Optionally, you can use the slider to change the rotation.

If you need to format a new chart like an existing one, you can copy the
formats from one chart to another. Activate the existing chart and on the
Home tab locate the Clipboard group, click Copy. Activate the new chart; on
the Home tab locate the Clipboard group, click the Paste down arrow. Select
Paste Special, select Formats and click OK. If you changed the scaling on
the existing chart, you may need to adjust it on the new chart.

You cannot rotate or angle Legend text.

To add unattached text to a chart, locate the Layout tab in the Chart Tools.
Click Text Box in the Insert group. Draw a text box; enter the text; and then
click outside the text box. Text boxes that you’ve added to a chart do not
appear in the Chart Elements drop-down list.

Using the mouse, you can drag a chart’s legend to any location; however,
the chart will not automatically adjust in size to accommodate the legend as
it does when you change the legend position using choices in the Legend
Options of the Format Legend dialog box.

© 2011 Online Consulting, Inc., Revised 07/26/11 4-15
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10.

11.

12.

13.

14.

15.

Formatting Chart Elements
In Charts, move to the YTD Chart worksheet.
Click the chart title and change itto Year to Date Sales.

To add a shape style to the chart title:

o Make sure the chart title is active;

e On the Format tab of the Chart Tools, locate the Shape Styles group;
o Click the drop-down arrow to display the Shape Styles gallery;

e Select Moderate Effect — Red, Accent 2 in the fifth row.

Click one of the data labels on a slice of the pie. This will select all four labels.

On the Home tab locate the Font group. Change the font size to 16 and apply bold
formatting.

Avoiding the text label, click the South slice; then click it again to activate only
that slice.

Click and drag the South slice outward to explode that piece of the pie.

Move to the Format Chart sheet.

Right-click the legend and select Format Legend.

Select Bottom as the legend position.

With the Format Legend dialog box still open, click on the background of the
chart to select the wall. This activates the wall element and displays the Format
Walls dialog box.

Select a darker solid fill color for the wall and then click Close.

Adda First Quarter Sales chart title above the chart and format the
title as desired.

Select the Summary sheet and format any chart elements as desired.

Save the workbook.

4-16
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Excel 2010 Intermediate

Working with Charts

Adding and Removing Data Series

Use this option 1o add a
data series to chart when
the source data is derived
from contiguous celfs.

Once a chart is created in Excel, it is linked to the data in the worksheet and will

update if the worksheet data changes. If you add data to a worksheet after a chart is

created, or if you wish to include data that was not originally incorporated in the

chart, several methods are available to include the new data in the chart.
Additionally, you can change or remove a data series once it is included in a chart.

How you modify a chart depends on whether the data series for the chart is derived

from contiguous or non-contiguous cells.

Generally, the easiest method for adding data to a chart is to copy the desired range
from the worksheet and paste it directly into the chart. You can also readily remove

data from charts by selecting the desired data series in the chart and pressing the

Delete key.

In instances where you need to view the ranges that created a chart or place
non-linked data in a chart, you may want to use the Select Data Source dialog box,
which is illustrated below:

T T T e e e e T~ Ny

S:e:'ligct___D_ata, Source

Chart data range: I;'Chaft Data'1$A$5:$D$9

A

Use this option fo add a
data series to a chart
when the source data is
derived from non-
contiguous cells.

Legend Entries (Series)

6(4 [ @ switch Row/Cotumn | ‘—J]_

Horizontal @@w} Axis 1.abels

S || e

K Remove | &

]
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Excel 2010 Intermediate

Adding and Removing Data Series

STEPS

Make the chart active.

On the Design tab of the Chart Tools, locate the Data group and click Select
Data.

To add a data series that is contiguous:

o Inthe Chart data range text box, click (% Collapse Dialog;

o Select the new contiguous range for the chart and press [Enter<J);
e Click OK.

To add a data series that is non-contiguous:
o From the Legend Entries (Series) options, click Add;

o In the Series name text box, type a name or click Collapse Dialog,
move to the worksheet and select a cell that contains the name for the
data series;

o In the Series value text box, type in the new data values separated by
commas or click Collapse Dialog, move to the worksheet and select
the data for the new data series;

o Click OK in the Edit Series box.

To edit a data series:
o Inthe Legend Entries (Series) list box, select the data series to be edited;
o Click Edit;

o In the Edit Series box, modify the Series name or Series values and click
OK.

To remove a data series:

o Inthe Legend Entries (Series) list box, select the data series to be
removed;

o Click Remove.

To edit the horizontal axis labels:

o In the Horizontal (Category) Axis Labels option, click Edit;
e Modify the Axis label range;

o Click OK.

Click OK to close the Select Data Source dialog box.

When adding a data series to a chart created from a series of contiguous
cells, make sure to select the existing data series and the new data series.

4-18

© 2011 Online Consulting, Inc., Revised 07/26/11




Excel 2010 Intermediate Working with Charts

@ In the Select Data Source dialog box, you can add data and labels by typing
in the appropriate text boxes. This information is not entered into the
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worksheet and, therefore, is not linked to it.

To add multiple labels, separate the words with commas. For instance, if
your x-axis labels in the worksheet are abbreviations for month names and
you want to have full month names in the chart, you can enter the new
labels in the Select Data Source dialog box.

When you select a data series in an embedded chart, the Range Finder
displays color-coded borders for all the data included in the chart. Legend
labels display a green border, x-axis labels have a purple border, and the
data values are outlined in blue.

. Q/ You can copy data ranges from a worksheet and paste them into a chart.

Select a data series in a chart and press to remove it.

Adding and Removing Data Series
On the Chart Data worksheet in Charts, insert a new row above row 10.

Type the following information in the new row, pressing after each entry:

Central 150000 203000 128000

Check the formulas for Total Sales and YTD to make sure the new cells have
been added.

Move to the YTD Chart sheet and note that the “Central” data is not included.

To add a Central region to the YTD chart:
o Make the chart active;

o On the Design tab of the Chart Tools, locate the Data group and click Select
Data;

o Inthe Chart data range text box, click [% Collapse Dialog;

o On the Chart Data worksheet, select the range A6 through A10, hold down
and select the range E6 to E10; press (Enter<);

o Click OK and note that the Central region is now part of the pie chart.
Move to the Chart Data worksheet. Select cells A15:D15 and copy the data.
Move to the 18t Qfr worksheet.

Right-click near the edge of the chart and select Paste. Note the copied data
series has been pasted in the chart.

Save the workbook.
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Working with Charts Excel 2010 Intermediate

Printing Charts

Typically, you should preview a chart before printing it, in case you want to make
adjustments such as changing the page orientation, altering the margins, or adding a
header or footer. You can also use the preview feature to help determine if you want
to print an embedded chart with or without its surrounding data.

To print an embedded chart without data, select the chart before using the Print
command. To print an embedded chart along with the worksheet data, select a cell in
the data, rather than the chart. When you print the worksheet, it will print as it
appears on the screen. Therefore, if the chart is larger than the page margins or covers
any worksheet data, the printed page will look the same way. A chart created on a
chart sheet will automatically print without the data used to create it.

When a chart is active, Excel’s Page Setup dialog box includes a Chart tab, illustrated
below, for adjusting a chart’s print quality:

Decreases printing time | Page | Margins | Header/Footer || Chart | |
by suppressing the T 7
printing of some graphic i Printing quality

elements. E_D Draft gudlity

’;/D Print in black and white

Prints data series as — |
black and white pattems,
rather than color, on color
printers or shades of gray
on black and white

printers.

i
!
t
|
!
i
|
%
§
I

(o) (ks ) [ ]

L — -
Lok ][ coxel |
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Printing Charts

STEPS

1. Make the chart active.
2. Click the click the File tab and click Print.

3. Set the desired options and click Print.

‘When printing a chart on a separate chart sheet, the default page orientation
is landscape.

When an embedded chart is selected, Print selected chart is automatically
chosen in the Settings on the Print tab in Backstage View.

To print an embedded chart along with its worksheet data, select a cell in
the worksheet rather than the chart and then print the worksheet.

To access the Page Setup dialog box for a chart without previewing it,
activate the chart. On the Ribbon, click the Page Layout tab, locate the Page
Setup group and then click the | s | dialog launcher to open the Page Setup
dialog box.

\Q Press (Ctrl] —(P] to access the Print dialog box.

Press (Esc] to return to the worksheet after previewing.

Click the File tab and click Print to view a chart or a chart along with its data
before printing.

Printing Charts
Select the Chart Data worksheet in Charts, and make the embedded chart active.

Click the File tab and click Print to preview the chart. Press (Esc) to return to the
worksheet.

Click in cell Al.

Click the File tab and click Print to preview the worksheet and the embedded
chart.

Click the Page Setup link below Settings.
On the Margins tab and select Horizontally and click OK.
Return to the worksheet.

Save the workbook.
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Working with Charts

Excel 2010 Intermediate

Creating and Using a Chart Template

Once a chart is created in Excel, the chart layout can be saved as a template. The next
time you need a new chart to look that same way as the template chart, just apply the
template to the selected data.

Creating and Using a Chart Template

o

o

To create a chart template:

2. To create a chart from a template:

Create a chart and apply the desired formatting;

Click the Design tab of the Chart Tools;

Locate the Type group and click Save as Template;

In the Save Chart Template dialog box, enter a name for the template;
Click Save.

Select the worksheet data for the chart;

On the Insert tab, locate the Charts group and then click the dialog
launcher to open the Insert Chart dialog box.

Select the Templates category;
Select the desired template and then click OK.

Click Manage Templates in the Insert Chart dialog box to launch the Windows
Explorer and view templates in the default template location which is
C:\Documents and Settings\Username\Application
Data\Microsoft\Templates\Charts. The templates can also be renamed or
deleted from the Windows Explorer by right-clicking the .crtx file and
selecting the desired option from the shortcut menu.

4-22
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Creating and Using a Chart Template

Switch to the Eastem worksheet in Charts.

To save the chart as a template, do the following:
o Make sure the chart is active;

Click the Design tab of the Chart Tools;

In the Type group, click Save As Template;

o Enter Quarter Sales asthe name for the template and click Save.
Switch to the Central worksheet and select the data in A3 to D6.

To create a chart using the Quarter Sales template:

e Click the Insert tab and then click the IE dialog launcher in the Charts group;
o Display the Templates category;

o Select the Quarter Sales template and then click OK.

. Move the chart under the data.

Select the title, type First Quarter Sales - Central and press (Enter<Jd).

. Apply the template to the Western worksheet for cells A3 to D6.

Change the title to First Quarter Sales — Western.

Save the workbook.

4972
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Excel 2010 Intermediate

Creating a Sparkline

A sparkline is a mini chart that appears in the background of a cell. Use a sparkline to
show the trend or pattern in a series of data. Choose from three different types of
sparklines to represent your data: Line, Column, and Win/Loss.

The picture below shows a column sparkline for each series of monthly data in rows

4 through 6:
: A B C p | E 1 F 6
1. Taylor Fashions - Eastern Region
2
i Product Line Jan Feb Mar 1st Qtr Jan to Mar
_4 . Women's $200,000.00 $210.000.00 $245,000.00 $655,000.00 —_——
_5 i Mens $135,000.00 $63,000.00 $100,000.00 $298,000.00 i =
] __§] Children's $120,000.00 $174,000.00 $87,000.00 $321,000.00 oo | — I
_7 {Total $455,000.00 $387,000.00 $432,000.00 %1,274,000.00
"9 |Expenses $250,000.00 §$187,000.00  $78,000.00 $515,000.00 " Sparklines ,‘I
10 : i
Eproﬁt $205,000.00 $200,000.00 $354,000.00 $759,000.00
12
Creating a Sparkline
1. Select the empty cell in which to create a sparkline.
2. On the Ribbon, display the Insert tab.
3. Locate the Sparklines group and do one of the following:
o Click HEure to create a Line chart.
o Click B Cowmn to create a Column chart.
o Click Ewmoss to create 2 Win/Loss chart.
4. Inthe Create Sparklines dialog box, make sure the cursor is in the Data
Range box.
5. Select the data for the sparkline in the worksheet.
6. Click OK.

Click the Design tab of the Sparkline Tools to access options for formatting
sparklines, changing the sparkline type, and working with data markers.

To remove a sparkline, select the cell containing the sparkline. On the
Design tab of the Sparkline Tools, locate the Group group and click 2 Qear -

To create a group of sparklines, use the fill handle to copy a sparkline to
adjacent cells. When you apply formatting to a sparkline in a group, the
other sparklines in the group are formatted as well.

4-24
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10.

11.

Creating a Sparkline
In Charts, switch to the Eastemn worksheet.
Select cell G4.
On the Ribbon, click the Insert tab.
Locate the Sparklines group and click B Colurmn .

Make sure the cursor is in the Data Range text box and select the data in the
range B4 to D4.

Click OK.

Use the fill handle to copy the sparkline to cells G5 and G6.
Select cell G4. Note the border around the group of sparklines.
Click the Design tab of the Sparkline tools.

In the Style group, click ' rcotor - and point to High Point; then select a color
in the palette. Note the changes to the group.

Save and close the workbook.
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Using Table reatures

Creating a table
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Filtering & tabie
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Formatting a Tadle
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Creating a Table

Excel has special features for working with data that is organized like a database with
columns as fields and rows as records of related informatior. such as a lst of
invoices or ciient names and addresses. You can designate data that has been
organized in inis manner es a (abl: 1o take adv antage of the sorting. filtering
formatting. anc analysis tools for working witii tabuiar data in Excel. In versions
ecriier ﬂmn bxcel 700". tables were referred to as lists.
When you specify a range of cells containing data as a table. filter drop-down lists
arc added to the column headings and formattm" 1s applica to the table. When the
ceH pointer is within the table. a contextual tab appears in the Ribbon containing the
ot s for v orking with 1able f reatur»s 11" addition to sorting and filtering, vou can
summarize data in a Total row. adu columns or rows automatically. and creaie
caleulated columns.

The illustration below shows a sample tab!:
highlighted on th:< Ribbon:

with the Design tab of the Tables Tools

IE Dataiistaisx - Microsofi Ercel Iu_g_‘__a =& .
m Hnmc Insert Page Layou! Fermutas Data kmm View nwclnpzv - Dasign [~ @ =F T
|1abte Kame: 35 ummanz: with Pvotlab:e EQJ‘ - . hieader Row :] First Colums: .
' iabiels f ~move Uphicates ’ - <) Totat Row: 7 Last Cotumn - |
R - Exaor Rete=: —_ — .
Tk Rasize Tabie <.} -owert to Range - = ) Banued Rows [ Danded Columns - |
;= Proparties Tooal, External Tas ‘i@ Talle Stute Oplion: |
R TE
Column headings || 26 . £ | westCaast Fashion: i . E{
G R 1 = ] T . Z i K=
or field names are LA j— —B v E __F__ 6 H -
in tne first row. T I ~
; » . o weN -
i resCoas Farhion: Sar Franuso c Yooz G =
"t iayor e proees Vi omaas Each column heaomq ;
| 17 VaayCu Cies Pasky-oh P Normeas appears witn a arop- !
|1 Vv Clomer Proviaonies R Nopeas. b iar |
112 Trendy Toa- Hazor o O down lls: tor 'ﬁl_{ermg i
' 17 Trendy Toa: tow Yor, Y lomeas : 800 | ant 30riNg daia. |
i |14 (o beacn Snoz Fi Lautersae ol Louremr, LCRRT.OS 2600 {
. 15 ‘Soum no- 2, Shaps Mamri Fo SouTEas Criarers  Hwrarer 4000
' 1 ReverFoans S loms At Higwss Chigrens  Jeanncs 3.032
117 Ramiear Borand o Vs Chinen: _ Schomar 2005
CIF lrvear 3ecze Wi e Crigrens  Jones 700!
= ‘R neage . Pz _Unrer brusare- 9.000!
' 20 3d Raas ___lmananools WL hiowest Checrs- SomeTan 5&;{_—)!
i amas Cares Deres " Maees Chizrens Jores 4103
22 [Freenom | abRCS __Phasdepn: » hargear 2 Scrumar: 208
| 23 :Coolnt: Asan: 84 Seufeas Jones 1.030
The Total Row can __ = !
- -
D2 wriec o1 of off. S

5
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Creating a Tabie, continued:

The following guidelines are useful when organizing data for a table in Excel.

Location

« Leave at least one blank row or column between the table and other data on
the worksheet.

¢ Try not to store important information in the cells to the left or right of a
table. If vou do, the information might be hidden when you filter the table.

o e e T

Column Labels

e Position the column heading labels in the first row of i table.
e Format the column labels differently than the data in the table.

¢ Do not use a blank row to separate the column labels from the data.

Contents

o Creatc 2ach row of the table so that the columns consi<t of similar items.

e Remove any extra spaces at the beginniug and end of a ceil. The spaces will
Y N p=4 p=4 p
§ affect sorting and seaching.

o Use the same format for every data cell in a column.

The illustration below shows a sample of table data:

i ~ I3 i B c o £ = G
& v:es:(.c"f ~.shx:'\s Los Ancaies .CA West Chidrens  Jenpinge 9.000
7 WazCoasi Feshions Foran: OR Wes Cridrens  Brubuer 3000
B IWecCoad Fashicns San Francseo Ch Vies Chidrens  Jones £,000
9 Wo 07 Clothes ‘Beson MA Nermeas: Chidreris  Brugz.sr .00
10 W i Clones Pizbureh PE Lomness Chddrens  Schuman 1.8001
11 "WavOir Clones Providence R harheast Chidrens  Jenmmads 6520
12 Trenav Teas Hargord C Norneas: Chigrens  Jeamnas 6.000!
13 I Trendy Toos New York WY Norneast Chigiens  Jores 10050
14 501N Beath Snans Friaunerdae  FL Soumeas.  Chiuiens  Jenangs 2800]
15 -Sowh Beach Snors Miam EL Soumeast  Chidrens  Brubaker £000.
A6 {Rwver Reas S Loug MO Mitives Criarens  Jennnas 2.000)
17 'RainVear Porant oF Wes Crddrens  Scuman 2,000]
18 |Ramvvear Seste Wh Wies: ‘Chidren:  Jones 7.000
15 iRad Rags ‘Cnicago 1L Mdwes Chidrens  Brunaker 9.000!
20 iRat Hage Limneanoks MN Wawes: Chidren's  Schumar. § 000
21 Kama Ciomes Deros M howes  Chigrens  Jomes 4000
2% iFrasaom Fabres Prateiphia Ph Nomeas  Chedrens  Schuman 2000
23 | CoolDuds poars [ Soumens.  Cndorens  Janes 100!
24 Cann Oomer New Orieans LA Souneast Chlorens  Brubake: 4,000
25 |Bay Briznes San Francisco CA Wes Chidrens Jenrings 4000
26 \wesiCoast Fashions 108 Angela ch Vies Henc Jennings 11,500|
27 ViestCoast Fashions Pertanc 03 Wiez. Men's Brubaker 5000!
28 'WesGoast Fashions San Frargson ok Wes Hen's Jores 12 5831
29 vvayOu: Cioinez Boson 1A Normeas: Wen's Brubaver 7080
20 iwayOuw Clomes Freburgh PA Nomaas  Wene Senuman 4500|
34 Wav0iz Ciotnes Providence R Nomeast  Mens Jenunas 5 550
32 Trendy Toos Hartord cT Nomheast  Mens Jemngs 3,620/
33 Trendy Togs New vori: NY Nommeas. Merns Jones 1 GQD';
34 :Souh Beach Snope Ft Laugerdte FL Soumaast bans Jeanmas 85°
35 iGouh Baach Shops Miam FL Soumeas’ Mens Hrubare* 7,000!
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Excel 2010 Infermadia

Crazating e Table

o

(93]

h

Enter the 1able aata into adjacent columns and rows.

Position the cell pointer within the tabie.

On the Ribbor. click the Insert tab and iocate the Tables group.
Ciick Table.

Verify the range that appears in the Create Table dialog bos:.
Select or clear the My table has headers optior., if necessary .

Click OK.

You can create multiple tables on one worksheet.

If vour table does nc.. have column headings. Excel wil! create generic
column headings for vou. L.e.. Columnl. Column2. etc.

To remove a table, on the Dasign tab of the Tables Toois. locate the Tools.
group and click Conwvert 1o Rar ce; ther click Yes. The filter drop-down lists
will be removed; however. the formatiing « the wabic will remain.

It is not necessary to create a table 10 sort or filter dowa. The Sort . Filter
tools on the Data tab of the Ribbon can be used or ary caw that is organized
2s a uble. Place the cell pointer within the dat: before nsing the comma: ds.

When vou create 2 table, it is given a generic name. such as Tablel. Tahie 2.
etc. To rename the table. dispiay the Design tab of the Table Taols and
locate the Propertizs group. Click in the Tahle Name text box. tvpe the
name and press | enter< ).

You can easily remove duplicate rows in a table. Select anv ceil in the table
and display the Design tab of the Table Toc's; locate the Tools group and
chick Remove Dupiicates. in the Remove Dupiicates dialog box. select the
column or columns that contain dupiicate information and click DX. Leavc
all columns selected if you want 1o search for entire rows that are identizal
and remove them.

On the Home tab of the Ribbon, use the Format as Table too! in the Styles
group to quickiy create a table and apply a table style of vour choice.
To guickly tum 2 range of daia into a table. select the range and press

J——

Cul: — L1

5-4
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===_ Creating a Table

1. Open the Datalist workbool:.

2. On the Data List workshee; select cell A6.
3. On the Ribbon, click the Inseri tab. .
4. Locate the Tables group and click Table.

3. Verifv that SA$5:$G$67 appears as the range for tae tabic and that the My table
has headers option 1s checked.

6. Ciick OK.

~1

Note that the entire table is selected and that a table format has been appliec.

¢. Select cell A6 and save the file.
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Using AutoComplete

The AutoComplzie featurs faciiitates cata eny by {iliing in repetitive entries i a
column. If'tie first few characters tvped in & -ell inarch an entrv n that column.
Excel can help complete the entry for vou. Tnis featurs is used with 1.5t entries oaiv.

Aac.vonally. as entries are tyned into a column, they are built ity a droj -down ist.
Rather than typing an entry in a cell. vou cau select the desired eriry rom the list of

entries that already appeur m that coium.

The illustration below show's & worksheet with the drop-down list o1 ¢iries visibie:

| 2 B B < L = - € IS
. Scidi Moon L nger IRc.
2 Seles Rapar:
" WesLoast Festions Los Angetes cA Yiegt Crécmans  Jennics
| 7 :\eCoa:'Fashons L35 Aroexs o Ves! Meris dennmgs
8 'wesiCoa i Fashens LS Angates £ Wwes: Wopens Jennanas
S ‘WemCoast Fashions Fordare OR Wes Chirets Brubake:
. 0 WesCoacr Fashions Portand CR Gl Mens Brubstar
Drop-down list of 19 [V sicoas: Fastron: Porgand OF wert Wwemar's  Brubarer
available entrigs ————t0ey Britcnns i Cx Yes Chivirens __ Jones
13 Eg?;ﬂoudd?me; [ vies lhers Jones
114 Freecom Fabric: =15an Fianmsoo ct wao V.omen: Jongs
15 [Kemixaz Cletnes —|8csrn MA Normeas Cnigren = Brugale
(16 .g:;{;a“ {8czon W hHorwas  Mers Lrubrre’
117 Y River - ~lbosT M Nomieas WoTEn s Brunare:
[ ‘D VayDs.cme. Frsbuier Ph isrneas. Clearans Soownin
119 wayCa Ciahes _ Prsburg ps, tiorneast  Mens Searnar
| 20 :wavOu Ciohes Pr=purar Pi Nornegs: Womer's Somrgn
| 21 WayOu Ciatnes readance R Norneac  Chfgren: N aes
1 22 wayOut Clome: Prove i Rt NOreE st viomens vemirc
27 Waduw Clores Broviaens: Ri Hgrneas Menc Janama.
| 24 Trenoy Tog: Hamor CcT Nor:.eas “adarens g
25 Trendy Toos Hzrdord CT horreas: nens SenRinns
28 irenay Toc: Hergerd o homess.  Womens Jenamgs
27 “Trendy Tooe Wew Yot Wy Norheas Crarens  Jonmas
28 Trenay TogT New Yo NY Norneas Mern's Jones
| 29 “irendy Toas New Yon. NV Normees. Women's Jor.e:

| 30 'Sow Beawn Snase L Lautardak: L Souneac.  Cridrens

PR T ~ATIne
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Using AutaCompiete

o | |
N “E’): 1. To enable or diszble AutoComplete:
STEPS | o Click the File tab and click | 2 Optians

e Display the Advancsd carsgory:

o Under Editing Options. select or clear the Enabic AuioComplete jor cell
f vaines check box:

! e Click OK.

g8

To use AutoComplete:

e Be sure that the cell pointer is in a column that has existing texi entries:

S

o  Start typing the first few characters of text:

«  When the appropriate entry is displayed, press (Enie; Enter =1 | or [Tab.

o

To choose an entry from a drop-down list:
o Right-click the desired celi to display the shorteut menu:
o Seiect Pici. From Drop lown List.

e Click the appropriate entry in the drop-down hst.

i S T T

Excal uses the text in the column as a reference. When multiple entries have
the same beginning characiers. vou will have to type until vou reach a
unique character for Excel to determine how to complete the entr .

If AutoComplete is disabled. vou can still use Pic from Dr op-doven List.

Entering data in the next row at the bottom of a table automaticaliv extends
the range of the table and the table formatting. Similarly. entering data nto
an adjacent column to the right of the table extends tiie tabie ranze.

The AutoComplete feature can be use ! with a table or with a range of
tabular data.

Q Select the desired cell and press (Al — (£ 1o display the drop-down list of
entries.

@ Different columns contain different text entries. AutoComplete entries
available in one column will not be available in anotier.

Onlv entries that coniain text or a combination of text and numbers can be
completed. Entries that coniain numbers. dates. or times are not.

(4]
'
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Using Table Features

Excel 2010 ln[ermediat::_

A v ma -

using AutoCompieie

1. In the Dataiist workbooli. seiect the AU’ Co mpisie worl-sheat,

2. Tocneck if'the AutoCompicte and List Autolill fearures are enablad on vour
computer:

. , N
s Click the File tab and click. | 2 Ostior |
¢ Cuck the Advanced category:
o Ensure that Enable AutoComplete jor cell vaiues is = -lectzd in the Editing
options:
¢ Click IX.

5. Use AutoComnlete to {1l in the information below for row 19. Beginning i £19.
type the first few characters of each entry and press Tab's) wien the appropricie
entry appzars.

|
WavDuot Clothes PiTtisburan o hortheast Ment chunar
' |
4. Type 2500 for the sales figure in G19 and press [Enter = .
YE & LEntel ==,

5. Right-click A20 and select Pick From Drop-dovwn List.

6. Choose WavOur Clothes.

7. Use the drop-down list or tvpe and use AutoComplete to complete the row with
the {oliowing inf rmetion:

Pitosbura? Pr Northsast Viomen's Schumar i
¥
A
§. Enter ¢000C G20,
0, Save the workbook.

-
Cpmds
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Using Table Features

: Soriing a Table

The order of the rows in a 1biz can be rearranged by sorting. You can arrange the

table alphabeiically. numerically. or cnronclogicaliv according to the cont: is of up
to sixty-four columns. Once a multi-ievel sort is created. vou can add, delete, or

reorder the sort levels.

Below is an iliustration of the Sort dialog bo::

“ajAddiev “'JW DelﬂtzLeE]F___g CopyLevﬂlJ

Sort Z to A.

To sort by muitiple columns:

e e TR TR
tJ

e (Click Sort;

g

row of drop-down lists:

To remove a sort level:

)

e ey

o Select any cell in the table:

e Select a cell in the column to sort by and display the Data tab on the
Ribbon: locate the Sort & Filter group and then click SortAto Zor

¢ On the Ribbon. click the Data tab and locate the Sort & Filier group:

Open the drop-down list under Sort On and make a selection:
! p

¢ Open the drop-down list under Order and make a selection:

e (reate additional sort levels as desired and then click OK.

e Click the sort level row to be removed and then click | ¥ Defeteleve |

_‘ fe! Options. ] ™y data has headers
- j Column Sort On o
N ISortby  jRegon v iVales v Aw? R -
- Theny  swre v Vaiues R
- {Thenby ol vaives T v Aw- e,
- {Store ] e e et

! City
; i State

Regon
N iLine
) : {Rep
Eaes ' ‘
R | o l r Cancgd';]
i Sorting a Tabdle
_ 1_
- ee | |
sf@ i ; 1. To sort by a single column. do one of the following:
. 4 ]
. g
{ ¢ In the table. op~1 the drop-down list for the column to sort by and select
STEFS { Sort A 1o 7 or wori Z1o A.

Open the drop-down list under Column and select the primary sort field:

Click | %i8d0 evel | and set the criteria for the second sort level in the second

© 2011 Oniine Consulting, Inc., Revised G7/26/11
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Eycel 2010 irtermediate

To undo a sort. ciick | “¥iUndo on the Quick Access teolbar.

In the Sort dialog box. click Options and select Case sensitive to creaie a sort
that differentiates between voper and lower case letters.

To move a sort 'evel row up or down in a multi-level sort. ciick the row a:id

then click B oI D
You can sort datu according to the font or fill color in the cell: to be sorted.

If vou are sorting a column containing both text and numbers and vou want
the numbers sorted together. such as 1. ia. 2. 2a. vou will need to format the
numbers as text. If the numbers have already been entered. edit each one
place an apostrophe (') before the number. If the numbers have not been
enterec. rormat the cells as text before typing in the numbers.

Sorting a Table

& X 1. Move to the Data List worksheet in Datalist.
Try it
2. Scroll down to see tne extent of the table and note the current sort order.
3. lucell AS. open the drop-down list for the STORE coiumn and select Sorz 4 1o Z.
4. View the data and click | *? Undo on the Quick Access toolbar.
3. Select any entrv in the REGION coiumn.
6. On the Ribbon. display the Daia tab. In the Sort & Filier group. ciick SonAtc Z
7. Click |*¥ Undo.
€. Onthe Data tab, click Sori e the Sort & Filter group.
¢, In the Sort dialog box. open the Sort by drop-down list and select Region.
10. Ciick Add Level.
11. Open the Then by drop-down list and select Store.
12. Add the Line field as the third row.
13. Make sure that Vafues is selected under Sort On and 4 0 Z is selected under
Order in al' rows.

14. Click OK.
13, View the daw and click |’_‘33 Unno.

£-10 © 2011 Online Consulting, inc.. Revised 07/26/11
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Using Table Features

Filtering 2 Table

When you create a table. a a:op-down menu used to set conditions for filtering data
becomes available for each column in the table. When you define a filter. only rows
containing data matching the criteria you spacify will be displaved: the remainder of
the table will be hidder.

The iliustration beiow

displaved:

shows a table with the drop-down list for the Region column

Dror-dowr anmows 6 iwesCopmbstiine |41 sonateZ dennirs 9.000
apoear 10 ire right /'p«wﬁoas: Fashons 7| << Jenrrgs 11,50
of the coiumn § I .-Coasfeshon: | 7 SertItoA Vomens  Jernngs 12800
neadings when you | § 'WestCoast Fashions Sort by Color |Chearens  Brubakes 3,000
crzate a labie. 10 IWextCoas: Fesfians Fomn [uens Brupaie® 5030
11 iWestCoas! Fashicns i IWomens  Brubaker 5,030

12 |WesiCoas: Fashionz |Cniiren's  Jones 6,070
13 IesiCoact Fashions Text Filters [Men's Jones 12,590,

Choigas for filtering :lé !'\ae:‘uoars: Fashane [ I3 l |Woimans Jgnes 5000
: . Waylouw Comas | Cnigeent Brubaker 6,000
tn: 5‘: glic;nacglumn 16 {WavOu Clgmes " giseectAl {hisms Brusaker 7L00
ars dispiayed. 17 ivvayOur Comes ® - AMigwect [Womens Brutaxer 9,000
| 18 IwayOu Ciamss i Northeast Chicrens  Schuman 1,800

19 IwayOuws Clotne: - gsoutheast {Mens Schuman 4500
.1 20 \hayCu Clomes “erwest Veomen's Serumar: 6000/
21 Iwavou Clomes [Cnldrens Jenninas 8820

2 i\WsayOuw Ciomes Lwomen's Jenningz 5400

23 \WayOu: Ciomes iMans Jenninas 5.500

24 | Trengy Toas fohorene  genringe 8009

| 25 'Trenay Toce I Mene dannn 3.820

25 | Trandy Toos homens Jenning: 2580

27 ITrendy Togs - U ox 3 ([ cancel | oiorens  ones 10,6

28 {Trendy Toas : 2 Menz Jongs 11,003

| 28 1Trenay Toue New York NY Nornaas! Women's Jonss 12,000

| 30 !50un Bearn Sheps Fo Laugerdas FL Scufeas Chiarens JEnnnas 7000

ty
y )
o
&
1
~ '\
.
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Usir.J Table Feetures Exca! 2010 intermsdiata

Filrering a Table

. 1. Tofilter a table:

¢ Open the drop-down list for the column to filter:

- e Click to remove the check next to (Seicer Al

[ ©  Click a check next to the value or vaiues to be used as ‘he filier criteria.
| ¢ Click OK. ’
' 2. Toecreate a custom filier: '
b . !
| ¢ Gpen the drop-down list for the column 1o filter:
[ e Pointto Text Filiers. Number Filiers. o- Date Filiers and then seluct |
f Custom Filter, |
{
] e Irihe first row. select a comparison operator in the drop-down list on the
i left: then select a vaiue 1o be used as the filter eriterion from the arop-
| down list on the right:
t - .

o Toadd another fiiter:

- Select 4And or Or: and make the desired selections in the second row:
! o (Cliclk OK.
f _ . )
3. Teremove the filter from a columu:

e Open the drop-down lis for the column and s=lect Clear Filicr From:
“Cofumm Newe

'y

<. 10 turn on the AuoFilter fzature 1o {ilter data that has not been designated as

a table:
e Dejectany celi m the data range:
¢ O the Ribbor. display the Data tab:

e Loczate the Sort & Filter group and clicl: Filter.

h

To turn off the AutoFilter feature:
e Sclectany cell in the data range:
¢ Onth Kibbon. display the Data tab:

: o Locate the Sort & Filter group and click Filtar.

@ When a filter has been applied. the down arrow for the filtered eolumn
J i
appears as |7,

You can apply & filter to 2 wable that has already teen filtered to create
mu ! iple conditions.

You can use the wildcard characters » and 7 when entering ¢
comparison value m the Custom Auto™ilter dialog box

L)

€ 2071 Drune Consuting. inc., Feviosd 0726/19
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=xcel 2010 in.armediate Using Table reatures

- @ When creating a custom filter. conditions can be combined using the And

and Or operators. 4n¢’ requires that both conditions are met for a row 10 be
included in the resuit. O altows for eitaer conditior: to be met for a row to
appear in the filtered results.

You can copy and paste filtered data to create a new table. Select the rows
and us= the desired method to copy the daia. When you paste. only the
filterec data that was visible in the original table will be pasted 1o the new
locattori. :

® If a workshest contains multiple tables. data in one table may be hidden

when vou filter data in another table as filtering afiects the entire row.

Remember to deselect previous criteria before creaiing new fiiter criteria.
Criteria selections remain in efiect until they are removed.

!
!J

L)

Filtering 2 Table
In the Data List worksheet, select any cell in the table.

Open the drop-down ist in the Region column and click to remove the check
next to (Select All).

Select West and then click OK. View the changes in the table.

Remove the West filter by choosing Clear Filter From “Kegion ™ from the
Region drop-down list.

Filter the Rep column to show information for Jennings.

Open the Rep column drop-down list and point 1o Texi £, ilters; then select Degins
with.

In the Custom AutoFilter dialog box. enter = as the filier criterion in the first
TOW.

Click OK to view the data.

Remove the filter from the Rep column.

 Add Glters to find the records in the West region for Brubaker and Jones.

 Add a Custom filter to find the records where the sales amount is greater than

2000 for the subsat above.

. Remove all existing criteria.
. Use the Top 10 AutoFilter to show the top 5 items in the Sales column.
. Change the Top 10 AuoFilter to show the top 15 percent of sales items.

. Save the workbooi..

@ 2011 Oniine Consulting, Inc.,
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Using Table Features =xcel 201C Intermediate

Working with the Total Row

You can choose to display a total row at the bottom of vour table to summarize data.
Wiien vou initially turn the total row on. the word “Total” appears in tiie leftmos: cel!
of the row and the cell in the last column shows the result of a summary function. If
thie data in the last column 1s numeric, the data is summed: if the data i the iast
column is text. a count of the values in the column is shown. However. vou can
change the text and the function in the total row to wnatever vou like. The cell
containing thie sumimary funcion has a drop-down list for selecting an alternate
function; vou can also enter a formula of vour own.

The table in the picture below has tiie total row displaved:

B A B . c D E L6 ¢
i1 Soteh Moan Under, Inc.
i 2 S x5 Repar
2
L6 nesToas Ferias Los Angs . i 1] l
T viesioad Fautuons Porgand OR Ves T ens
{_8_‘WesDoe “ashions San Franesco ce. ek [ i
{9 'wavOw Clomes Boston M2 Nommaast Chiaren's i
3 PA Numheast  Chadren's |
] R N Chidren's
9 Nuileast Chidresis 5 6,000
NY Chiorens  Jonas 1000
FL Southeast Chiarans Jenaiias 20830
FL Soucast Chiforens Brugaxe: 4000
WO Mrwest Chidrens __ Jepmings awo !
OF wwed Chégrans Senuman 20001
WA Wes [ 7,000
nw Migwest Chiv one  Brunaker 9.000
N Mitweg Ctadrens  Sonuman 50800
i Maveg Chdoren's Jonez 4.00¢
PA NorBweast Crdmaps . Schiman 2600
GA Souheas! Chiaren's Janas 1.000
LA Souhonst Chidrerms  Erulicker 46,
{Ivone
| Average
{Coumt
Zount Numbers
! Max
BEEY
3 [ i)
s e
137 I var
b tMere Functisas
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Excel 2010 intsrmediate

Usi¢ Table Features

Wiorking with tha Total Row

i
@if ! 1. Todisplay or hide the total row:
1 ® | ’
= e On the Ribbon. dispiay the Design tab of the Table Tools: i
- | |
t . . ;
STEFS ¢ In the Table Style Ontions group. select or ciear the Toral Row opuen.
Z. To change the text
? e Select the cell conmining the existing text:
f
! o Type the new text.
E 3. To replace the summary function with a different function:
} e Select the cell containing the function:
t ¢  Open the drop-down list for the cell and make a selection.
E‘ 4. To add a function to another cell:

L94]

o Selectacell in the total row:
¢  Open the drop-down list and make a selection.

To add a formula to the total row:

e Enter the formula in a cell in the total row.

‘gt:, If vou enter a formuia or function in any of the cells in the row imnediately’
. B

below a table. the total row will display automea.ically.

The results of formuias and functions in the total row will change to reflect
filtered data.

)

]

—

 Rmvomtmisasmatu |
& 1
Try bt
4.
3.
6.

i

Working with the Total Row
In the Data List workshezt. seiect any cell in the tabie.

Display the Design tab of the Table Toois and locate the Table Style Options
group.

Click to select Total Row and view the row at the botiom of the 1able.

Open the drop-down list of the cell containing the summary function and select
Average.

Clear all filters and notice the change in the average sales.
Seiect the cell containing the text “Total” and type hverage Sales.

Save the file.

- e i ————————_

© 2011 Oniine Consulting, tnc.. Revised 07/28/11 5-15



Using Table Faatures Excsi 2010 Intermediate

Creating a Calculatzd Coiumni

ir a table, vou con easily create a new column of data using a formula that references
existing daia in the 1able. Upon enteri 2 ¢ formula in a coiumn o7 a table. the formula
automarically extends to all ¢+lis ii th> column. eliminating tie need 1o copy it

Morzover. rather than czll references. the data in an Excel table can be reierred to by
its column name. When vou refer to data vsing a ¢oluma name rather than a cel!
adaress, it 1s called struciured referencing. A suwuctured reference is entered in a
formula inside square brackets. When vou tyne the opening bracket. a list of the
structured references 1or the table appesrs in the AuoCompiete list. as shown in the
picture below:

5 ;‘,«"

8 Crowen's Janringg
|7 W Ja:.raShX)IL A VieT Men's Jennings
€ .oz Fashon ol Wz Women's Jdenmnas

& v ToasFae ne OR Wes Chidren's rubake:
g1" . 2stFasiyns 2 vz Merne Sratarer

41 WesCozz Fashons OR Wes wamans Brutake:

1Z WeszCoas! Fashone San Franusco CA Weg Chinrens  Jenas

|12 'Wes:Caast Fashion: San Frarasx Ch 8z, Meris Jones 12,2 ;

14 ‘westCoas:Fasmons  SanFrancai SH Veeg! Womens dores S80S CommissiRe
[15 Wayow Clozie: Basion MA NorReas Chidrems  srubans: s T

Creating a aicuia el olumn

1. Create 2 new cclumn i 2 table,

E 2. Enter the formula in a cell in the new column and press Enier =),

} ~ ~ . +

| 3. Touse a swructured reference in the formula: :
! e At the point in the formula 10 use the reference. tvpe an opening square

i racket ([ )

e Seisct the reference from the AutoComplete fist and press (205

e Type aclosig square bracket (1) and continue the formule. |

@ The houndary of an Excel table will amomatically expand when you enter
data in the column immediately to the right of the table.

Double-clizk the name of a structur=d reference in the AntoComplete list «
enter it into the formula.

To prevent a formula you enter into a table from automancallv extending 1o
the entire column. click the Fils tab and click = oo Select the Proofing
category and click tne AutoCorrest Options button: i the AutoCorrect dialog
box. click the AutoFormat As You Type tab. Ciear the Fill formulas in 1ables
10 create calculated colunms check box and click OF. When this option has
been disabied and vou enter a formula in a table. the AutoCorrez” Options
bution displays with an option to extend the formula to all ceils in the
cotummn.

e @ 2011 Qnline Gonsultng. me.. Revised 07/26/7



Excal 2010 Intiermediats 1+ ~g Table Feaiures

Creating a Calculated Column

1. In the Data ist worksheet. select cell HS.

2. Type Commission asalabel fora new column. Notice that the formattng of
the table is extended to column H. ’
2. Select cell H6 and type the following: =1

4. In the AutoComplste list. double-click Sales to add tne reference to the formula.

Tvpe a ciosing square bracket ( ] ) to finish the reference.

h

(=N

Complete the formula to matches the formulz below:

=

7. Press | Enter=—-.
. Wotice that the formula is automatically extended to the entire column.

0. Save the workbool.

—rs
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Lwing Table Features Exc=l 2010 intermed ate

Formetting a Table

The Table Stvles gallery contains several predesigned tables formats that vou can
apply to vour tavle. As with most galleries in ('ffice 2010. the Table styvles galien
worke with the Live Preview feature 1o display a preview of a stvle as it will appear
ui the worxsheet. When vou mouse over the thumbnai! i the galler. the vrevien
appears. Once vou apply a style. vou can enab e or disable cerain eiemants of it. For

. example, vou can choose 1o turn ofi’ the Banded Rows option or & style that features
different shading ior everv other row. .

Th= Table Stvles gallery 1s shown ir: the picture beiow:

«a Tt

Design

it

HE  Hew Table Sye...

,E Clegr

518 © 2011 Cniine Consuirrg, (.o, xevised 07 7511



Excel 2010 Intermadiai { g Table Features

Formatiing a Table

e Place the celi pointer within the tabie:
o Display tiie Design wab of tiie Table Tools:
e Locate the Table Stvies group and chick |7 | More to open the gallery:

¢  Move the mouse over the selections to view the preview and then make @
selection.

‘l OQCQ! i 1. To apply a table style:
i
E
;
'

2. Tomodify a styie:
i e On the Dasign ab of the Table Tools. locate the Table Stvle Options
t group and then do one of the following:

—  To apply different formatting to the first or last column. select Firs!
Column or Last Columiz.

- To display every other row or every otner column differantly. select
Banded Rows or Banded Colunms.

)

To clear table formatiing:

o Open thiz Table Styles gallery and select Clear.

Use the controls on the right side of the Table Stviss callery to display a
saveral choices at once Or view one row ata time in the Ribboi.

The Table Stvies ga'lery can be sized. Position the mouse over ---- at the
bottom the gallery and drag this handle to size tow callery.

You can modify the tabie formatting using options in the Table Style
Cptions group on the Design tab of the Table Tools.

The paiette of colors that appears in the Tabie Stvies gallerv is controlled by
the theme that is currently active in the workbook. The tools for changing
the taeme can be found on the Page Layout tab of the Ribbon.

Onpen the Table Stvles callery and select New Table Stvie to create & Cusiom
stvie in the New Table Quick Style dialog box. Cusiom able stvles arc
only available in the workbook in which you create them.

To delete 2 custom wbie style. right-click the style thumbnail in the Table
Styles gallery and s=lect Delete.

Right-ciick a format in the galiery and seiect Ser 4s Dejaudr 1o have that

Q' format applied to newly created tables in the current file.

When vou insert or deiete Tows or columns in a table that has bar ‘ed rows
or panded columns, the shading will adjust to maintain the stvle. nis
functionality is lost when vou convert a table 1o a range.

The settings of options in the Table Stvle Options group afiect the way
thumbnails appear in thz Table Styles ealiery. For example. if the Banded
TLows option is disablec. styles in the gallery will not reflect banded rows.

© 2011 Online Consulting, Inc., Revised G7/2¢/11 B¢
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“ormatling 2 Table
On the [ala List worisheet in the Datalist workbooki. seiect 2.1v cell in the table.

(i the Ribbon. display the Design 1ab of the Table Tools

Locate the Table Styles group and click | ¥ ! More to open the Tzole Stvies caliery.

Mouse over several of the formatting thumbnails and then select one of the sovles
that nas different shading 1or cliernate rows.

Locate th= Table Stylz Options group and clear the check next to Fanded Ronvs.

In the Table Stvle Options group. select Banaed Column: and view the resulis in
the tuble,

Upan the Table Styles gallery and notice that some thumbnaiis reflec: the Banded
Column option and that none appear with baudad rows.

Press (Zsg) 1o close the galiery without making a seleciion.

in the Table Stvie Options groug. select First Column and clsar Danded
Colunms. Note the resulss.

Reniove the First « olummn formatting and reapply tne Banded Rows fonatting.

Onen the Table Stvles gallery Lnd not= that the thumbnazils appear with bande
TOWS.

At the bonom of the gallery. choose Clear to remove the tar!e formatiing.

Save and close the workbool..

e
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tyles and Templates

Creating and using stviss
Merging styles
Using tempiates

Crzsaiing templates
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Lsing Styles and Templatss

=xce! 2010 Intarmediaiz

Working with Cell Styias

A cell style is a collection of formats that can be applizd to a cell or range of cells.
Styles define characteristice such as font size. font color, borders. number formatung.
and cell shading. Whils a handful of buili-in number format stvies were availabie in
previous versions of Excel. the feawre is more accessible and useful in Excel 2010,
In addition to the Comma. Curreucy, and Percent number formar styles that Vou may:
be familiar with. Excel 2010 provides several other styles for changing the
appearance of vour werksheet data. These buili-in styles appear in the Cell Stvles

gallery, shiown here:

A
i Cell
Styles -~
Good, Bad and Neuwa! -
f vormal { Bad Good Neutral i
| Uaia and Mode! ) . )
!i Calcalation oo YRR EEE Sxomnnton .. |Input | brkedzs ’Notg__
; | Gutput Warning Tex: i
| Titi=s and Headings ) H
Heading 1 Heacding2  Headingd Heading4 Title Total ;
Thgme'.\ Celi Styles ) _ {
20% - Accen 20%- Acceni2  20%-accent  20%-Accentd 205 - AccentS  20% - Accents !

-

Nuwine: Foranat

Comma Comma [0]

= w Cell Styge,.. -

._&:z‘_l Lierge Styies..

Currency Currency [0]

aDfa-Accentl 80%-Accen  40%- Accentd  A0%- Accentd

40% - Accents %: - Accente

Percent -

Click New Cell Style 10

open ine Style dialog

J Stvle
pox where you can || Stvie name: - ESERE
creale and name a B

CUSEOT Slyie i
i
Sryie Includes (By Examode)

|~ ) Number Ceneral

| 7] Alignment  General, Hiottom Aligned

i; 7 Eont Calbri (Body) L1, Text 1 i
| 1] porder Ne Borders

| E Fiil No Shading

I [ Pratection Locked

fl

|

|

Ok

l L Cancelj 1[
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Working with Cell Styles
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To apply a cell style to a cell or range of cells:

e Select the cell or celis:

e On the Home tab. locats the Stvles group:

¢ Click Cell Stylss to open the Cell Styles galiery:

e Apply the desired style from the gallery.

To create a custom style:

e Display the Cell Stvles gallery and select New Cell Stvie:

¢ Enter a name in the Snile name text box:

o Click Format:

e Inthe Format Cells dialog box. make the desired changes and click Ok

e Click OK in the Styvle dialog box.

To customize an existing style:

¢ Display the Cell Styles gallery and right-click the stvie to be customized:

e Select Modify from the shortcut menu;
o In the Stvle dialog box. click Format:
e Inthe Format Cells dialog box. make the desired change. and click OK.

¢ Click OK in the Stvie dialog boa.

To delete a cell style:
o Display the Cell Styles gallery and righi-clicic the stvle 1o delete:

¢ Select Delere from the shortcur menu.

To remove & stvle from a selected cell or cells:

e Display the Cell Stvies gallery and select Normal under Good. Bad and
INeutral.

&

Clear Formats.

You can remove a cell style from selected cells using the Clear command.
On the Homs tab, locate the Editing group: ciick |<£ | Ciear and then sclect

If vou create vour own styles. they will appear at the top of the Cell Stvles

callerv under Custom.

Cusiom stvies are stored in the workbook in which vou create them. You
can share custom styles berween workbooks using the Merge Stvles
command which appears at the bottom of the Cell Stvles gallery.

The cell stvles are based on the theme that is applied the whole

workbook. If vou change to a different theme. the stvies will be changed to

mateh the new theme in the whole workbook.

@ 2011 Onine Consuling,
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Using Styles a.d Templates Excel 2010 intermedia’s

™ To create a naw stvle bascd on a formatied cell mn vour worksneet. select the

W cell. display the Cell Styles gullerv and select New Cefl Srvie: enter a name
for the stvie and then clicic OK.

® If vou delete a style. the format.” ¢ will be cleared fror ali cells that have

the svle cpplied.

Merge and Center 1s not su, Horted in cell stvies. Il you want merged and
centered text to have a celi stvle. merge and canter the text first then apply
the style.

19

L2

[ o2 N th

e ey

Working with Cell Styies
Onen the Taylor Saies worlbook.
Displey the Eastern worksheet and select celis Al through E1.
On t.1e Home tab. locate the Alignment group and then click 122~ [4zrge & Center.

With the merged cell stili seiectec. locate the Styles group and open the Cel
Siyies caliery.

Point to various selections and view the changes in the worksheet. When vou are
{int:hed. select the Titie style.

Selest the column headings in cells B3 through £3 and use the Celi Styles gallery
1o apply the Heading 3 style.

Continue to use the Cell Stvies ¢allery and do the following:

e Select the row labels in A4 throuzh A6. Appiy the Heading 4 stvie.

e Apph the Total style to the label and figures inrow 7.

¢ Sclect cells A9:F0Q and A11:Ei1 and app'y one of the s'v 25 that appears
under Themed Cell Stvies

¢ Select celis B4:211 and apply the Currency [0] number {ormat.

Select the title i cell A1 and apply formats as follows:

e On the Home tab. locate the Font group and click | 4™ Decreass Font Size:

¢ Ip the Font group, click the down arrow next to| & - Fill Coior and select &
color from the palette under Theme Colors.

To create & n2w style based on the formatting applied to the title in cell Al:

¢ IMake sure cell Al is selecred and open the Cell Styies galler::

o Select New Cell Srviz:

e Tvpe MyStyle inthe Style name box and the click Ok

coniinuec on next page

©® 2011 Onine Consuiting. inc.. Revised 07,26/7%
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Working with Cell Siyies, conlinued
Switch to the Central workshest.

Merge and center cells AL:EL

. Open the Cell Styles gallery and select MySnvle at the top of the ?gallery.

. To apply the Eastern cel! style formatting to the Western worksheet:

e On the Eastem worksheet. select cells ATI:E11 and copy the data:
¢ Display the Westem worksheet and sclect Al:ELL

e On the Home tab in the Clipboard group. open the Paste drop-down arrow
and select Formatting from the last row under Other Paste Opuons.

. On the Page Layout tab in the Themies group. select Themss.
_ Click Apex and note the changes 10 the worksheet.
_ Return fo the Eastemn worksheet and note the changes.

. Sévc the workbook.

£ 9011 Oniine Cananliing Ine Revised 07/26/11 6-5



Using Swvies and Tampiai=s Excel 2010 Intermadiate

Marging Styies

Sivies created or modified i & workbook are only available in that workbook. To use
a stvle in the current workbook thai was created in a different workbook. you ne ed to
copy tie style from the source workhook 1o the active workbool.. This process is
called merging stvie

Merging Styles

1. Cpen the source w orkbook that contains the stvles to be copied and the
! destinaiion workbook that will receive the styles.

STEPS

!J

ake the aestination workbook the active window.

[F9]

On the Home tab. locat= the Stvles group and select Cell Styles.

Click Merge Styles.

:[‘L

2 Select the workbook that contains the styles to be copied.

i 6. Click OK,

@ If the destination workbook Las stvles that have the same names as st tag’
" that are being merged from the source workbook. Excel will display tne
“Merge snvles that have the same names?” nrompt Clicl: Yes 1o replace
stV lus in tne active workbool: with stvies from the source w orkbook: click
No to retain the styles in tie active workbook.

Copy the contents of a cell to which a stvie has been applied and paste it in
another workbook to make the style available in the other workbook.

1. Open the Northern workbook.
= On the Home b, locate tne Styles group and sslect Cell Styiss. Click Merge Styles.

In the Merge stvies fron: iist. seiect Tapior Sales.xlsx and ciick OF.

LB

4. Merge and center celis ALLEL

5. On the Home tab locate the Styles group and select Cell Stviez.

6. Apply the MyStvie style.

7. Apply stvies to the remaining cells in column A and the column headings.

§. Close both workbcoks saving changes when prompted.

e o e A A BT S P
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Using Tempiates

A template file contains a pattern cr framework on which new worksheets can be
basec. Templates usually include data and formatting such as column and row labels.
page headers and footers, and standard formulas. Tuey may also include stvles.
custom toolbars, and VBA macros, v-hich are programming commands. Excel has
several templates that «. ou can use as a foundation for worksheets. Some template
are installed automarically. while others can be creaied by tie user.

When vou create a new file based on a template. you are using a working copy of the
template. When vou save the file, Excel will automatically save it as a workbook
rather than a template. and vou will be prompied to enter a filename. This keeps the
templaze file from being altered or overwritten.

The iilustration below shows the New tab of Backstage View:

[P SR Bookl - Macrasoft Excel S D
@_Hwe e Pagelayow  Formuas  Datz Revew  View ® =<
il s '
Avaliable Temolates Biank warkhook
e save s — ———
% Open G Hore
5§ Qose I B A
i . ~
nic - : T ' ?
L EE @
Recont | Bank fecert Samate Py tempiate:
| workbook temutate: tempiates !
Office.com Tempiates fasror Coze som +
ot - [ - Hie
; i R 1
H H N 1
Save & Send R % .__._j -t
Agenoy: Buagers Eaxpense Feim:
belo repornt;
2% Opnze S ' - o -
== —_— c
€4 b o ".“:‘_—. 5 W . B
v ; iy
iweniones itdoice: it eis st Meracs Pians B
[ . Terd, e P Creawr
E .o s — —
- 5 FE
S pu— — ==t Mgl =
Plenner; becents kezory Scheduter Sistement Stauenery
— / g
ik,
Fagst
Time sneess Nore
categonss

amortizati...

s s es

T
I B
‘ Your Cempeny kams
157 aewva:
4 arr e e

i
I

—
| Ot ;) Lence
L
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Using Templates

12

Ly

Ciick the File tab and seiect New.
Selec: the desired optior under Available Templates.
Select the des'red teinplate.

Chick Creare,

When you create 2 new file based on a template. the template name appears
m the window title bar along with 2 number. For instance. when vou create
anew file based on the Loan Amortization template. *_oan Amc-iizaton!”
appears in the title bar.

Ciick | & Save to save a new workbook that you've created from a
templare. T Save As dialog will be displaved und Excel Workbook *.x1sx
will be automaticaliy selecied in the Save As Type drop-down list. Type a
name for the workbook. navigate 1o the desired location. and ciick Save.

The tempiate categories under Office.com Templates are onl: available if
vou are connected to the Internet.

1f vou download one of the templates from Microsof: Office Online. vou
can save 1t as a template storec on your computer. To save it 25 2 iemplaie.
click the File tab and select Save As. In the Save as npe drop-down Hist.
seiect Excel Tempiare (*.x1:c). This will save the template in the Templates
folder on vour comp! <. The next time vou need ir. click the File tab and
szlect New and choose I, tempiatas. Select the templaie from the New
aialog box and click OK.

® 2041 Online Censuiting inc., Re ssed 07/25/%
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Using Siyl=s and Templates

& 1. Ciick the rile tab and select New.

category. .

2

EEN

Loan Amount:

Annual Interest Rate:

Loan Period in Years:

Number of Pavments Per Year:
Start Darte of Loan:

Optional Exira Payments:

Lender Name:

Using Temipiates

100000

/
7%

Press [Crl} — [ | 1o enter today s date

Oniine Banlk, Inc.

Enter the following information. pressing {Enter<) or [Tap=! after each entry:

!

1

I —

3. Review (Qiz pavment information and the Loan Summary.

6. Save the workbook in the student data foider as Mortgage.

Close the workbook.

~1

©. In the Wew Workbook dialog box. click Schedules in the Office.com Templates

Click Business schedules. sclect Loan amortization schedule and ciick Download.

@ 2041 Cniine Consulting, tnc.. Revised 07/26/17
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Creating Tempiates

Template files are typically used o produce workshezts for forms and reports that
vou need 10 repeatediy create. such as 2xpense forms or weekly or monthiv reports.
As sucli they comain information suct as column and row labels. formulas,
jormatiing. st les. and any other rtems that are part of that specitic form or renort.
Besides temiplute filzs that come with Excel or that vou can download from M- _rosoft
Ofiice Online’'s web site. vou can also create vour own templates to save tirie.

chieve consistency. and deveiop custom acpplications.

For example. vou could create a trevel expense 1zmnlate for vour compary that
includes formulas to calculate various totals. You could protect the cells that comain
formulas so that other users cou'd not modify them. All emplovees couid then use the
emplate to not only save time but also to eli:ninate mistakes 11 celculations.

When vou save a template. by default Exca! points to a location in the Micr soft

Office Templates folder whare its buili-in tempiates are storec. Accept this location
o have vour template appeai on the Personal Templates tab of the New craiog box.

Creating Tempiates

ke

STEPS

o . {l
H

f B e

1. Create a worlthook with the desired headings, formulas. and formats. Do not
include informarion that will change.

| 2. To save the workbook as a template. click the rile tab and seicc
! Save As..
3. Enter the nane of the file.

i 4. Open the Save As iype drop-down list.

I 3. Select Excel Templare (*.xlix).
6. Chel Szvs

- = DAY 1T UL Y AT, TAE

Templates have an .xltx extension.

If a tempiate contains macros. the file needs to be saved as an Execel Macro-
Enaoled Tempiate (* .xlom) file type.

The defau!: location for teraplates you create 15
C\Documents and Seuings'<Username>\Application Data\Mizcrosoft Templeates

You can use any Excel workbook as a template. even if it has not besn

Q saved as a template. by moving or copving the file to the defav location tor
templates shown in the note above. The workbook will appear on tie
Persona Temgpiates t-b of the WNew dialog box. When vou open the
workbool., a working copy, rather tuan an originai copy. of the file i¢
opened and its nume is displaysd along with a number in the tiile bar.

@ 20* Onune Censuling, inc., Revised 07/26/17
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Excal 2010 Intermadias Using Stvies and Templaies

® If tne templates that you create are not saved in the default folder. they will

not appear on the Parsonal Templates tab of tne New dialoz box.

To save a template vou have created back to a workbook. open the tempiate
then use the Save As command from the File tab. Remember to change the
Save as Type to Lxcel Workbook (*.xlsx) beiore saving the file.

t2

(SP)

Crzating & Tempiate
Open the Eypenses Workbooit.

In cell 18. create a formula that sums the mileage reimbursement and the
misceliansous expenses.

Copy the formula down through cell H22.

Select the ranges C3:C3 and A7:17: apply the Heading+ cell stvle to the ranges.
Seiect call Al and apply the Titie cell stvle.

Format F8:G22 and 18:122 as the Currency cell style.

Apply the Toral cell stvle to cell 125,

Move the cell pointer 1o D3.

Click the File tab and select Save As.

. Select Excel Template (% xlix) from the Save as fype drop-down list.
. Click Save.

. Close the template file.
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13

)

.,[>

t™h

€.

5.

10. Close any open workbooks. saving 23 desirec.

Click the File tab and seiect New.

Click W tempistes.

Using a Temolate

In ihe New dialog box dovble-clicl. the Expenses template. Nete the file name in

the title bar.

~ . . - freamenuvan) -
Add the following daiz in row §. pressing Tacs) after each entry:

E_Date | Todey's Dats
¢ _ocation l Philzdelp iz, TR
!_ e inring Odomeis b 17003
|
Ending Odom-ter l 17089
Niscellaneous Expense 1 15,00
‘ :
[ Iviscallaneous Exnense Descripiion | pariing

To save the expense report in your foider:
o Click |zt Seve on the Quick Access toolbar:
¢ Type January Lxbenses as the [T1ie name:

e Be sure to navigate 1o the smdent data folde:

o Clicii Save.
Close the workboolk.

T delete the temipiate:

¢ Ciick the =ile tab:

e Seleci Now:;

o Ciick My tampiates:

e Dighi-chick Lxpenses:
o Select Delecc:

e 1In the Confirm File Delete dialog box, click Yes.
Close the Wev. dialog box

Click the Home tar to display the workshieet.

]

e ot

@ 2044 Cniine Ceasuling. Inz.. Reviset 7,267
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8.

Review - Working with Charts, Lists, and Styles
Open the Iavent workbook.
On the PC Producis workshest. zlect the range A6:E10.

Creats a 2-D ciustered column chart with a legend. and the title “Inventory
Conirol Associates™ on a new sheet named Inventory.

Add axis titles as desired.
Changs the chart type to 2 3-D clustered column chart.

To add the hard drives information to the chart. on the PC Products worksheet
copy the range F6:F10 and paste it into the chart.

Format the Titles as desired.
Select the Employee List worksheet.

Move the cell pointer within the data and create a table. The range is A5 1o H3Z.

_ Sort the table by Emplovee ID in ascending order.

_ Filter the list to find emplovees with a BA degree who are earning more than

$43.000.

_ Move to the Annua! Review worksheet.

. Create a stvle named My Heading 1 that formarts text to 14 pointe. bold. and

red. Apply the style to cells A1 and A3.

_ Create another style named v Heading 2 that formats ©xt 1o 12 points and

bold. Apply the style to celis AS. A7, A9. ALl and A13.

. AutoF1t column A.

. Just note how vou would save the workbook as a template. (If vou do. in fact.

save the file as 2 template in the default folder. be sure to delete the template file
from the Persona Templates tab of the New dialog box.)

. Save and close all open workbooks.

© 2041 Oniine Sonsuling, s, Revised 07/26/1° 6-13
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Excel 2010 Intermediate

Using Protection and Shared Workoook Feaiures

Protecting workbooks and worksheets
Working with shared workbooks
Configuring a workbook for shared use
Highlighting tracked chianges

Crealing the history report

Reviewing shared wurkbook changss

Merging workbocks

€ 2071 Online Consultina. Inc.. Revised 07/26/11
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tUsing Protection and Shared Workbook Featurss Sxce! 2010 tntermediats

Brotecting Vorkbooks and Workshests

Excel has various levels of protection to prevent SOMEOne from changing the content:
of a worksheet or altering d workbook. Protection at the wor \.sheet level includes
preventing datc. objects. or scenarios from oeing changec. brotection at the
workbook level can prevent worksheets from being added. delered. hidden. or
renamed as well as maintaining the size and placement of the workbook vindanw.

When you use protection in Excel. vou have the optioit ol assigning 4 case-sensitive
password in the different dialog boxes. This prevents others from unprotecting the
worksheet or workbook and making unauthorized changes.

The ilinstration below shows the Changes group on the Review tab that contains
options for protecting both worksheets and workbooks.

% protect and Share

Workbool \ These commands Drovias
i yarious choices 1o protecl

\ elemenis Ci WOrKSnests

\ and Workpooks.

o Allow Users to Edit Ranges
protect Protect Share .

Sheet Workbook Workbook ‘> Track Changes ~
Chanageas

——

Components ol protecting workbooks and worksheets are tisied below:

| Protecting 2 Workbook You can protect the structure and/or the workbook
window.

e

Protecting the srructure wil! prevent viewmg hidden

wo-ksheets. inserting new shests. deleting sheeis.

modifying the names of worksheets. and moving or

! copying worksheets 10 another workbook. However.
vou can insert an embedded chart in a protected

! workboolt.

DProtecting the window will prevent changing the
size or position of the window.

- You can set a password t0 further proiect a
workbook.

' Proteciing 2 Worksheet By default all cells are locked when protecting a

} worksheet. To allow changes 0 specific cells vou

~ must unlock them before prot ecting the worksheet.
Optionally, vou can grant permission Tor s 2Citic
users to change locked cells. This. t00. must be st
before protecting the worksheet.

You can set a password to further protect several 0l
the worksheet protection opriois.

T
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Using Protection 21¢ Sharad Viarkbook Featuras

Proteciing a Vorkbook

When sharing a workbook v ith others. vou may want to protect the workbook from
certain changes. such as a worksheet being deleted. The choices available in the
Frotect Structure and Windows dinlog box, which 1= opened from the Protee
Workbook command, are illusirated beiow:

Prevenis adding, deieting,

nir

renaning worksneets., ——-——*—E’ Structure

Protacts a worlbook's —F

wingow from being moved, | _ L '
resized, minimized, or Password (optional): |

7, unhi

maximizad.

F'rotect workbook for

ding. or
d . .
L[] Windows

If used, the passvior
T must bs amered fefore &
worrbcun is unprois o.ed.

N

EEEn

Froteciing a VWor kr‘ocp\

B T

Set up the workbook as it should be when protectzd. inclucing hiding

v-orksneets and designating the size and placemen: o the v adow,.

To =nable protection for the workpool:

e Onthe Review tab. Jocats tne Changes group anc click Protzet Workbook:

o Select the desired options;

¢ Opuionally, type a password and click OK. In the Contirm Password
dialog box. enter the same password again and ciick OK,

To remove the workbooi: protection:

e Ontne Review tab. locate the Changes group and clicl: Protzact Workboal:

e Ifnecessary. enter the passworc and click OK.

@7

ﬁ

You can set 2 password protect to prevent users from opening a file: "Iicl'
tne click the Filz tab anc select Save As. In the Save As dialog box. oper the
Toots drop-down lIist and select General Oprions. Type a p(.ﬁword in the
Password 10 open text box. When prompted, reente~ the password and click
Ox. Click Save and then click Yes.

Passwords that you assign in Excel arc case-sensit ve. A password can be un
10 255 characters long and mey consist of numbers. Jetrers, spaces, anc
symbols.

Excel has no method for vou to readily recover forgotten passwords.

€ 2717 Online Consulting, inc.. Revisey 07 '26/11
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10.

11.

Protecting a Workbook
Open the Quarterd workbook.
On the Home tab. locate +he Cells groun and select Formet.
Select Hide & Unhide and click UI?hid&;‘ Shee!.
Note that the 4th Quarter worksheet is hidden and click Cancel.
If the workbook window 1s maximized. click & Restore.
Resize the workbook window to show only through columns G.
On the Review tab. locate the Changes group and ciick Protact Workbook.

In the Protect Structure and Windows dialog box:

e Mazle sure that both the Srructure and Windows ~heck boxes are selected:
o Do not entar a password:

e Click OK.
Trv to maximize. move. of resize the Quarterd workbool: window.
Click several worksheet tabs to note that vou can still access the different sheets.

On the Home tab. locate the Cells group and click Zormat. Note that vou cannot
hide. unhide. rename. move Or COPY sheets. or color-code worksheets.

_ On the Reviev! tab. locaie the Changes group and ciicl- Protact Workbook 1o turn off

the workbook protection.
 Maximize the workbook.

_ Save and close the file.

@ 2011 Oniine Consutting, Inc.. Reviced 07/26/11
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Using Protecticn and Shared Workbaok Features

Proteciing a Workshest

Use workshezt level prowection to prevent data. objects. or scenarios from being
chaneed. Pratecting a worksheet reauires two steps: unlocking cells or ranges where
changss will be aliowed. and enabling the protection.

The illustration below shows the Protection tab of the Format Cells dialc g box: that is
used to designate selected cells as locied or unlocked:

By defaul:, iniually all c2lis
in a workshee! arg
azsignated as locked.

Salact to hide tha display .~
of a cel's formuia in the
Formuda bar. Th2 value tc
which the formula equates

wilt stilt b= displaved 0 in2
workshee! arsa.

S S —

Numbe: = Guonment Fort Boroer Pattern

———f=—v| Locked

/:I Hidden

Locking celis or hiding formulas lias no effect uriess the
worksneet iz orotected, To pretect the worl:sheet, choose
. | Protection from 2 Tools menu, and then crinose Protact
' Snee:. & passwoi 13 ophional,

L ov 1| ¢

The Protect Sheet command opens the Frotect Sheet dialog box. where vou can
specify the protection status of the current worksheet as ilivstrated below:

Prohibits changes to
v/orkshzef a stipuia
in the st b= ow ana
focked celss.

Id=ntiiies elemente anc
editable operations in &

nrotacted worksies!
witich users have
access. Tne icp wo
items are selectad b
deiault.

a

ted :
i . Password to unprotect sheet:

~a [ . 3 . 9
2] Proce ot workshest anc conitents of locked celis

Aliaw 2! user= of this worksneet tc:

& TR

i 1 Selact uniocked celis

- Format celis

i . _|Formet colurans

4 5 fg Format rows

' inser columns

y y ;:]Insert 'rows i i
T Jinsert hyperiinis

" Jueiete coturans

N D Delete rovis b
N

18]

; Ok ][ Cance: ]

I used. the password

must e entered before
tne snaat is unproteciad

© 2011 Online Consuliing. Ins., Revised 07/26/11
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Protecting ¢ Workshesl

= - e N

= . T ST TR

1 To unlock the cells in which to allow changes once the protection 1s enabiec:
" ¢ Select the desired cells or ranges:
)h e On the Home tab. locate the Cells group and click. rormat:
. Seieet Lock Cell.
| 2. To enable worksheet protection:
¢ On the Review tab. locate the Changes group and ciick Proiect Shest:
‘L ¢ Ensure that Pretect worksheet and contens of fncked cells is selectec:
i‘ e  Optionally. Tvpe a password:
i o Select the items to be enabled for all users of the worksheet under Allow
:_ all users of this worksheet 10:
: e Click OK: if necessarv. enter ihe same password again in the C onfirm
! Fassword dialog pox and click Ot
3. To remove the workshest protection:
¢ On the Review tab. locate the Changes group and seiect Unprotect Shest:
f o 1 necessary. enter the password and chick OK.
|
X

By default. all celis in 2 worksheet are locked. If vou want the majority of
(he worksheet to be editabie. vou can first unlock all cells in the worksheet
. d then lock onlv the cells ana ranges vou want to protect.

Using a password m the Protect Sheet diatog box prevents otiers from
unprotecting the worksheet. When granting aceess of proteciced ranges 16
individual users. you can enter a password to prevent cthers trom editing
ine designated ranges.

&

When a cell containing a formule is unlocked. & green triangle appears in
the upper-left corner of the cell 1o indicate an unprotected formula. If vou
selest the cell, ‘_2 Trace Eror displavs to the left of the cell. Point Lo the
error indicator to view the folloving ScreenTip: This celi contams o
Sformula and is not locked to proiect It from being changed inadveriently

I you click @ Trace Error. a list of options appears under the heading
“Unprotected Formula™

The Protection tab i the Format Celis dialog box is not available if the
worlksheet 1s protected.

The elements selected in the Protect Shect aialog box affect the entire
worl.sheet and appiy to all users.

=~
]
o

© 2011 Oniine Consulung. inc.. kewsed 07/28/77
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e

To select the entire worksheet, clic:: tive Select All bumon in e upper lef:
corner of the worksheet where tne columrn and row headirgs meer.

To unioci: cells. right-click tie selected cells and select Formar Cells. Click
the Protection tab. remove the check next to Locked and click OK.

{z ; You cannot lock or unlock individual ceils after protecting a werksheat.

Y ou must first remove tne prote.tion. .
Mary menu choices will be unavaileble whan protection is turned on.

If vou copy a protecied worlisheet to another workbook., 1t will still be
protected. If vou copy cells from a protezied worksheet to another
workbook. they will not be protecied.

If worksheet protection is enabled, yvou cannot grant specific users access ¢
edit ranges.

(PR

:1.\

ti

Protecting a Worksheet
Open the Williams workbook and dispiay the New York workshzet.

To make sure that an Error Checking rule 1s enabled before doing the exercise:

¢  Clicl the Fils tab and click 1 et

o Clicl: Formuias:

e Under Error Checking Rules. ensure that Unlocked cells conaining fornudas
is selecred and click OK.

To unlock cells to be used {or data entryv:

e Seject cells BS:EE:

¢ On the Home 1ab. locate the Cells group ans click Foriuan setect Lock Ceil

Nete the green triangies and the error message for the cells containing formuias

i 5 through E8. Select EZ:E8 and click ‘<’| Trace Error: select Lock Ceil to lock

them. Note the green wriangies are gone.

To enaple worksheet prote ction for the worksheet:

e  On the Review tab, locaie the Changes group and click Protect Shesl:

e Leave the three default check boxes selected:
e gave the password biank and ciick OK.

Select cell B13 and v 1o wvpe over the formulz: click OK to ciose the warning
dialog box. Verifv that only cells B5:D§ can be edited.

Save the file.

© 2071 Onine Consuiling, Inc
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Allowing Users to Edif Ranges

Lists editable ranges
tnat nave been
@siined.

Opens a dialoa box
10 stipuiate usars and
their password
parmissions jor the
$3iected range.

Creates e list of /

rangas znd ussr
permiss s in a
n2W WOTKDOOr.

i e
—7| Permissions... l ;

When vou protect a worksheet. all users are prohibited from maling changes {0
locked calis. Before protecting a worksheet, you can provide exclusive uccess to
individuals, groups. or computers to allow them to edit specified ranges in the

worksiieet. With this access. a user can make cranges 1o cel:s even if thev are tocked.

The Allow Users io Edit langes dialog box. avaiizble from the command with the
same name and shown below. 1s where vou assign special access

| Crens the New Rangs
| diaicg box 1o dsiing an
<4 editable range.

' Ranges unlocked by a password when shest is orotected:

to protected rangas:

Titie Refers to cells

Profit Datz Opens the Modify
— Range dialog box to
alter the selectad range.

~ Removes the selected
range irom the list.

|

Znecity who may edit tha range without & password:

i —

| raste

permissions information inte & new workbook

Ok ] [ Cancel

’5 t Frotect Sneet...J [
| |
1

Displays the Protect Sheat dialog box where you can
eniter & password 1o protect (e worksneet.

el
e e
Snier g itie for thz range thal | Tids:
you arz granting accass (e

— Brofit Date l

Snier the range of cells tha! Refers to celis: :
access is being aranted ic ~— —Bo:DE F:‘

R i
nter 2 password tat is requirsd | Range password: :
10 edit the speciiied rangs of L "0 ogae
cehe, If vou do not use & . -
password, anyotie can edit the
range A — - -

o | Permissions... ] l OK J ‘ Cancel

Disniays the Permissions for <Range Name™ dialog box
10 stipulate users anc thair passworc permissions.

7-8
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Allowing Ugers

to Edit Ranges

When vou prorzct a worksheet. all users are prchibited from making changes 10
focked cells. Before protecting 2 worksheet. vou can provide exclusive aceass i

mdividuals. groups, or computers 1o aliow them to edit specified rang
workeheer. With this ceeess.

ses in the

. user car make changes to cells even if they are iocked.

The sliow Users to Edit Ranges dialog box. available from the command with the

same name and shown below. 1s where vou assion spacial access 1o protecied ranves:
) Zn sp i g

R T

; Renges eniacied by a password when sheet

is prot=ztad:

Titlz
profit Data
Liste editabi= rances
{hat have teen i
aelined.

Re ‘ere to cebs
$BF6:5045

Crens the Naw Ranos
_ Galsgposto definz a

r ediaole angs.

Opens & Giaioa boy |
ic stintiats users and
iheir passworc
parmissions for the
Selacian rangs.

Craates 2 lis of /f

H

[ Spedfv wiho may edit the range without & pesstord:

rengas ard user
parmissions in a

Zanzel

| |

On3ns the iAodil

1— Rangs cialod cox 1o

— b
| Delete
L —

~}

alier the seiszied ranoe

"~ Reroves the selected
range from iz ist.

NSW WOTKDCOK.

Disolays th~ Protec! Shest dialog bo whers yor ca
enier @ password to protest the worksinest.

Enter a title for the range that
you are granting access 0.

£nter (ne rangs oi celis that
access is peing granted fo

=nier a paseword that is required

10 =dit the specified rangz of ___1

celts. If you donctuse e
password, anvone can edif the
range.

3 "ﬂ"q

m% «sa&

T DrnhL Leta

Pere to celis:

I =B&:DE

i

. Range password:

T OUIGeHOe

|

[ o

[ Permissions... |

!

| . .
Dispiays th= Permissions fcr <Range Name> dialog oy
to sfipuiate users and their password permissions.

€: 2011 Uniine Consuting Inc.

Rev.sad 077’



Excel 2010 intermediae Using Protaction and Shared Worikbook Features

Allowing Users to Edit Ranges

S < _
‘ '\*\39 2 1. On the Review :ab. locate the Changes group and select £liow Users 1o Ldit
= W Ranges.
STEPS i the Allow Users to Edit Ranges dialog box. click Naw.

[¥8)

To create a range and its access permissions for specific vsers. do the
following in the New Range uxalog box:

¢ Inthe Title text box: type a title for the range:

e Inthe Refers to celis text boxz: specify the desired worksheet range:

A A, T R 4 T e
>

s Inthe Range password text box. type a password to uccess the range:

¢ Clicl Permissions:

i
i e In the Permissions for <Range Name> dialog box. do the {oliowing:
3
t .
—  To acesss users on the svstem. click Add:
| — In the Select Users. Computers. or Grouns dialog boz, enier the

desired users in the text box and click OF:

- To xeqmr° a user to supply t1e password to edit the range. select the
f user’s name in the list at the top of the Fermissions dialog box and
then select the Denry option at the bottom of the dialog box:

—  Click OK. If a security warning appears. click Y2 10 contimue.
o Cilick OK to ciose the New Range dialog bo::
' ¢ Ifnecessarv. in the Confirm Password dialog box. reenter the password

t and click OK.

}_ 4. To grant access 10 other ranges. click New in the Aliow Users 1o Edit Ranges
dialog box and repeat the steps above starting with Step 3.

| 5. Toenable the protection afier ali ranges have been sei up. ciick Protect Shea
‘ in the Ailow Users to Edit Ranges dialog box and do the foliowing:

e Ir the Protect Sheet dialog box. ensure that Protect workshicet and
coments of locked celis is selected.

¢ ¢ Optionally. type a password in the Fasswor d 10 unproiect sheet 1€xt box:

s Select the items to be enabled for all users of the worksheet under Allow
| all users of this worksheer 10 and click OK;

] e Ifnecessary. in the Confirm Password dialog bo:. enter the same
' password again and clici: OlC
1

. To specify a worksheet rangs {0 grant access 1o users in the Reters To Celis

]
t=xt box of the New Range dialog box. vou can eitier type the range or click
Q COHaDSD Dialog and select the range: then click U Zxpand Diaiog or press

L Enter -t ).

~ 2014 Anline Canauliine inz.. Rewsed 07/26/17% 78
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=xze! 2010 Intermediz =

To change permiissions for ¢ range. select it in the Allov U sers 1o Edit
Ranges dialog box ana click Permiss.ons.

To modity & range name, the celis to wiich it r2fers. or its password. sefezt
itin e Allow Users 1o Edit Ranges dialog box and click Modify.

wh

[@a)

h

1C.

11.

17

Lt

15.

Aliowring Users to Edit Ranges

o the Williamis workbook. move to the Fio ae Janeird worisheet.

Se

ectthe rance B37:D8.

On the Review tat. in the Changes group. click Allow Users 1o Zdit Ran.zss.

In the Allow Users tc Edit Raiges dia'cg box. clizl: New.

Enter password inthe Range password 125t box and clicl: Ol

IR

Reenter the password in the Cenfirm Password sox and click GiC.

Click Proteci Sheet and then click CK.

Auempt to enter 25,000 in cell C3.

Enrer the password in the Tnlock Range box.

Chan e the contents of C3 10 22.000.

WMove to the Prefits worksheet and protect the sheet.

Note the Rio de Janciro January profit value in cell B7.

. Move 1o the Rin de Janairo worksheet and change cell B3 to 230.000.

. Return to the Profit worksheet anc note that the Rio de Janeiro profit has beer

updaied ever though the worksheet is prorecied.

. Dpuonally, 1o hide the display of formulas in tae Formula Bar in the Profiis

worksheet:

e  Unprotecr {iie sheet:

»  Gelect cells BE:EI2. Right-ciicic any cell in the rarge and choose Formiar
Celis:

e (Click the Protection tab. select MHiddern: and 1 =n chick OK:

e  Protect the sheet:

[

Note the suppression of the formuias in the formuta bar.

Save and close all oper workhoois.

D o e - - i s T g e st

110
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Working with Shared Workbooks

Workbook sharing allows multiple users on a network 10 simultaneousiy view or
modifv a workbaoli. Since some Excel features can’t be changaed when a workbook: is
designated as shared. vou should set up the data and format It as necessary belore
making it available to other users. Once multinte users can edit the workbool. as the
save tieir changes. other vsers can see tue modifications. When vou save a shared
workbook. it is updated with al! the changes tuat other users have saved 10 1L

Al features of Excel are not available when a workbook is shared. 1T vou want 1o
include any of the following features. you should add them before vou save the
workbook as a shared workbook: merged cells. conditional formats. data vaiidation.
charts, pictures. objects including drawing objects. hyperiinks. scenarios. outiines.
subtotals. data tables. PivotTable reports. workbook and worksheet protection. afi.
macros. You cannot make changes to these features after vou share the workbool.

Conflicts arise onlv when multiple users save changes that afiect the same cell. When
this happens. Excel will display the Resclve Conflicts alalog box so that the last

person to save the changes will get 1o decide wiiich alterations to keep.

The steps in this process are as follows:

- s g 253

L e A workbool: is saved as ¢ shared workbool: i a shared network location.

Individual users edit and then save the workbook.

e o
o

One person reviews the worlkbook and accepts and/or rejects cihanges.

. R v/
@ 2011 Online Consulting, inc.. Revised &7728 7-17
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Ex-el 2010 Intermediatz

Configu: ing 2 Workbcok for Sharad Use

Before a workbook can be shared. it must be configured correctly. The originator
must enable workbook sharing so that multiple users can access it. You can share a
workbook or you can protect a workbook with a password and share it at the same
time. Once the workbook is shared, many users can edit the data as needed.

The following is an illustration of the Share Workbook dialog box for sharing « -
workbook:

i

- . |
Select this checkpox —— [
to enable workpook

sharing.

. Editing | Advanced

L oK ] L Zance! j}

Seiect a user from ihe
Iist above ana chic:

Remove User ——— Remove Userio

disconnect a user
from the session.

The illustration below shows th- Prot=ct Shared Workbool: dialog box where you can
add 2 passv.ord and share 2 WOrkbooi ai e saine time:

Select this checkboy 10
enable workboor.
snaring and password
nroteziion.

| Prokect workbool: fFor

— [ 3naring with Frack changes.

removed.

Password (optional):

This shares your workbook and ther orevents changs tracking from: being

If desired, & password must be chosen now, prior to shering the workbook.

© 2011 Onhne Consuliing. Inc., Revised 0726/ 1



Configuring 2 Workbook for Sihared Use

5} [ '5 I
g ,0 3 E 1. Open the workbook that is to be configured.
' 2. To share a workbook:
STEPS |

¢ On the Review tab. locate the Changes group and click Share Workaook:

. { e On the Editing tab of the Share Workbook dialog box. seleci Aliow
| " changes by more than onc user at the same time. This also allows
l workbook merging:

! e Click OK:

| o At the “This aciion will now save the workbook. Do vou wanl 1o
i continue?” prompt, click: OK 1o save the workbook.
¥ i
} 3. To remove a workbool: from shared use:

p
: e On the Review tab. locate the Changes group and click Share Workbook:
L ¢ On the Editing wb of the Share Workbook dialog box. clear Allow
: changes kv more than one user at the same rime. This also aliows -
i workbook merging.

e Click OK:
' ¢ Click Yes. ;

If vou want 1o limit aceess to a shared workbook using 2 nassword. use
Protact and Share Workbool: in the Changes group on the keview tab. The
Protect Shared Workbook dialog box has eptions for enabling tracked
changas and for adding an optional password.

To remove an individual user. display the Review tab. iocate the Changes
group. and click Snare Workbook. On the Editing tab select the user vou want
to remove. and then click Remove Uszer.

The maximum number of users of a shared workbook 1s 236.

Sharing 2 workbook turns on the crange history. By defauli. the change
historv is retained for 30 days. If a different period is needed. click Snare
Warkbook and then click the Advanced tab, and enter the number of deys n
the Keep change history for text box.

® Any user can remove a workboox from shared use and change any of the
options uniess Sharing with racic changes is enabled and a password has
been entered.

Passwords are case sensitive, 1 forgotien. they cannot be recoverac.

When a workbool: is removed from shared vse. the cnange history 18
automatically deleted. Make sure the changes have been accepted or
rejected first.

© =011 Oniine Consulting, ., Revised 07/26/11 753
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Using Protection arc 3t arad Workpook Features =xcel 2010 Intermegiats

L e e S e

Configuring a Workbook for Shared Lse

The workbooks thar we wili use {or the exercises in this chapier have been designed
to sitiulate working i a shared environment without needing to be in a sharec area.

Open thie Suared workbook.

2. Display the Review tab.
5. Locate the Changes groun.

4. Click Share Workbook.

n

O tne Titing tab of the Share Workbook dialog box. select the
Aliow changes by more than one user al the senie time check box and click O:C

(. Click O¥ to answer the promipt: “This action will now save the workvooin Do
vou warnt to continue?”

7. Note the addition of [Sharad] in ine title bar.

ey s ® 20" % Ouiine Consuling. .nc.. F.2viseo 07.25/1
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Highlighting Tracked Changes

The ability to track (he changes made ic a shared workbook. wher: the changes were
made. and by whom, is important. This feamre is so closely linked with workbook
sharing that if vou enable the Highlight Changes option. the workbook is
automatically sharec.

Below is an illustration of the Highlight Changes dialoyg box foliowsd by u
description of the Highlight Which Changes options: :

Enahies tracking
and shares ine

~1+] Track changes while editing. This also shares your workboaic
wOrkbook. }

Highiight which changes

1

. o : ) e [ . A+
Sets fhe interval ; [“]when:  Since Tiast savad «
users, and range — [Cwhy Everyone ~
0 \ [ -
cice lS'lO pe Clwhers: = = Creates cell borders
tracked. ere: . B | anc comments for

edited sele.

1] Highlight changes on screer

"J List changes on & new sheet : Creales a History
report of ali changes.
i 7 e
of || cancel |
§ When spacifies the interval of time to retain or display changes.
¢ Who specifies which user changes to track.
! Where provides the ability to specify ranges of cells for tracking.

© 2011 Oniine Consulting, Inc.. Reviseo 07/26/17 T8
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Highlighting Tracked Changes

. 1. Display the Review tab.

= Locate th= Changes group and click Track Changes.

LVS]

Select Highlight Changes.

4. Select Track changes whiic editing. This also shares vour workbook.

w

Make the desired seiections from the Highlight wiiich changes options.

6. To enable borders and cell notes for editec celis:

! o Select Highligh: changes on screen.

| 7. Click OK.

To make sure thar your user name is correct so that vour changes are
properly identified in the shared workbooi:. click the File tab and click

_a oees . Verify the name in the User name text box under Personalize
your cony of Microsoft Office.

The porders around edited celis will displav in different colors for each user
who edits the file.

The comment indicator dispiays in the upper left corne: 10 indicare racked
changes rather than in the upper right comer as it does for a regular
comment.

To add. edit. deieie or view comments use the Comments group on tiie
Review tat,

[e}}

1
1

© 2011 Online Consulting, Inc.. Revised C7/25/11



Zxcel 2010 intarmadiate Uising Proteciion and Shared Workbook Feaiures

1)

(O3]

o

9.

10.

14.

Hiahlignting Tracked Crianges
In the Shared workbook. dispiay the Review tab.
Locate the Changes group and select Track Cnanges.
Select Highlight Changes.

Match tiie choices in the Highiight Changes dialog box with the illustration
below:

| 7] Trazk changas while eciting. This also shates your workbook, N

Highiight shich changes

“lwhen: Al v
7] Whe: ‘Everyone b
[ wihere: T

[« Highlight chang=s on scresn
[ st changes on a new shest

Click OK rwice.

Chanee the contents of cell B7 to 567. Note the border around the call and the
note indicator in the upper left corner of the cell.

Point to cell BT and read the note that is displaved.
Change the conients ofceli Bll1to =sum(27:BL0
Change C1010 25C.

Select cell B10 and click |4 h-w Comment in the Comments group on the
Raview tab.

. Type Why are sales so low? and click outside the comment box.

 Add the foliowing comment to cell F1:

What hapopsned this month’ i
4

. Add any other changes as desirec.

Save and close the workbook.

& 2011 Online Consulting, inc.. Revised £7.28/17 TA47
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Creating the History Report

The History report listing all the saved changes made 1o the worksheer automatically
appears on a separate sheet once it 1s configured. Although the report is not saved
with the workshezt. it can be regenerated at any time.

Creating the History Report

e
—

Open tiic shared workbook.

STEPS

[ ]

Make the desirad changes to the worksheet.

Save the workbook.

L)

Displav the Raview 1ab.

5. Locate the Changes group and click Track Changes.

e e AP S S ot
RSN

6. Select Highiight Changes.

i 7. Clear the chiecks next 1o Fhen. Who. and Where i the Higalighir which
; changes options.

8. Select Highlicht chicniges on screer:. if necessary.
i 9. Select Lis? ciianges on u new sheet.

|10, Click « L

@ The History worksheet is created with the AutoFilter feature wrned on and
7 can be used 1o filter this worlshest to view difierent categories of changes.

Once the workbook is saved. the History wor! sheet will be dejered
automatically. To retain a copy of the change nistory. pring tne Histor:
workshee: or copy the desired cells from the sheet to another workbook.
The worlishee: cannot be copied as vou cannot copy & worksheet from a
shared worlbook.

Sharing 2 workbool turns on the change history. By default. the change
history is retained for 30 days. If a different period is nesded. display the
Raview ta» and locate the Changes group. Click Snare Workbook. click the
Advanced tab. and enter the number of aays in the Keep change vistory jor
text box.

718 © 2011 Online Consuliing. 1112, Kevised 07/25/17%
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Creating the History Report

1. Open the Shared2 workbooi.

2. Make the following changes 10 the workshee:
o Changecell A0 o North Hills Mall:
¢ Changecell D710 2752
o Change cell EC10 70C.
3. Save the werkbook.
4. Display the Review tab and lozate the Changes group.

5. Click Track Changes.

6. Select Highlight Changes.

7 Clear the When. Who, and Where options under Highlight which changes.
S, Select List changes on a new sheer and click OK.

9. Display the History worksheet.

10. Save and ciose thiz workbook.

11. Open the Shared2 workbook again.

12. Change cell G710 842,

13. Save the workbook.

14. Regenerate tite History report.

. Save the workbook.

@ 2514 Online Consultine. Inc.. Revised 07/28/11 7-1¢
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Raviewing Shared Workbocok Changes

Once rovisions have peen made te a shared worl book. they are reviewed by ong
mdivigual and are either acceptec or rziected. This can only be done wfier ali vsers
have saved their copies of the shared workbook.

Below is an niustration of the Select Changes 1o Accepi or Reject dialog box:

&oeciiv ine intarval,
users. anc rangs of —= _1WhZ:  lEvervons o
slisto paraviswed | LDWhere- T =

| .
|

The illustration below shows a workbook with the Accept or Reject Changes dialoz
hox open and cell B11 highiighied:

r N
B sharec2uisx (Shered: . = E
f A B ¢ I ©v " E_F & H N
1 MusicTims, inc. _:ll
2 Quarierly Report !
T |
= . . L n
5 ) QIR 1 Q2 ¥TD : l
o _‘Stoe S5 i Ldat Gty R Ty . BpY Ly Jrn i H
7 l Emntzips 32l 867 433 375‘4‘ 200 230 821 yaes i
8 | Serhtaa 178 i) i 2258 380 3253 779
|9 ' sebubes Piaza 300 0 358 700 42 £30 7735 P
10 “eostiy #ils Ealt 108 25 533 563 7T EX 2153 i
11 Towks 1133 140 1€38 72 115 £ 15300 :I
LA i
iz e
13 =
iy !
15 - it
1% Change 2 of 4 mede te this document: ! ,I
17 [Studers, 5/25/2011 .27 PM: i~ !
P !
;'-q— | Zhanged cell D7 from '200" to 375", y
20 :
- I
21 - i
2 3 , v !
E : - .
p7:8 I Accept Eeiec: J Accept b 1 [ Raect Al j | Cese ! "
P 7 Y = -
£33
28 \/ N ~|
Accept or reject Accept 07 rejec
indiv-due Char\ges. ali changes.
7-2 © 2011 Online Consulung Inc., Rewissc 97/28/17
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Zxcel 2010 tnisrmadiate Using Protection anc Sharec Workbook Feafurss

Raviewing Shared Workbook Changes

-

1. Maeke sure that 2!l users have saved the shared workbook.

-, Display the Review teb and locare the Changes group.

3. Click Track Changes.

a,—
mil €,
W

o =

| 4. Select Accept/Reject Changes.
5 in the Select Changes 1o Accept or Reject diatog hos. make the desired

choices.
;0. Ciick Ok
7 Select the desired revision. ii necessary.

R To accept the change:

e Clicl Accept.

. 9. To reject the change:

N o ik Relagll

10. To aczept all ravisions and ciose the dialog box:

o Click Accept All.

11. To reject all revisions anc close the dialog bos:

¢ Click Reject Al and ciick Yes.

2. Save the workbook.

e

@ Y ou do not have io own the workbook to accept or reject changes.

However. it is a good idea to decide who will do this when the workbook 1s

st up.

If more than one user has mads changes 10 e same cell. a dialog box will
appear containing the original value and each of the user’s changes. Any of

the changes can be accepted. including tne original value.

Once a change is aceepted or rejected and the workbook is saved. the
change is not available to be reviewed by another user.

If the workbook has unsaved changes. you will be prompied 1o save th
before accepting or rejecting revisicns.

18I
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=1

[=2e]

ot

F.eviewing Share d Workb.ook Char ges
in the Shared2 workbook, d spiay the Raview tab and iocate the Chanses orous
Click Track Changes.

Selcct Accezpt/Reiect Change and click OF,

Click Accept for the Tirst proposed change.

Zlick Aczept for the second clrange,

Zlick reigct for the third cbange.

Accept or reject the remaining changes as desired.

Save and ciose the workbook.

© 2017 Oniira Sonsulting, inc.. Revisad 252011
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=xcel 2010 In

mediate Using Proteciion and Shared Workbook Features

Merging Workbooks

If multiple users nesd to edit a workbook but do not have access to the network, you
can still share the workbook by making separate copies for the individuais without
network access. Once the users have made their individual changes, Excel can merge
the separate copies of the workbook together into one file. The original file 1s
considered the master and all additional copies of the workbook will be repiicated
into the master. .

The Compare and Merge Workbooks coinmiand is not avaiiable on the Ribbon. To
use this feature vou must add it to the Quick Access toolbar.

Below is an illustration of the Select Files to Merge into Current Workbvook aialog
box:

i
T —— T T T T T T T S L L T T T T e ~ |
7y, My Recent | 1 narks. s i
\— Documents | i} Consobdation.xlsx )
!@Datehst.xisx |
: i
: {
Loyt :
== Documents i
| My ]
e R4 Computer i
i )My Network l
o~ Puaces '
| i
i -
}
;:]Shered‘xh: é
E07e, lor Sales.xis: 3

AN Wikiams. xisx

| Fie name: T S o =
| Fiies of type: (g, el;«t.)r'k;t;;k(‘.xlsx)‘ N - o T

lv Fools 'l | o ] | Canee l !

-~
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Using Pratection and Sharad Workbook rFeatures

£xce! 2010 Interm=diats

Marging Workbooks
F f - -
e o | |
\’G Y 1. Open the master workbool:.
DR ;
]
STEPS | 2. Configure the master workbool: for shared use. if necessary.
3. To setor verify the duration of the change history:
i ¢ Dispiay the Review tab and locate the Changes group:
e Click Share Workbook;
o In the Share Workbool: dialog box. click the Advanced tab:
o Inthe Keep change history for option make sure the time period is iong
: enough to complete the review. Click OK and save the file.
b . . . .
. 4. Copy the master workbook and distribute the copies 1o reviewers. t
3. To add the Compare and nerge Workbooks tool to the Quick Access wolbar:
o (Chck the down arrow next to the Quick Access 1oclbar and select More
Commands:
!
| e Select Commands Not in the Ribbon from tie Choose commiands from
| drop-down list: !
o Select Compare and Merge Workbooks:
o  Click Add. and then click OK.
6. To merge the workbooks once the reviews are complete:

(]

e

Open the master workbook:
On the Quick Access toolbar. click Compare and Merge Workbooks:
select the filza 10 be merged and click OK;

Accept or reject the chianges. as desired.

All changes made to the merged workbooks will be made to the master
workbook one-by-one in tue order that they appear in the dialog box.

Each copv of the master workbool must have a unique name.
The default history duration is 30 days.

Use {Cirl] — click to select multipie non: diacent files. Use - Shift — clicl to
select multiple adjacent files.

The workbooks that vou want to merge into the master cannot be open at
the tme of the merge.

Sharing must be enabled in the master workbook and the history duration
set before tie copies ai: made.

I£ the historv tims period has been exceeded the werkpooks canno be
nerged.

15a
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o

LS}

wh

O

10.

1.

—
th

Wierging Worlizooks
Open the Music2Z workbook.

Change B7to. 500 and add the comment Jane gave me this nsw

Tigure.

Save and close the workbook.

Open the Music workbool:.

Add Compare and Marge Waoribooks to the Quick Access toolbar. if necessary:
e Click the down arrow next to the Quicl: Access toolbar:

e Select More Commuands:;

o Select Commands Not in the Ribbon from the Choose commands jror drop-
down hist:

e Seleet Compare and Merge Workbooks:

e Click Add. and then click OK.

On the Quick Access toolbar. click Compare and ierge Workbooks.
Select Music2 and click OK.

Note the comment in the worlsheet.

Merge Musicd into the current workbook. This will merge & comment into cel!
F10.

Display the Raview wab and locate the Changes group.
Click Track Changes and then seiect Accept/Reject Changes.

Click OK 1o accept the default choices in the Select Changes to Accept or Reject
dialog box.

. Accept all the changes.

&

. Delzte the commenis.
. Save the workbook.

. Save and close any open files.
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